Subject: Re: [Rserpool] ASAP Server Announce

From: Thomas Dreibholz <[email-masked]>
Date: Wed, 1 Sep 2004 17:32:20 +0200

Am Montag, 19. Juli 2004 20:01 schrieb Michael Tuexen:
> But from 
> my point of view, we can add that. What do others think?

Section 2.2.10 of the ASAP draft defines that Transport Parameters in the ASAP 
Server Announce are optional. For the case that the NS is multihomed and 
sends no Transport Parameters, the IP layer uses another source address for 
every network interface. For a PE/PU listening to the NS's announces on 
multiple networks, there is no possiblity to map these different announces to 
this single NS. The PE/PU must assume, that each announcement belongs to a 
different one. But having the NS ID in the announce, mapping the different 
announces to the single NS is trivial.

Adding the NS ID to the ASAP ServerAnnounce is also useful for the case that 
the NS changes its addresses. In this case, a new ServerAnnounce would create 
a new entry in the PE's/PU's server list instead of replacing the old one.

The ASAP ServerAnnounce message format can be as follows:

     0                   1                   2                   3
     0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    |   Type = 0x0a |0|0|0|0|0|0|0|0|        Message Length         |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    |                          Server ID                            |
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    :                       Transport param #1                      :
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    :                       Transport param #2                      :
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    :                                                               :
    :                             .....                             :
    :                                                               :
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
    :                       Transport param #n                      :
    +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Server ID is the 32-bit ENRP server ID.

Best regards
- -- 
=======================================================================
 Dipl.-Inform. Thomas Dreibholz

 University of Essen,                            Room ES210
 Inst. for Experimental Mathematics              Ellernstraße 29
 Computer Networking Technology Group            D-45326 Essen/Germany
- -----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://www.exp-math.uni-essen.de/~dreibh
=======================================================================

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Johnson Walter-CWJ002 <[email-masked]>
Date: Wed, 1 Sep 2004 12:45:46 -0500

I believe the Server ID is also needed. There doesn't seem to be a mechanism for a PE to ever receive the server ID of the Home ENRP Server in either the ENRP Server Hunt procedure or the Registration Procedure. It would be nice to have the ID to fill out the PE parameter during registration instead of all zeroes.

Thomas Dreibholz <> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Section 2.2.10 of the ASAP draft defines that Transport Parameters in
> the ASAP Server Announce are optional. For the case that the NS is
> multihomed and sends no Transport Parameters, the IP layer uses
> another source address for every network interface. For a PE/PU
> listening to the NS's announces on multiple networks, there is no
> possiblity to map these different announces to this single NS. The
> PE/PU must assume, that each announcement belongs to a different one.
> But having the NS ID in the announce, mapping the different announces
> to the single NS is trivial. 
> 
> Adding the NS ID to the ASAP ServerAnnounce is also useful for the
> case that the NS changes its addresses. In this case, a new
> ServerAnnounce would create a new entry in the PE's/PU's server list
> instead of replacing the old one. 
> 
> 
> -
>  -----------------------------------------------------------------------
>  E-Mail:     [email-masked] Homepage:  
> http://www.exp-math.uni-essen.de/~dreibh
> -----BEGIN PGP SIGNATURE----- 
> Version: GnuPG v1.2.4 (GNU/Linux)
> 
> iD8DBQFBNeuE32BbsHYPLWURAkG3AKDK3M+Z77WO9bzKbs3H80lV/pXPggCfX6KN
> plRVbIi4d28VhCLVQWtM3+w=
> =NBgD
> -----END PGP SIGNATURE-----
> 
> [email-masked] https://www1.ietf.org/mailman/listinfo/rserpool