Subject: [Rserpool] Checksum

From: Michael Tuexen <[email-masked]>
Date: Tue, 9 Aug 2005 15:31:57 +0200

Dear all,

we discussed the checksum problem at the IETF and the result of that
discussion is:

1. the 16 bit Internet checksum is sufficient.
2. the 32 bit Internet checksum (and any other 32 bit checksum) may
    result in problems with an IPR filed by Motorola.

Therefore the result is that the use the 16 bit Internet checksum as
described in the current versions of the IDs. Ethereal has been updated.

Best regards
Michael

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Randall Stewart <[email-masked]>
Date: Tue, 23 Aug 2005 08:14:21 -0400

> described in the current versions of the IDs. Ethereal has been updated.

Michael:

I think this is the best approach for two reasons..

a) The checksum is NOT like a transport level checksum
    verify'ing the end2end integrity of the packet. Instead
    it gives the ENRP deamon a "hint" that a problem exists
    in the data it has vs one of its peers. Thus if the
    csum is a bit weak.. it does not matter.. It is a
    far better situation then a weak transport checksum.. and
    as far as that goes... TCP as been using it for years and
    not had that many problems..

b) Using this checksum gives us no worries about the Mot IPR.
    In particular their patent uses addition of port numbers but
    the Cisco IPR lawyer advised me that you wanted to stay
    as far away from anything even similar as possible. In the
    case of the inet() sum we are fairly safe .. unless Mot
    has some IPR that pre-dates TCP :-D

Regards

R

-- 
Randall Stewart
803-345-0369 <or> 815-342-5222(cell)