Subject: RE: [Rserpool] ASAP_ENDPOINT_KEEP_ALIVE

From: Johnson Walter-CWJ002 <[email-masked]>
Date: Tue, 9 Aug 2005 08:16:31 -0500

What is the reasoning?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Dreibholz
Sent: Tuesday, August 09, 2005 7:12 AM
To: [email-masked]
Subject: [Rserpool] ASAP_ENDPOINT_KEEP_ALIVE

Hi all,

draft-ietf-rserpool-asap-12.txt defines for the ASAP_ENDPOINT_KEEP_ALIVE that 
the PH parameter TLV block comes before the fixed Server Identifier. The 
fixed identifier should either be placed before the TLVs or a Server 
Identifier Parameter should to be introduced.

Best regards
- -- 
=======================================================================
 Dipl.-Inform. Thomas Dreibholz

 University of Essen,                            Room ES210
 Inst. for Experimental Mathematics              Ellernstraße 29
 Computer Networking Technology Group            D-45326 Essen/Germany
- -----------------------------------------------------------------------
 E-Mail:     [email-masked]
 Homepage:   http://www.exp-math.uni-essen.de/~dreibh
=======================================================================

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

_______________________________________________
rserpool mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rserpool

---

From: Michael Tuexen <[email-masked]>
Date: Tue, 9 Aug 2005 15:28:10 +0200

Hi all,

I agree with Thomas.

One of the nice features of TLVs is that I can scan them even if I do  
not
understand the types. But this requires that I do know that everything  
is in
TLV. This means that we need to have all parts of a message which are  
not
TLV before all TLVs.

Best regards
Michael

On Aug 9, 2005, at 15:16 Uhr, Johnson Walter-CWJ002 wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hi all,
>
> -  
> -----------------------------------------------------------------------
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.4 (GNU/Linux)
>
> iD8DBQFC+J2T32BbsHYPLWURAkukAJ9rYDYFgjou9PdMpAlY7RcDiszj8gCgtGhY
> vVlB8oUt6sU2CPzEOJF6R50=
> =esq3
> -----END PGP SIGNATURE-----
>

---

From: Michael Tuexen <[email-masked]>
Date: Fri, 12 Aug 2005 11:18:39 +0200

Dear all,

to fix the problem I changed the .xml source of the ASAP ID such that
the server id is now in front of other TLVs.

Best regards
Michael