Subject: Re: [rsvp-dir] RSVP directorate formed

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 08 Jul 2010 15:46:02 +0100

Hello RSVP directorate!

Now that a directorate exists, I'd like help in two ways to manage the 
RSVP work in TSVWG:

1) I'm assuming that you will help with selecting appropriate work for 
adoption of TSVWG (as per the top bullet below). How do you see this 
working, specifically there are a number of drafts that currently have 
not become work items - despite author pleas - while we waited for 
clarification of how to handle RSVP work. Undoubtedly I'll be asked if 
these can become work items. As usual I'll push-back on need to do the 
work, and people to review/contribute to the drafts. Are there current 
drafts know to the directorate that would seem ready and important 
enough that the WG should consider taking these on?

2) Would someone from the directorate like to say "hi we're here and 
this is our remit" - taht would be helpful in the tsvwg meeting!

Gorry

> At 08:01 AM 5/10/2010, Lars Eggert wrote:
>> Hi,
>>
>> following the discussion during the IETF-77 TSVAREA meeting on how to 
>> better review and progress extensions to (non-TE) RSVP and IntServ, 
>> the transport area directors have formed a new RSVP directorate and 
>> given it these tasks:
>>
>>   * Review of all new work related to RSVP and Integrated Services that
>>     is proposed for IETF adoption. The purpose of this review is to
>>     advise the ADs and the chairs of the Transport Area Working Group
>>     (TSVWG) on whether a particular proposal should be taken on as a
>>     work item. The directorate will continue to guide and review such
>>     new work in TSVWG until it is ready for publication as an RFC.
>>
>>   * Review of selected documents during IETF last call or under IESG
>>     review. The directorate monitors ongoing IETF work and should
>>     independently decide when a document will benefit from their review,
>>     assign a reviewer and enter into a follow-on discussion with the
>>     authors. When deemed necessary, the area directors will on occasion
>>     directly consult the directorate while forming their opinion on
>>     selected documents being under review by the IESG.
>>
>>   * Cross-working group review. RSVP documents may have relevance to
>>     several working groups, including TSVWG and MPLS-related groups
>>     such as MPLS WG and CCAMP WG. The directorate will ensure that
>>     drafts submitted to TSV WG are reviewed in the appropriate 
>> MPLS-related
>>     WGs if necessary, and will bring drafts from the MPLS-related WGs
>>     to the attention of the TSV WG as appropriate.
>>
>> The directorate can be reached at [email-masked]. Additional 
>> information about the directorate is at 
>> http://trac.tools.ietf.org/area/tsv/trac/wiki/RSVP-Directorate.
>>
>> Lars
> 
>

---

From: Bruce Davie <[email-masked]>
Date: Thu, 8 Jul 2010 13:05:25 -0400

Gorry,
 I have asked the directorate to start by looking at 3 drafts that have been proposed as WG items:

draft-narayanan-tsvwg-rsvp-resource-sharing-02 

draft-lefaucheur-tsvwg-rsvp-multiple-preemption-02.txt
draft-polk-tsvwg-intserv-multiple-tspec-03.txt

In response to some questions from Bob Briscoe, I then asked all the authors to provide short justifications for why their drafts should be adopted (I can pass these on to you if that would be helpful).

With that information in hand, I have asked the directorate to try to get some reviews done before the upcoming meeting.

Unfortunately, I am unable to attend the meeting in Maastricht. I agree, it would be great if one of the other directorate members were to introduce our little team in the meeting. Any volunteers?

Bruce

On Jul 8, 2010, at 10:46 AM, Gorry Fairhurst wrote:

> 
> Hello RSVP directorate!
> 
> Now that a directorate exists, I'd like help in two ways to manage the RSVP work in TSVWG:
> 
> 1) I'm assuming that you will help with selecting appropriate work for adoption of TSVWG (as per the top bullet below). How do you see this working, specifically there are a number of drafts that currently have not become work items - despite author pleas - while we waited for clarification of how to handle RSVP work. Undoubtedly I'll be asked if these can become work items. As usual I'll push-back on need to do the work, and people to review/contribute to the drafts. Are there current drafts know to the directorate that would seem ready and important enough that the WG should consider taking these on?
> 
> 2) Would someone from the directorate like to say "hi we're here and this is our remit" - taht would be helpful in the tsvwg meeting!
> 
> Gorry
> 
>>> following the discussion during the IETF-77 TSVAREA meeting on how to better review and progress extensions to (non-TE) RSVP and IntServ, the transport area directors have formed a new RSVP directorate and given it these tasks:
>>> 
>>>    drafts submitted to TSV WG are reviewed in the appropriate MPLS-related
>>> The directorate can be reached at [email-masked]. Additional information about the directorate is at http://trac.tools.ietf.org/area/tsv/trac/wiki/RSVP-Directorate.
>>> 
>>> Lars
> 
> _______________________________________________
> rsvp-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rsvp-dir

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 08 Jul 2010 18:28:19 +0100

Thanks Bruce

Yes please do send me the author's rationale for why this is important 
to the WG (that would be helpful).

Is anyone willing to say a few words at the TSVWG meeting (with or 
without slides)?

Gorry

---

From: "David Harrington" <[email-masked]>
Date: Thu, 8 Jul 2010 14:42:05 -0400

Hi,

A few questions.

Is there any progress on 
"RSVP-Directorate-Reviews describes the current guidelines for RSVP
directorate reviewers"?
It would be good to have some consistency to review criteria about
whether a proposal is "worthy".
Will you build this interacively using a wiki, or is somebody going to
take an action item to do this?

How will recommendations about which WG should consider adopting the
drafts be made?
which criteria will be used to justify a recommendation for passing a
draft to a specific WG?
It will obviously be a WG choice to decide whether to adopt a draft.
So will you recommendation be made to the suthor "we think you should
take it to WG XXX" or to the WG "we think the WG should look at draft
XXX, because we think the draft is worthy of considerations and we
think it fits within your WG scope"?

Can we make sure that reviews and supporting documents get posted to
the rsvp-dir archive?
is the rsvp-dir archive private or public?

dbh

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Bruce Davie
> Sent: Thursday, July 08, 2010 1:05 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [rsvp-dir] RSVP directorate formed
> 
> Gorry,
> In response to some questions from Bob Briscoe, I then asked 
> all the authors to provide short justifications for why their 
> drafts should be adopted (I can pass these on to you if that 
> would be helpful).
> 
> With that information in hand, I have asked the directorate 
> to try to get some reviews done before the upcoming meeting.
> 
> Unfortunately, I am unable to attend the meeting in 
> Maastricht. I agree, it would be great if one of the other 
> directorate members were to introduce our little team in the 
> meeting. Any volunteers?
> 
> Bruce
> 
> 
> > 1) I'm assuming that you will help with selecting 
> appropriate work for adoption of TSVWG (as per the top bullet 
> below). How do you see this working, specifically there are a 
> number of drafts that currently have not become work items - 
> despite author pleas - while we waited for clarification of 
> how to handle RSVP work. Undoubtedly I'll be asked if these 
> can become work items. As usual I'll push-back on need to do 
> the work, and people to review/contribute to the drafts. Are 
> there current drafts know to the directorate that would seem 
> ready and important enough that the WG should consider taking 
> these on?
> > 
> > 2) Would someone from the directorate like to say "hi we're 
> here and this is our remit" - taht would be helpful in the 
> tsvwg meeting!
> > 
> > Gorry
> > 
> >>> following the discussion during the IETF-77 TSVAREA 
> meeting on how to better review and progress extensions to 
> (non-TE) RSVP and IntServ, the transport area directors have 
> formed a new RSVP directorate and given it these tasks:
> >>> 
> >>> The directorate can be reached at [email-masked]. 
> Additional information about the directorate is at

---

From: Bruce Davie <[email-masked]>
Date: Wed, 14 Jul 2010 12:56:41 -0400

> A few questions.

Some answers below.

> take an action item to do this?

While we've had discussion on the list about what the criteria are, it hasn't been documented there. I agree that would be good, so I'll put it on my to-do list, but of course other members of the Directorate are welcome to jump in.

I think the criteria will follow from what I asked the authors to provide for the 3 drafts under current consideration, which I include below:

> - What problem with existing RSVP/Intserv are you trying to solve?
> - What class of application will benefit if your draft becomes a standard?
> - Is there another way to solve this problem (or might someone think there is)? If so, explain how your solution is better.
> - What new capability will we have if this draft becomes a standard?
> - What community of users will benefit from this work?

If the directorate feels that the draft solves a real problem, benefits some class of apps & users, doesn't simply replicate another existing solution, etc, then that would I think form the basis for a recommendation to take it to the WG. And of course it should be technically solid enough to start a WG effort (but would not need to be perfect, of course, to start with).

> think it fits within your WG scope"?

I was imagining the latter.

> Can we make sure that reviews and supporting documents get posted to

Sure

> is the rsvp-dir archive private or public?

I would argue for private. Anything that we want to be public should be sent to the appropriate WG, IMHO.

Bruce

---

From: Francois Le Faucheur <[email-masked]>
Date: Tue, 27 Jul 2010 15:26:10 +0200

Hello RSVP Directorate,

Any chance to get an update from RSVP Directorate regarding the submitted RSVP candidate items before TSVWG (Thur am)?

I believe the submitted candidate items are:
	* RSVP Multi-TSPEC/Multi-PREEMPTION
	* RSVP Flexible Resource Sharing

Also, for memory:
	* the meaty part of "draft-narayanan-tsvwg-rsvp-resource-sharing" has been merged into "draft-berger-ccamp-assoc-info"
	* so the latest version of "draft-narayanan-tsvwg-rsvp-resource-sharing" only contains a smaller optional delta on top of "draft-berger-ccamp-assoc-info"
	* the CCAMP plan is that "draft-berger-ccamp-assoc-info" be progressed in CCAMP
	* I believe CCAMP is also proposing to progress "draft-narayanan-tsvwg-rsvp-resource-sharing" as a companion document (this proposal does make sense to me since, again, the real meat is in "draft-berger-ccamp-assoc-info").

It would be good to get  views on this plan.

Thanks

Francois

> 
> On 10 May 2010, at 15:01, Lars Eggert wrote:
> 
>> Hi,
>> 

Francois Le Faucheur
Distinguished Engineer
Corporate Development
[email-masked]
Phone: +33 49 723 2619
Mobile: +33 6 19 98 50 90

Cisco Systems France
Greenside
400 Ave de Roumanille
06410 Sophia Antipolis
France
Cisco.com

 Think before you print.

This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone.

For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Gorry Fairhurst <[email-masked]>
Date: Tue, 27 Jul 2010 15:45:39 +0200

It would indeed be good to get a summary of feedback from the rsvp 
directorate on these 2 drafts - please reply to tsv-ads and 
tsvwg-chairs, if it is appropriate, please also feel free to copy the 
tsvwg list.

My understanding is that this consultation is to provide feedback for 
the ADs and Chairs. These inputs can help to determine if there is 
sufficient interest and a need to adopt a draft. The RSVP directorate 
are not enabled to make a decision on what drafts are adopted.

If the directorate provide comments that support progression it may be 
helpful to also suggest some document reviewers who would commit to 
comment on the document both as it progresses through the WG *and* in 
the WGLC.

Gorry

On 27/07/2010 15:26, Francois Le Faucheur wrote:
> Hello RSVP Directorate,
>
> Any chance to get an update from RSVP Directorate regarding the
> submitted RSVP candidate items before TSVWG (Thur am)?
>
> * the meaty part of "draft-narayanan-tsvwg-rsvp-resource-sharing" has
> been merged into "draft-berger-ccamp-assoc-info"
> * so the latest version of "draft-narayanan-tsvwg-rsvp-resource-sharing"
> only contains a smaller optional delta on top of
> "draft-berger-ccamp-assoc-info"
> * I believe CCAMP is also proposing to progress
> "draft-narayanan-tsvwg-rsvp-resource-sharing" as a companion document
> (this proposal does make sense to me since, again, the real meat is in
> "draft-berger-ccamp-assoc-info").
>
>>> The directorate can be reached at [email-masked]
>>> <mailto:[email-masked]>. Additional information about the
>>> directorate is at
> *
> Francois Le Faucheur*
> *Distinguished Engineer*
> *Corporate Development*
> [email-masked] <mailto:[email-masked]>
> Phone: *+33 49 723 2619*
> Mobile: *+33 6 19 98 50 90*
>
>
> 	
>
> *Cisco Systems France*
> Greenside
> 400 Ave de Roumanille
> 06410 Sophia Antipolis
> France
> Cisco.com <http://www.cisco.com>
>
> 	
>
> Think before you print.
>
> This email may contain confidential and privileged material for the sole
> use of the intended recipient. Any review, use, distribution or
> disclosure by others is strictly prohibited. If you are not the intended
> recipient (or authorized to receive for the recipient), please contact
> the sender by reply email and delete all copies of this message.
>
> Cisco Systems France, Société à responsabiité limitée, Rue Camille
> Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les
> Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur
> de la publication: Jean-Luc Michel Givone.
>

---

From: Bruce Davie <[email-masked]>
Date: Tue, 27 Jul 2010 10:40:22 -0400

Directorate,
 I don't feel I can speak for the directorate at this point, as I have only heard back from Bob Briscoe to date, and only with questions. For the record, I am in favor of the WG adopting the 3 drafts that I asked you to look at, but I'd like to hear from some more directorate members.

Is anyone there?

Bruce

Begin forwarded message:

> From: Gorry Fairhurst <[email-masked]>
> Date: July 27, 2010 9:45:39 AM EDT
> To: Francois Le Faucheur <[email-masked]>
> Cc: [email-masked], "[email-masked] chair" <[email-masked]>, tsvwg WG <[email-masked]>
> Subject: Re: [rsvp-dir] Update from RSVP directorate on RSVP Candidate items?
> Reply-To: [email-masked]
> 
> It would indeed be good to get a summary of feedback from the rsvp directorate on these 2 drafts - please reply to tsv-ads and tsvwg-chairs, if it is appropriate, please also feel free to copy the tsvwg list.
> 
> My understanding is that this consultation is to provide feedback for the ADs and Chairs. These inputs can help to determine if there is sufficient interest and a need to adopt a draft. The RSVP directorate are not enabled to make a decision on what drafts are adopted.
> 
> If the directorate provide comments that support progression it may be helpful to also suggest some document reviewers who would commit to comment on the document both as it progresses through the WG *and* in the WGLC.
> 
> Gorry
>

---

From: Lixia Zhang <[email-masked]>
Date: Sat, 31 Jul 2010 01:02:23 -0700

>  I don't feel I can speak for the directorate at this point, as I have only heard back from Bob Briscoe to date, and only with questions. For the record, I am in favor of the WG adopting the 3 draf…

My sincere apology!

I finally caught up all the exchanges on this list on this train ride to Amsterdam.
I also talked to someone (forgot the name) at IETF about these drafts.
Unfortunately I was unable to make to the TSVWG meeting due to conflict.
I am also in favor of the WG adopting the 3 drafts.

Lixia