Subject: [rsvp-dir] RSVP Directorate Reviews

From: Bruce Davie <[email-masked]>
Date: Wed, 30 Mar 2011 03:57:52 -0400

I met with the TSV ADs on Monday and we talked about how we might make more progress with the RSVP-related drafts that are coming through TSVWG. As you know, the directorate has not to date produced many reviews of the drafts, and the ADs really would like to see more reviews, and promises to review mature drafts, in order to feel confident that the drafts are worth the time and attention of the WG. So, first of all, I'd like to respectfully ask the Directorate members to step up and commit to reviewing these drafts. The 2 drafts that need attention right now are:

draft-polk-tsvwg-intserv-multiple-tspec-06.txt
draft-polk-tsvwg-rsvp-app-id-vv-profiles-02.txt

Many of you have spoken in favor of the former, but AFAIK, only Lou and I have actually provided detailed reviews. Could I ask for one or two more reviewers? Even a promise of a review would be nice.

For the record, I will also review the second draft.

To spread the load around, we should be trying to find people outside the directorate who can do reviews. I have asked Ken Carlberg; can any of you think of, or find, others who might do reviews? If we want to keep RSVP standards in the IETF, we really need a stable of reviewers.

Finally, David Harrington asked me to draw up some review guidelines, so here is my attempt to do that.

A review should address why (or whether) the draft warrants the attention of TSVWG. That justification should cover the following points to the extent possible:
- What problem with existing RSVP/Intserv is the draft trying to solve?
- What class of application will benefit if the draft becomes a standard?
- Is there another way to solve this problem (or might someone think there is)? If so, explain how this solution is better.
- What new capability will we have if this draft becomes a standard?
- What community of users will benefit from this work?

In addition, the review should sanity-check the draft for technical correctness in terms of its relationship to the RSVP and Intserv specifications. 

Thanks.

Bruce Davie

---

From: Lou Berger <[email-masked]>
Date: Wed, 30 Mar 2011 14:47:26 +0200

Bruce/Dave,
	First let me say that review is goodness and I have no issues with
providing input on the suitability for *acceptance* as a WG document
based on technical review.  But I'm left with a couple of questions:

1) It sounds like you are expecting a non-technical / market review of
the drafts by the rsvp-dir.  Is this correct?

2) What work / input do you expect from the WG before a LC is issued for
a document that has gone through the described process?

Much thanks,
Lou

On 3/30/2011 9:57 AM, Bruce Davie wrote:
> _______________________________________________
> rsvp-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rsvp-dir
> 
> 
> 
>

---

From: Bruce Davie <[email-masked]>
Date: Wed, 30 Mar 2011 12:36:14 -0400

> the drafts by the rsvp-dir.  Is this correct?

I would tend to say that the review guidelines I wrote are trying to get at 2 key issues:
 - does this draft tackle a problem worth solving?
 - does it do so in a technically correct way?

So, no, I don't really view this as a non-technical review. But the first question has some not-totally-technical aspects, I guess.

> a document that has gone through the described process?

David (or Gorry) should maybe answer this, but I think they are looking for adequate review from *somewhere*, either the directorate (which contains a lot of RSVP experts) or other WG members (which is the reason I was asking the directorate to try to recruit more reviewers).

It seems to me that the ADs & Chairs are looking for a pretty large number of reviews even before adopting the draft as a WG item, which should mean that any adopted draft should be in fairly good shape.

Bruce

---

From: Lou Berger <[email-masked]>
Date: Wed, 30 Mar 2011 23:58:58 +0200

Bruce,
	Your response is reasonable.  I'd still like to hear from the WG chairs
on question 2 though.

Lou

---

From: Bob Briscoe <[email-masked]>
Date: Thu, 31 Mar 2011 09:58:14 +0100

Bruce,

I have detailed pen-written reviews of:
- rsvp-multiple-preemption-02 (still at 02)
- intserv-multiple-tspec-03 (now at 06)

Back in Sep'11, I should have said I have to go into background mode 
regarding IETF activities for a few months. Since, loads of stuff has 
backed up due to personal & work issues outside my control. I'm out 
of the end of the tunnel now, and eating up the front of the queue so 
that the queue length is now shrinking, but...

Typing these reviews up is now way down my priority stack. If taking 
paper copies away from Prague would be useful, I can offer that at 
least. No-one will be able to understand my scrawlings, but...

Bob

At 17:36 30/03/2011, Bruce Davie wrote:

>So, no, I don't really view this as a non-technical review. But the 
>first question has some not-totally-technical aspects, I guess.
>
> >
>David (or Gorry) should maybe answer this, but I think they are 
>looking for adequate review from *somewhere*, either the directorate 
>(which contains a lot of RSVP experts) or other WG members (which is 
>the reason I was asking the directorate to try to recruit more reviewers).
>
>It seems to me that the ADs & Chairs are looking for a pretty large 
>number of reviews even before adopting the draft as a WG item, which 
>should mean that any adopted draft should be in fairly good shape.
>
>Bruce
>
> >
> > Much thanks,
> > Lou
> >
> >> I met with the TSV ADs on Monday and we talked about how we 
> might make more progress with the RSVP-related drafts that are 
> coming through TSVWG. As you know, the directorate has not to date 
> produced many reviews of the drafts, and the ADs really would like 
> to see more reviews, and promises to review mature drafts, in order 
> to feel confident that the drafts are worth the time and attention 
> of the WG. So, first of all, I'd like to respectfully ask the 
> Directorate members to step up and commit to reviewing these 
> drafts. The 2 drafts that need attention right now are:
> >>
> >> Many of you have spoken in favor of the former, but AFAIK, only 
> Lou and I have actually provided detailed reviews. Could I ask for 
> one or two more reviewers? Even a promise of a review would be nice.
> >>
> >> To spread the load around, we should be trying to find people 
> outside the directorate who can do reviews. I have asked Ken 
> Carlberg; can any of you think of, or find, others who might do 
> reviews? If we want to keep RSVP standards in the IETF, we really 
> need a stable of reviewers.
> >>
> >> Finally, David Harrington asked me to draw up some review 
> guidelines, so here is my attempt to do that.
> >>
> >> A review should address why (or whether) the draft warrants the 
> attention of TSVWG. That justification should cover the following 
> points to the extent possible:
> >> - Is there another way to solve this problem (or might someone 
> think there is)? If so, explain how this solution is better.
> >> In addition, the review should sanity-check the draft for 
> technical correctness in terms of its relationship to the RSVP and 
> Intserv specifications.
> >>
> >> Thanks.
> >>
> >> Bruce Davie
> >>
> >>
> >>

________________________________________________________________
Bob Briscoe,                                BT Innovate & Design

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 31 Mar 2011 15:35:59 +0200

So more on Q2.

I expect these things:

- Keeping-up with revs and comments/wisdom as the draft proceeds, but 
this is "normal" for any WG document.

- Specific people to sign-up for a detailed review of the protocol spec 
at the time when the Authors say this is nearly finish.

- Specific people to sign-up for a detailed review when the Chair starts 
the WGLC process.  I see completeness as a specific issue, especially 
when there has been no tradition of multi-vendor testing for this topic.

- Advice form the directorate as requested by the Chair during IETF LC 
or IESG Discusses.

There have been suggestions for a checklist for RSVP WGLC. I think this 
would be good and I would support such a list. However, there is no 
current push for this as a WG Chair. My best choice would be to try to 
make the "process" work, rather than seeking to perfect the rules.

Gorry

P.S. I'd expect the motivation for the document and case for why the 
work is needed to already be captured from (1) - and I will copy some of 
this directly into the Shepherd Review document after WGLC.

On 30/03/2011 23:58, Lou Berger wrote:
>> It seems to me that the ADs&  Chairs are looking for a pretty large number of reviews even before adopting the draft as a WG item, which should mean that any adopted draft should be in fairly good shape.
>>
>> Bruce
>>
>>>
>>> Much thanks,
>>> Lou
>>>

---

From: Lou Berger <[email-masked]>
Date: Thu, 31 Mar 2011 18:37:50 +0200

Gory,
	Much thanks for the response.  Was your response covering rtg-dir
work/input or WG work/input?  Note my question related to the latter.

Much thanks,
Lou

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 31 Mar 2011 18:58:34 +0200

My hope was the "specific people" I spoke about could be anyone with 
relevant experience, e.g. in TSVWG (but I'd hope that RSVP-DIR would 
step-up if there are no others, that way I'd feel confident the work is 
completed).

I'm not sure whether I deciphered your question correct, you may like to 
try again.

Gorry

On 31/03/2011 18:37, Lou Berger wrote:
> Gorry,
>> - Advice from the directorate as requested by the Chair during IETF LC
>> or IESG Discusses.
>>