Subject: RSVP/traffic control interface

From: "gaetano ferrari" <[email-masked]>
Date: Fri, 10 Dec 1999 12:25:28 +0100

Hi everyone 
I would be grateful if someone could answer my questions.
 
About the set of calls of RSVP/traffic control interface, as specified in the RFC 2205:

the call "Make a Reservation"  (TC_AddFlowspec) establishes a reservation channel on a interface without any session specification;
the successive call "Add Filter Spec" (TC_AddFilter) associates a filter spec and a session specification to an existing reservation.
It is a very general approach ; with these two calls one can add two different session specifications to the same reservation channel , right ?

We can merge these two calls in a less general call that reserves a channel with a session specification and eventually a filter spec ?

I would like to learn more about RSVP/trafic control interface; where could I find other documents ?
 
Thanks in advance
Best regards
-------------------
Ferrari Gaetano
University of Rome "La Sapienza"

---

From: Steven Berson <[email-masked]>
Date: Fri, 10 Dec 1999 11:41:56 -0800 (PST)

On Fri, 10 Dec 1999, gaetano ferrari wrote:

> the call "Make a Reservation"  (TC_AddFlowspec) establishes a
> reservation channel on a interface without any session specification; 
> the successive call "Add Filter Spec" (TC_AddFilter) associates a filter
> spec and a session specification to an existing reservation.  It is a
> very general approach ; with these two calls one can add two different
> session specifications to the same reservation channel , right ? 

I don't have the text in front of me, but that is not the intention.
The intention is that a session specification (IP destination, destination
port, protocol) define a session.  The reservation channel(s) are then
dependent on the type of reservation type (1 for WF, 1 per filterspec
for FF, or S1 for E).

> We can merge these two calls in a less general call that reserves a
> channel with a session specification and eventually a filter spec ? 

Again, I don't have the text in front of me, but that is what SCRAPI does
- take a look at the RSVP web page in publications for more information.

> could I find other documents ? 

Take a look at the implementation section.  The ALTQ code is an
implementation for FreeBSD.  Sun has code for Solaris.  There is code that
can be configured in the Linux kernel.

> Best regards

Regards,
Steve