Subject: RE: Comments on draft-ietf-rsvp-refresh-reduct-02.txt

From: Adrian Farrel <[email-masked]>
Date: Thu, 10 Feb 2000 13:28:45 -0000

Lou Berger wrote...

>>2) Refresh period/ Refresh delay
>>    Section 3 suggests that refresh messages may be delayed up
>>    to their refresh interval. This isn't clear to me.
>>    Are you saying that a refresh message that is generated
>>    _before_ the refresh timer pops can be delayed up until the
>>    time that the timer pops?
>
>yes.  Implicit in this is implementations can take advantage 
>of this but aren't required to.

OK.  Clear now.

>>7) MESSAGE_ID_NACK object
>>    See section 4.3
>>    Is there scope for a reason code?
>
>Scope?  Do you mean room or value?

I meant, is it worth adding a reason code now so that future extensions
don't require a modification of the format of the object.

But then you said...

>I'm not in favor of adding anything to the object that's not 
>needed at this point.  We've been working to minimize 
>features and options.  We can always define a "reason code" 
>object or new c-type if and when the need arises.

OK.

>>9) Message_Identifier value
>>    See section 4.5, para 4...
>>        When a node is sending a trigger message, the
>>        Message_Identifier value MUST have a value that
>>        is greater than any other previously used value.
>>    This is within the scope of the current value of Epoch, right?
>>    Perhaps the text should say so.
>
>I think it's adequately covered by text in the preceding paragraph:
>    The [Epoch] value MUST NOT be changed unless the node or the
>    RSVP agent is restarted.

Not a big issue.  The point I was trying to make is that it is OK to reset
the Message Identifier to 0 when starting with a new Epoch.  The text
actually says "greater than any other previously used value".

Regards,
Adrian

---

From: Lou Berger <[email-masked]>
Date: Thu, 10 Feb 2000 09:01:46 -0500

At 01:28 PM 2/10/00 +0000, Adrian Farrel wrote:
>[...]

Ahh, you're right, I missed your point.  It is valid (although a little 
redundant with the definition of the field).  I'll clarify.

Thanks again for the comments,
Lou