Subject: Re: Sender TSpec on PathTear

From: Bob Braden <[email-masked]>
Date: Tue, 21 Mar 2000 00:52:07 GMT

*> From [email-masked] Mon Mar 20 04:45:27 2000
  *> From: Adrian Farrel <[email-masked]>
  *> To: [email-masked], [email-masked]
  *> Subject: Sender TSpec on PathTear
  *> Date: Mon, 20 Mar 2000 12:32:03 -0000
  *> MIME-Version: 1.0
  *> X-Mailer: Internet Mail Service (5.5.2650.21)
  *> Sender: [email-masked]
  *> Precedence: bulk
  *> X-Lines: 44
  *> 
  *> All,
  *> 
  *> RFC 2205 states that Sender TSpec is mandatory on a PathTear
  *> if a Sender Descriptor is included.
  *> 
  *>     <PathTear Message> ::= <Common Header> [ <INTEGRITY> ]
  *>                            <SESSION> <RSVP_HOP>
  *>                            [ <sender descriptor> ]
  *> 
  *>     <sender descriptor> ::= (see earlier definition)
  *> 

And the very next sentence says, "A PathTear message may include a
SENDER_TSPEC or ADSPEC object in its sender descriptor, but these
must be ignored".

There are several places where the text modulates the BNF, and
this is one of them.  This presentation was chosen for simplicity
and (we thought) clarity, but apparently it failed for you.

Bob Braden

---

From: David Charlap <[email-masked]>
Date: Mon, 20 Mar 2000 22:08:59 -0500

While readining through draft-ietf-rsvp-refresh-reduct-03.txt, I
discovered a problem.

Both the MESSAGE_ID_ACK and MESSAGE_ID_LIST classes have the same value
(24).  They also share some of the same C-Types.

If this is intentional, how are you supposed to know what the object
is?  I hope the meaning of the object isn't meant to be a function of
the router's current state or something.  The way the draft is currently
written, it becomes very difficult to determine what the object really
is, in the context of a stateless device, like a packet sniffer.

-- David

---

From: Lou Berger <[email-masked]>
Date: Tue, 21 Mar 2000 07:46:35 -0500

Hi David,
         You are correct.  That should have been 25.  (Had it that way in 
my request to IANA, see below.)  Please remember that values *may* change 
until assigned by IANA.

Here's what I requested:

>The messages and objects assigned in the draft are:
>
>         Name                    Suggested value
>         ========================================
>Messages:
>         Bundle                  12
>         ACK                     13
>         Srefresh                15
>New objects classes:
>         MESSAGE_ID              23
>         MESSAGE_ID_ACK          24
>         MESSAGE_ID_LIST         25

I've not heard back on the assignments.

Lou