Subject: Re:

From: "David Perez Perez" <[email-masked]>
Date: Fri, 07 Jul 2000 04:56:44 -1300

Hello all

I am using RSVP and CBQ with Linux, and I have some 
questions.
I have the system: sender <--> router <--> receiver
and I have installed:
	Router:	SuSE 6.3, kernel 2.2.13
	Sender, receiver: Red Hat 6.0, kernel 2.2.12-14
	and the packets:	iproute2-current.tar.gz
				rsvpd.rel4.2a4-1.tar.gz

a) Why if I start the rsvp daemon like root it doesn´t 
do UDP encapsulation, and if I start it 
like a user it do UDP encapsulation ? (it happens in 
the 3 machines)

root: # rsvpd -D

	RSVP Version 4.2a4, Compiled....
	Log level:7  Debug mask:7  Start time....
	IPv4 Multicast Daemon is not running
	Physical, Virtual...
	.
	.
	T1>

user: # rsvpd -D	

	RSVP Version 4.2a4, Compiled....
	Log level:7  Debug mask:7  Start time....
	IPv4 Multicast Daemon is not running
	Using UDP encapsulation			(<--- 
¡¡ HERE  !!)
	Physical, Virtual...
	.
	.
	T1>

	Does it refer with Multicast ?

b) If I compile the rsvp daemons with option -DCBQ in 
the Makefile of rsvp, I obtain:

	sender: send PATH messages
	receiver: receive PATH messages
	receiver: send RESV message
	router, sender: when RESV arrive, the rsvp 
daemon does`t work, and appear the next
		message in rsvp.log

		00:07:12.344  ôÎÿ¿ «: errno 
1071644672
		00:07:12.344  ôÎÿ¿ «: errno 
1072168960
		00:07:12.344  ôÎÿ¿ «: errno 
1072431104
		00:07:12.344  ôÎÿ¿ «: errno 
1072562176
		00:07:12.344  ôÎÿ¿ «: errno 
1072627712
		00:07:12.345  ôÎÿ¿ «: errno 
1072660480
		00:07:12.345  ôÎÿ¿ «: errno 
1072676864
		00:07:12.345  ôÎÿ¿ «: errno 
1072685056
		00:07:12.345  ôÎÿ¿ «: errno 
1072689152
		00:07:12.345  ôÎÿ¿ «: errno 
1072691200
		00:07:12.345  ôÎÿ¿ «: errno 
1072692224
		00:07:12.345  ôÎÿ¿ «: errno 
1072692736
		00:07:12.346  ôÎÿ¿ «: errno 
1072692992
		00:07:12.346  ôÎÿ¿ «: errno 
1072693120
		00:07:12.346  ôÎÿ¿ «: errno 
1072693184
		00:07:12.346  ôÎÿ¿ «: errno 
1072693216
		00:07:12.346  ôÎÿ¿ «: errno 
1072693232
		00:07:12.346  ôÎÿ¿ «: errno 
1072693240
		00:07:12.346  ôÎÿ¿ «: errno 
1072693244
		00:07:12.347  ôÎÿ¿ «: errno 
1072693246
		00:07:12.347  ôÎÿ¿ «: errno 
1072693247
		00:07:12.347  ôÎÿ¿ «: errno 
1072693247
		00:07:12.347  ôÎÿ¿ «: errno 
1072693247
		00:07:12.347  ôÎÿ¿ «: errno 
1072693247
		00:07:12.347  ôÎÿ¿ «: errno 
1072693247
		00:07:12.347  ôÎÿ¿ «: errno 
1072693247
		00:07:12.348  ôÎÿ¿ «: errno 
1072693247
		00:07:12.348  ôÎÿ¿ «: errno 
1072693247
		00:07:12.348  ôÎÿ¿ «: errno 
1072693247
		00:07:12.348  ôÎÿ¿ «: errno 
1072693247
		ôÎÿ¿ «: errno 1072693248
		00:07:12.348  Mmm, no policing info?
		00:09:08.341  get_stats

		in the monitor appears also:

		"rsvpd: rsvp_debug.c: 460:log:The 
declaration 'severity==0 || severity>=3'
		 Don`t expire"

	What is happening ?

	I comment the line 460 in rsvp_debug.c, I start 
de daemons, write the commands and it 
	works and does the reserve.

c) The class 1:7fff has 1Mbit (with CBQ), I do a 
reserve of any size (< 1Mbit) and the router
reserve it. It is OK. After I do a reserve of any size 
that add with the previous reserve 
overflow the 1Mbit, the daemon in router and after in 
the sender don`t work. In the monitor
appear:

	RTNETLINK error: Unknown error 4294967100 
get_stats Segmentation fault

	What does it mean?

Thank you very much !!
E-mail: [email-masked]

Tu correo gratis en MixMail http://www.mixmail.com
Inicia tu navegacion en http://www.ya.com

---

From: alfred <[email-masked]>
Date: Fri, 07 Jul 2000 16:00:49 -0300

> like a user it do UDP encapsulation ? (it happens in

::: :::

The rsvp code tries to use the rsvp protocol first, if that fails, it
does udp encapsulation.
To use rsvp, the code must  be able to use the raw interface. On linux,
raw devices may only be opened by root. Hope this addresses your
question.
Alfred D'Souza