Subject: RSVP message-exchange sequence in VoIP session

From: Arie Nimkovsky <[email-masked]>
Date: Tue, 27 Feb 2001 13:05:27 +0200

Hello,

Our BWA (Broadband Wireless Access System) application resides in a bridging
entity and operates on a data-link level. In order to provide layer-2 QoS
for stand-alone VoIP devices at our customer premises, we plan to intercept
RSVP messages exchanged by such devices over the Internet. 

Can you please direct us to documents with a detailed description of RSVP
message-exchange sequence (e.g. in the form of message sequence chart), as
seen and acted by an RSVP receiver and sender. A specific reference to a
VoIP session (how the RSVP message sequence interact with telephone
signalling messages) will be, of course, very helpful.

Thanks,
Arie Nimkovsky
Vyyo Ltd

---

From: Bob Braden <[email-masked]>
Date: Tue, 27 Feb 2001 16:50:53 GMT

*> From [email-masked] Tue Feb 27 03:03:21 2001
  *> From: Arie Nimkovsky <[email-masked]>
  *> To: [email-masked]
  *> Subject: RSVP message-exchange sequence in VoIP session
  *> Date: Tue, 27 Feb 2001 13:03:12 +0200
  *> MIME-Version: 1.0
  *> 
  *> Hello,
  *> 
  *> Our BWA (Broadband Wireless Access System) application resides in a bridging
  *> entity and operates on a data-link level. In order to provide layer-2 QoS
  *> for stand-alone VoIP devices at our customer premises, we plan to intercept
  *> RSVP messages exchanged by such devices over the Internet. 
  *> 
  *> Can you please direct us to documents with a detailed description of RSVP
  *> message-exchange sequence (e.g. in the form of message sequence chart), as
  *> seen and acted by an RSVP receiver and sender. A specific reference to a
  *> VoIP session (how the RSVP message sequence interact with telephone
  *> signalling messages) will be, of course, very helpful.
  *> 
  *> Thanks,
  *> Arie Nimkovsky
  *> Vyyo Ltd
  *> 
  *> 
  *> 

The "Message exchange sequence" model is not appropriate to describing
RSVP operation.  RSVP is, by design, not synchronous in the sense that
this term would imply.  I suggest that you read RFC2205, and you might
also find it helpful to read Lixia Zhang's original academic paper on
RSVP.  The details are not strictly correct, of course, but the general
concepts are there.  That reference and others are on the RSVP
web page www.isi.edu/rsvp.

Bob Braden

---

From: "Rawlins, Diana" <[email-masked]>
Date: Thu, 01 Mar 2001 00:50:43 +0000

Arie,

This doesn't have all the information you requested but you
may find the message charts and discussion of RSVP and
 SIP useful.

http://search.ietf.org/internet-drafts/draft-sinnreich-aaa-interdomain-sip-q
os-osp-00.txt

-Diana

-----Original Message-----
From: Arie Nimkovsky [mailto:[email-masked]]
Sent: Tuesday, February 27, 2001 5:05 AM
To: [email-masked]
Subject: RSVP message-exchange sequence in VoIP session

Hello,

Thanks,
Arie Nimkovsky
Vyyo Ltd