Subject: Re: epoch field in Refresh Reduction RFC (2961)

From: Bob Braden <[email-masked]>
Date: Sun, 9 Sep 2001 19:39:13 -0700 (PDT)

*> From [email-masked]  Thu Sep  6 23:50:55 2001
  *> X-Originating-IP: [63.27.22.48]
  *> From: "manoj juneja" <[email-masked]>
  *> To: [email-masked]
  *> Subject: epoch field in Refresh Reduction RFC (2961)
  *> Date: Thu, 06 Sep 2001 23:49:06 -0700
  *> Mime-Version: 1.0
  *> X-OriginalArrivalTime: 07 Sep 2001 06:49:07.0117 (UTC) FILETIME=[30B24DD0:01C13769]
  *> 
  *> Hi All,
  *>            I have a doubt regarding the epoch value as described in RR RFC. 
  *> If a node receives different epoch value than previously received from the 
  *> neighbor, should the node delete the context of all the message Ids that 
  *> were linked with old epoch value learned previously ? If not, then how can a 
  *> node maintain the context of two different epochs at the same time from the 
  *> same node ?
  *> If the context of all the old message Ids that were linked with old epcoh 
  *> has to be deleted then should the path and reservation states be deleted or 
  *> need to kept without the message ids ?
  *> 
  *> Regards,
  *> manoj.
  *> 
  *> _________________________________________________________________
  *> Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp
  *> 

If the received epoch value changes, then presumably the sender of that
value has been restarted and lost state.  So the sensible thing to do
would seem to be to delete all state associated with the old epoch value.

Whether you delete the old path and resv state or just let it time out
would seem to be an implementor's choice.

Bob Braden

---

From: Ping Pan <[email-masked]>
Date: Sun, 09 Sep 2001 20:48:39 -0700

>  *> need to kept without the message ids ?

Yep.

>would seem to be an implementor's choice.
Actually, if there is an epoch value change, the receiving nodes should 
nack the messages to force the sending node retransmits the full 
messages. This is somewhat important in case of summary refresh messages.

- Ping Pan