Subject: Re:

From: kiran torne <[email-masked]>
Date: Thu, 20 Sep 2001 06:42:47 -0700 (PDT)

hi everbody,
I have my application running on linux (Red Hat 7.0) 
router C . In my application , i have created a raw
socket which blocks to receive datagrams belonging to
a particular protocol id (my own protocol id -- 135). 
That protocol id is not recongised by linux kernel.I
am sending a datagram belonging to protocol id 135
using raw socket from Application on Host A to 
application running on Host B via the router C. The
datagram goes through my router and reaches the
destination C , but my raw socket is not given the
datagram. I have tried setting the router alert option
also. The router application
only gets the datagram when the destination address of
the datagram is the router and not some other third
host.If anybody has tried this out before , can they
give me some hints. I think because that protocol id
is not added to kernel code Please mail me if any more
information is needed. 

Thanks in advance
expect reply soon
regards
kiran

__________________________________________________
Terrorist Attacks on U.S. - How can you help?
Donate cash, emergency relief information
http://dailynews.yahoo.com/fc/US/Emergency_Information/

---

From: Ping Pan <[email-masked]>
Date: Thu, 20 Sep 2001 07:53:00 -0700

> is not added to kernel code Please mail me if any more

Hi,

In my past life, I have written a FreeBSD kernel extension, that would 
allow users to pick up any type of IP option packets. It's a new 
protocol family, PF_IPOPTION, 
(http://www.cs.columbia.edu/~pingpan/software_list.htm). Also wrote a 
new command, ipodump, to test this. The code is for  some older version 
FreeBSD, and port it to the new version should be simple.

I guess you could have poked with with ipfw() to figure out how to 
intercept packets.... (not sure about the performance though).

Good luck!

- Ping