Subject: SOS

From: v sp <[email-masked]>
Date: Wed, 23 Jan 2002 02:06:30 -0800 (PST)

Hi Teams
  Iam new to RSVP.I read rfc-2205.I didnt understand
why rsvp can't be sender initiated.
Ultimately its the sender who has to send the data.A
receiver has to accept the rate at which Sender is
sending otherwise Rx may not be able to process the
data if it reserves for something less than that sent
by sender.
Example
----------
Sender sends at 8Mbps say and Rx reserves for
5Mbps,then Rx may not receive a good QoS as when
compared to the case where Rx reserves 8Mpbs,in which
case reservation shud be sender initiated.Because
sender nows how much bandwidth etc are required and it
reserves that much.Why should Rx shud have a say.

rgds
vsp

__________________________________________________
Do You Yahoo!?
Send FREE video emails in Yahoo! Mail!
http://promo.yahoo.com/videomail/

---

From: Kiran Kumar A <[email-masked]>
Date: Thu, 24 Jan 2002 16:09:51 +0530

Hi,
     sender won't send data with his own speed.
Initially sender and receiver come to an understanding
regarding this reservation of resources using PATH
and RESV messages. Until then data transfer will
not be there.
Sender will know the receiver's speed with his reply
through RESV msg and reserve the bandwidth with which
the receiver can accept. So sender will not send data
with more speed with which receiver cannot accept.
If recerver's speed is more, then anyhow sender cannot
reserve more bandwidth. so there will be no problem at all.

pl confirm the ans with others also.

--
ThanX N Regards,
kiran.

---

From: "Raghavan Chakravarthy" <[email-masked]>
Date: Thu, 24 Jan 2002 16:44:31 +0530

Hi,
When we are talking about multiple receivers, if sender had to maintain a
reservation for each of the receiver in the path, protocol has a scaling
problem. It won't scale for large multicast groups (in a typical multicast
application). This puts a condition that the reservations be receiver
initiated.
-Raghavan

---

From: v sp <[email-masked]>
Date: Thu, 24 Jan 2002 04:12:06 -0800 (PST)

Hi

But if an Application needs 8Mbps whats the use of
reserving 5Mbps in which case receiver may not be able
to play back the data properly.

RSVP is not used for flow control(fast sender-slow Rx)
but to ensure QoS.Isn't it. Pl comment

If an appl needs some B bps bandwidth whats the point
in going for something less and not able to get that
QoS.

thanks
vsp

__________________________________________________
Do You Yahoo!?
Great stuff seeking new owners in Yahoo! Auctions! 
http://auctions.yahoo.com