Subject: RSVP-IP interaction.

From: Madhav Bhamidipati <[email-masked]>
Date: Thu, 24 Jan 2002 16:42:30 +0530 (IST)

Hello,

     Does  RSVP module needs to talk directly to the IP module to provide
a guaranteed service to the Applications? According to my understanding
it has a direct role to play in the IP module, by the way is the packet
scheduler a part of the IP module?

Thanks,
Madhav

---

From: Bob Braden <[email-masked]>
Date: Thu, 24 Jan 2002 17:24:57 GMT

*> From [email-masked]  Thu Jan 24 03:06:52 2002
  *> X-Authentication-Warning: brahma.roc.com: madhavb owned process doing -bs
  *> Date: Thu, 24 Jan 2002 16:42:30 +0530 (IST)
  *> From: Madhav Bhamidipati <[email-masked]>
  *> X-Sender: [email-masked]
  *> To: [email-masked]
  *> Subject: RSVP-IP interaction.
  *> MIME-Version: 1.0
  *> X-AntiVirus: scanned by AMaViS 0.2.1
  *> 
  *> 
  *> Hello,
  *> 
  *>      Does  RSVP module needs to talk directly to the IP module to provide
  *> a guaranteed service to the Applications? According to my understanding
  *> it has a direct role to play in the IP module, by the way is the packet
  *> scheduler a part of the IP module?
  *> 
  *> Thanks,
  *> Madhav
  *> 
  *> 
  *> 

The packet scheduler is in the packet forwarding path.  If that is
what you mean by the "IP module", then the answer is Yes.

Bob Braden