Subject: RE: Imposing QoS on existing flows

From: Offenbacker Chad E DLVA <[email-masked]>
Date: Thu, 12 Sep 2002 12:07:23 -0400

Mr. Berson,
Thanks for the quick response.  I will clear up my question by restating it.
Given a regular UDP/TCP data flow (WITHOUT sessions and reservations being
setup) between 2 hosts that each have a RSVP daemon running in the
background, can QoS then be requested and imposed on this data flow???

Many thanks,
Chad Offenbacker

-----Original Message-----
From: Steven Berson [mailto:[email-masked]]
Sent: Thursday, September 12, 2002 11:52 AM
To: Offenbacker Chad E DLVA
Cc: [email-masked]
Subject: Re: Imposing QoS on existing flows

Chad,

If you are asking whether an RSVP-enabled application can start
requesting QoS after the data has started flowing, the answer is yes.

Regards,
Steve

On Thu, 12 Sep 2002, Offenbacker Chad E DLVA wrote:

> Mr. Berson:
> I have been working with RSVP and RAPI for several months and a particular
> question has come to mind regarding reservation setup.
> Can RSVP/RAPI be used to establish a reservation for a UDP/TCP data flow
> that already exists??? (Imposing a QoS on an existing data flow)
> Please let me know if this is possible.
> 
> Many thanks,
> Chad Offenbacker
> Scientist
> NSWC-Dahlgren Division
> [email-masked]
> 
>

---

From: Steven Berson <[email-masked]>
Date: Thu, 12 Sep 2002 09:14:20 -0700 (PDT)

Chad,

The answer is yes.  As far as the routers are concerned, the flow of 
data and the establishment of reservations are completely decoupled.  
So you can make (or terminate) a reservation at any time, and you can 
send (or stop sending) data at any time.

Regards,
Steve