Subject: Re: Rtg-bfd Digest, Vol 178, Issue 5

From: Reshad Rahman <[email-masked]>
Date: Tue, 23 Feb 2021 22:15:47 -0500

Hi Albert,

Apologies for the delay in replying.

I believe (no hat) that there is value in adding counters to expose drop-related info. We should look into augmenting the BFD YANG model, not sure whether we should add that in the stability draft… I would like to hear from the WG.

Regards,

Reshad. 

From: Rtg-bfd <[email-masked]> on behalf of "Albert Fu (BLOOMBERG/ 120 PARK)" <[email-masked]>
Reply-To: Albert Fu <[email-masked]>
Date: Sunday, January 31, 2021 at 2:06 PM
To: <[email-masked]>
Subject: Re:Rtg-bfd Digest, Vol 178, Issue 5

Hi,

1. Re: New Version Notification for
draft-ietf-bfd-stability-07.txt (Reshad Rahman)

This feature is good to have. As a matter of fact, we have been trying to get vendors to expose BFD counters as we know links from carriers do drop packets without any indication of errors, and the basic send/receive counters are not reliable indicators, since the timers are randomized up to 25% lower.

The draft talks about geneation of diagnostic info but no details. I would think syslog is not practical for large network. What do you think about mentioning keeping counters of missing seq numbers, and have these counters exposed to telemetry/snmp? This would be very useful to us.

Thanks

Albert

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 24 Feb 2021 19:54:32 -0800

Hi Reshad,

> On Feb 23, 2021, at 7:15 PM, Reshad Rahman <reshad=[email-masked]> wrote:
> 
> Hi Albert,
>  

+1

Done. However, the document now needs a YANG Doctor review. Do you think you can take a quick review of it?

>> The draft talks about geneation of diagnostic info but no details. I would think syslog is not practical for large network. What do you think about mentioning keeping counters of missing seq numbe…

Mahesh Jethanandani
[email-masked]

---

From: Reshad Rahman <[email-masked]>
Date: Thu, 25 Feb 2021 18:13:06 -0500

Hi Mahesh,

Thanks for doing the update. Yes, I can do the review.

Regards,

Reshad.

From: Rtg-bfd <[email-masked]> on behalf of Mahesh Jethanandani <[email-masked]>
Date: Wednesday, February 24, 2021 at 10:54 PM
To: Reshad Rahman <reshad=[email-masked]>
Cc: "rtg-bfd@ietf. org" <[email-masked]>, Albert Fu <[email-masked]>
Subject: Re: Rtg-bfd Digest, Vol 178, Issue 5

Hi Reshad,

Hi Albert,

+1

 

Regards,

Reshad. 

Hi,

Thanks

Albert

Mahesh Jethanandani

[email-masked]