Subject: [Rtg-dt-encap-considerations] Edits? Slides? Open Issues?

From: Erik Nordmark <[email-masked]>
Date: Wed, 18 Feb 2015 11:33:18 -0800

I've been working on both the text and the slides.

Document:
Some set of sections in the document are tagged with [Erik - please 
review] which means I think they are ready. I have not touched the 
sections which have Jesse, Tom, Pat/Albert's name on them. Still need an 
owner for the OAM section. Larry, did you volunteer for some section?

Slides:
Still working on them. I think I'll manage to summarize all sections of 
the document *except* the hardware friendly section.
Thus we should talk about what the hardware friendly summary would say 
in one (or two) slides.

*In addition to talking about the slides tomorrow, it would make sense 
to touch upon this technical open issue:*

  *

    There is discussion about timestamps, sequence numbers, etc in three
    different parts of the document. OAM, Congestion Considerations, and
    Service Model, where the latter argues that a PWE3 service should
    really be layered on top of the encaps using its own header. Those
    recommendations seem to be at odds with each other. Do we envision
    sequence numbers, time stamps, etc as potential extensions for OAM
    and CC? If so, those extensions could be used to provide a service
    which doesn’t reorder packets.

*

*There is also an editoria**l open issue in where we place text about 
middlebox considerations. C**urrently **text about middleboxes appears 
in different sections.*

*   Erik**
*

*

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Thu, 19 Feb 2015 00:03:36 +0000

Hi Erik,

I volunteered to help Pat and Albert if they needed any on the hardware considerations section.  I am not an expert (by any means) on OAM, but I know people who are.  I could (with a lot of their help) sign up for the OAM section.

 - Larry

From: Erik Nordmark <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, February 18, 2015 11:33 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Rtg-dt-encap-considerations] Edits? Slides? Open Issues?

Document:
Some set of sections in the document are tagged with [Erik - please review] which means I think they are ready. I have not touched the sections which have Jesse, Tom, Pat/Albert's name on them. Still need an owner for the OAM section. Larry, did you volunteer for some section?

Slides:
Still working on them. I think I'll manage to summarize all sections of the document *except* the hardware friendly section.
Thus we should talk about what the hardware friendly summary would say in one (or two) slides.

In addition to talking about the slides tomorrow, it would make sense to touch upon this technical open issue:

  *   There is discussion about timestamps, sequence numbers, etc in three different parts of the document. OAM, Congestion Considerations, and Service Model, where the latter argues that a PWE3 service should really be layered on top of the encaps using its own header. Those recommendations seem to be at odds with each other. Do we envision sequence numbers, time stamps, etc as potential extensions for OAM and CC? If so, those extensions could be used to provide a service which doesn’t reorder packets.

There is also an editorial open issue in where we place text about middlebox considerations. Currently text about middleboxes appears in different sections.

   Erik

---

From: Jon Hudson <[email-masked]>
Date: Thu, 19 Feb 2015 02:37:42 -0800

greetings all..

I made some very small edits.  I added some illustrations to help folks
remember the slides.

I also combined 2 slides into 1 as an example, slide 9 (I think)  is a
combo of slide 10 and 11. Just an idea for how you can reduce the slides.
Make the 12 steps 6 slides, instead of 12.

Jon

On Wed, Feb 18, 2015 at 4:03 PM, Larry Kreeger (kreeger) <[email-masked]>
wrote:

>  Hi Erik,
>
>  I volunteered to help Pat and Albert if they needed any on the hardware
> considerations section.  I am not an expert (by any means) on OAM, but I
> know people who are.  I could (with a lot of their help) sign up for the
> OAM section.
>
>   - Larry
>
>   From: Erik Nordmark <[email-masked]>
> To: "[email-masked]" <
> [email-masked]>
> review] which means I think they are ready. I have not touched the sections
> which have Jesse, Tom, Pat/Albert's name on them. Still need an owner for
> the OAM section. Larry, did you volunteer for some section?
>
> Slides:
> *In addition to talking about the slides tomorrow, it would make sense to
> touch upon this technical open issue:*
>
>    -
>
>    Service Model, where the latter argues that a PWE3 service should really be
>    layered on top of the encaps using its own header. Those recommendations
>    seem to be at odds with each other. Do we envision sequence numbers, time
>    stamps, etc as potential extensions for OAM and CC? If so, those extensions
>    could be used to provide a service which doesn’t reorder packets.
>
>
>
>
> * There is also an editorial open issue in where we place text about
> middlebox considerations. Currently text about middleboxes appears in
> different sections.    Erik *
>
> _______________________________________________
> Rtg-dt-encap-considerations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtg-dt-encap-considerations
>
>

-- 
"Do not lie. And do not do what you hate."

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 19 Feb 2015 07:32:30 -0800

On 2/18/15 4:03 PM, Larry Kreeger (kreeger) wrote:
> Hi Erik,
>
> I volunteered to help Pat and Albert if they needed any on the 
> hardware considerations section.  I am not an expert (by any means) on 
> OAM, but I know people who are.  I could (with a lot of their help) 
> sign up for the OAM section.

I think the OAM section is mostly about editing the words into something 
readable. I can make a pass at that if you prefer.

    Erik

>
>  - Larry
>
> From: Erik Nordmark <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] 
> <mailto:[email-masked]>" 
> <[email-masked] 
> <mailto:[email-masked]>>
> sections which have Jesse, Tom, Pat/Albert's name on them. Still need 
> an owner for the OAM section. Larry, did you volunteer for some section?
>
> Slides:
> Still working on them. I think I'll manage to summarize all sections 
> of the document *except* the hardware friendly section.
>     There is discussion about timestamps, sequence numbers, etc in
>     three different parts of the document. OAM, Congestion
>     Considerations, and Service Model, where the latter argues that a
>     PWE3 service should really be layered on top of the encaps using
>     its own header. Those recommendations seem to be at odds with each
>     other. Do we envision sequence numbers, time stamps, etc as
>     potential extensions for OAM and CC? If so, those extensions could
>     be used to provide a service which doesn’t reorder packets.
>
> *
>

---

From: Tom Herbert <[email-masked]>
Date: Thu, 19 Feb 2015 08:13:48 -0800

I think we need a slide on checksums, there has been a lot of work on
this-- not just for zero checksum in IPv6 but also use in IPv4. MPLS/UDP
draft ended up having a lot of requirements on zero UDP checksum in IPv6,
we expanded that in GRE/UDP (with some requirements for IPv4). Also, both
of these have a lot of requirements around congestion considerations that
might be useful.

Tom

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 19 Feb 2015 11:34:00 -0800

On 2/19/15 8:13 AM, Tom Herbert wrote:
> this-- not just for zero checksum in IPv6 but also use in IPv4. 
> MPLS/UDP draft ended up having a lot of requirements on zero UDP 
> checksum in IPv6, we expanded that in GRE/UDP (with some requirements 
> for IPv4). Also, both of these have a lot of requirements around 
> congestion considerations that might be useful.

Didn't see this email before the call.

Can you check and add comments to the IPv6 header protection. Or update 
the slide to cover IPv4 checksums?

Thanks,
    Erik

>
> Tom
>
>
> On Wed, Feb 18, 2015 at 11:33 AM, Erik Nordmark <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Some set of sections in the document are tagged with [Erik -
>     please review] which means I think they are ready. I have not
>     touched the sections which have Jesse, Tom, Pat/Albert's name on
>     them. Still need an owner for the OAM section. Larry, did you
>     volunteer for some section?
>
>     Slides:
>     Still working on them. I think I'll manage to summarize all
>     sections of the document *except* the hardware friendly section.
>     *In addition to talking about the slides tomorrow, it would make
>     sense to touch upon this technical open issue:*
>
>      *
>
>         Considerations, and Service Model, where the latter argues
>         that a PWE3 service should really be layered on top of the
>         encaps using its own header. Those recommendations seem to be
>         at odds with each other. Do we envision sequence numbers, time
>         stamps, etc as potential extensions for OAM and CC? If so,
>         those extensions could be used to provide a service which
>         doesn’t reorder packets.
>
>     *
>
>     *There is also an editoria**l open issue in where we place text
>     about middlebox considerations. C**urrently **text about
>     middleboxes appears in different sections.*
>
>     *   Erik**
>     *
>
>     *
>
>     <mailto:[email-masked]>

---

From: Albert Tian <[email-masked]>
Date: Thu, 19 Feb 2015 19:44:08 +0000

Hi Larry,

That would be really great!

I spent couple of hours yesterday but was struggling on what would be right level of considerations. We don’t want to be biased to any specific hardware, which would be politically incorrect.

Maybe we can setup a separate call on this section?

Thanks,
Albert

From: "Larry Kreeger (kreeger)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, February 18, 2015 at 4:03 PM
To: Erik Nordmark <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-dt-encap-considerations] Edits? Slides? Open Issues?

Hi Erik,

 - Larry

Document:

Slides:

   Erik

---

From: Tom Herbert <[email-masked]>
Date: Thu, 19 Feb 2015 14:00:20 -0800

I think slide #7 is mostly unnecessary, these seems to be covered by other
slide.

Slide #21 is a little unclear. I think we should just say that the service
model of IP encapsulation is the same as IP or UDP (can be reordered,
lossy, unreliable protocol)-- these are higher layer protocols. CC is the
exception to this but I think we have a good case this is needed in the
encapsulation because of the detrimental effects to unrelated traffic.

Maybe middlebox considerations can replace service model in the twelve
steps?

Tom

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Thu, 19 Feb 2015 22:04:15 +0000

Hi Albert,

While I agree that we can't point to a specific piece of hardware, I think we can address general categories, e.g. NICs and switches, as well as point out different types of implementations, such as those using microcoded Network Processors and ones that use cut-through for low latency.  I'm open to a call.

 - Larry

From: Albert Tian <[email-masked]<mailto:[email-masked]>>
Date: Thursday, February 19, 2015 11:44 AM
To: Larry Kreeger <[email-masked]<mailto:[email-masked]>>, Erik Nordmark <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-dt-encap-considerations] Edits? Slides? Open Issues?

Hi Larry,

Thanks,
Albert

Hi Erik,

 - Larry

Document:

Slides:

   Erik

---

From: Jon Hudson <[email-masked]>
Date: Thu, 19 Feb 2015 14:12:40 -0800

Seems a topic worth one

Would love to join as well

> On Feb 19, 2015, at 2:04 PM, Larry Kreeger (kreeger) <[email-masked]> wrote:
> 
> Hi Albert, 
> 
> From: Albert Tian <[email-masked]>
> To: Larry Kreeger <[email-masked]>, Erik Nordmark <[email-masked]>, "[email-masked]" <[email-masked]>
> From: "Larry Kreeger (kreeger)" <[email-masked]>
> To: Erik Nordmark <[email-masked]>, "[email-masked]" <[email-masked]>
> To: "[email-masked]" <[email-masked]>
>  There
>  is discussion about timestamps, sequence numbers, etc in three different parts of the document. OAM, Congestion Considerations, and Service Model, where the latter argues that a PWE3 service should really be layered on top of the encaps using its own header.
>  Those recommendations seem to be at odds with each other. Do we envision sequence numbers, time stamps, etc as potential extensions for OAM and CC? If so, those extensions could be used to provide a service which doesn’t reorder packets.