Subject: [Rtg-dt-encap-considerations] FYI: draft-rtg-dt-encap-01 & TSV in Dallas

From: Erik Nordmark <[email-masked]>
Date: Mon, 09 Mar 2015 23:24:34 -0700

-------- Forwarded Message --------
Subject: 	draft-rtg-dt-encap-01 & TSV in Dallas
Date: 	Tue, 10 Mar 2015 06:05:10 +0000
From: 	Black, David <[email-masked]>
To: 	Erik Nordmark <[email-masked]>, Alia Atlas <[email-masked]>
CC: 	[email-masked] <[email-masked]>, [email-masked] 
<[email-masked]>, Black, David <[email-masked]>

Erik,

> On 3/9/15 6:00 PM, Black, David wrote:
> >
> > > Please take a read through.  It will be discussed in rtgwg.
> >
> > Bother - as a tsvwg chair, I won’t be in rtgwg :-(.
> >
>
> The design team might accept invitations to speak about it elsewhere ;-)
>
> In fact we are doing a short version at the NVO3 interim this Friday.
>
>     Erik

I'll be on the phone for NVO3 on Friday.  I've cc:'d my tsvwg co-chair
(Gorry) and the TSV ADs to consider which TSV invitation we should extend,
as at least the following 5 sections of the draft are relevant to TSV:

    7.  Entropy  . . . . . . . . . . . . . . . . . . . . . . . . . . .  7

    9.  MTU and Fragmentation  . . . . . . . . . . . . . . . . . . . . 10

    12. QoS  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
    13. Congestion Considerations  . . . . . . . . . . . . . . . . . . 16
    14. Header Protection  . . . . . . . . . . . . . . . . . . . . . . 18

UDP usage concerns are lurking behind both the Entropy and Header Protection
topics (e.g., 5-tuple hash behavior, UDP zero checksum for IPv6, respectively).

My initial inclination is to invite a short TSV-oriented discussion into the
Tuesday afternoon TSVWG session, and arrange for the GRE-in-UDP draft to be
taken up in that same session.  The only RTG WG in that time slot is IDR,
which should not pose a content conflict concern.  If Alia wants to observe
in person (as she's the AD for IDR), we can bash both WG agendas so she can
be in the right room at the right time for the important topics.

That said, I'll give my honorable TSV ADs first shot at whether they'd like
to pull this encap discussion into TSVAREA, probably the Monday session so
that the TSV discussion comes before the RTG discussion.

Thoughts?

Thanks,
--David

> >
> > *From:*routing-discussion [mailto:[email-masked]]
> > *On Behalf Of *Alia Atlas
> > *Sent:* Monday, March 09, 2015 8:43 PM
> > *To:* [email-masked]; [email-masked]
> > *Subject:* Fwd: [nvo3] Fwd: New Version Notification for
> > draft-rtg-dt-encap-01.txt
> >
> > This is the internet-draft produced by the Data-Plane encapsulation
> > design team
> >
> > that started at the last IETF.
> >
> > Please take a read through.  It will be discussed in rtgwg.
> >
> > Thanks,
> >
> > Alia
> >
> >
> >
> > -------- Forwarded Message --------
> > Subject:        New Version Notification for draft-rtg-dt-encap-01.txt
> > Date:   Mon, 09 Mar 2015 15:51:45 -0700
> > From: [email-masked] <mailto:[email-masked]>
> > To:     Jon Hudson <[email-masked]
> > <mailto:[email-masked]>>, Tom Herbert <[email-masked]
> > <mailto:[email-masked]>>, Lawrence Kreeger <[email-masked]
> > <mailto:[email-masked]>>, Patricia Thaler <[email-masked]
> > <mailto:[email-masked]>>, Patricia Thaler <[email-masked]
> > <mailto:[email-masked]>>, Jon Hudson <[email-masked]
> > <mailto:[email-masked]>>, Albert Tian <[email-masked]
> > <mailto:[email-masked]>>, Jesse Gross <[email-masked]
> > <mailto:[email-masked]>>, Albert Tian <[email-masked]
> > <mailto:[email-masked]>>, Pankaj Garg <[email-masked]
> > <mailto:[email-masked]>>, Pankaj Garg <[email-masked]
> > <mailto:[email-masked]>>, Tom Herbert <[email-masked]
> > <mailto:[email-masked]>>, Jesse Gross <[email-masked]
> > <mailto:[email-masked]>>, Erik Nordmark <[email-masked]
> > <mailto:[email-masked]>>, Lawrence Kreeger <[email-masked]
> > <mailto:[email-masked]>>, Erik Nordmark <[email-masked]
> > <mailto:[email-masked]>>
> >
> >
> >
> > A new version of I-D, draft-rtg-dt-encap-01.txt
> > has been successfully submitted by Erik Nordmark and posted to the
> > IETF repository.
> >
> > Name:           draft-rtg-dt-encap
> > Revision:       01
> > Title:          Encapsulation Considerations
> > Document date:  2015-03-09
> > Group:          Individual Submission
> > Pages:          37
> > URL: http://www.ietf.org/internet-drafts/draft-rtg-dt-encap-01.txt
> > Status: https://datatracker.ietf.org/doc/draft-rtg-dt-encap/
> > Htmlized: http://tools.ietf.org/html/draft-rtg-dt-encap-01
> > Diff: http://www.ietf.org/rfcdiff?url2=draft-rtg-dt-encap-01
> >
> > Abstract:
> >    The IETF Routing Area director has chartered a design team to look at
> >    common issues for the different data plane encapsulations being
> >    discussed in the NVO3 and SFC working groups and also in the BIER
> >    BoF, and also to look at the relationship between such encapsulations
> >    in the case that they might be used at the same time.  The purpose of
> >    this design team is to discover, discuss and document considerations
> >    across the different encapsulations in the different WGs/BoFs so that
> >    we can reduce the number of wheels that need to be reinvented in the
> >    future.
> >
> >
> >
> > Please note that it may take a couple of minutes from the time of
> > submission
> > until the htmlized version and diff are available at tools.ietf.org
> > <http://tools.ietf.org>.
> >
> > The IETF Secretariat
> >
> >
> >
> > _______________________________________________
> > nvo3 mailing list
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/nvo3
> >

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 10 Mar 2015 09:29:02 -0700

> be in the right room at the right time for the important topics.

I don't have any conflicts in that slot. FWIW it has
INT 6lo
OPS anima
OPS dnsop
RAI ecrit
RTG idr
SEC dots
TSV tsvwg

	

	

	

	

> that the TSV discussion comes before the RTG discussion.

The Monday TSVAREA conflicts with NVO3, which is an issue for myself 
and, I suspect, many of the other design team members.

   Erik

---

From: Alia Atlas <[email-masked]>
Date: Wed, 11 Mar 2015 10:57:04 -0400

I'll try and duck out of IDR for it.  I'll have to check the agendas.

On Wed, Mar 11, 2015 at 10:55 AM, Black, David <[email-masked]> wrote:

>  Ok, we’ll find time for this in TSVWG on Tuesday.
>
>
>
> Thanks,
> --David
>
>
>
> *From:* Spencer Dawkins at IETF [mailto:[email-masked]]
> *Sent:* Wednesday, March 11, 2015 8:59 AM
> *To:* Erik Nordmark
> *Cc:* [email-masked]; [email-masked]; Black, David;
> [email-masked]; Alia Atlas
> *Subject:* Re: draft-rtg-dt-encap-01 & TSV in Dallas
>
>
>
> Hi, Erik and David,
>
> I would be fine with David and Gorry bringing this to TSVWG.
>
> I agree that TSVAREA needs to see it if we can work that out, but that can
> take a back seat, especially if at least a couple of RTG design team
> members can come to TSVWG.
>
> If that happens, David, do you think sending a heads up to the TSVAREA
> list would be helpful?
>
> I suppose most folk who would flip out in TSVAREA would be in TSVWG anyway
> :-)
>
> Spencer
>
> On Mar 10, 2015 11:29 AM, "Erik Nordmark" <[email-masked]> wrote:
> >

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 11 Mar 2015 07:59:27 -0500

Hi, Erik and David,

If that happens, David, do you think sending a heads up to the TSVAREA list
would be helpful?

Spencer

On Mar 10, 2015 11:29 AM, "Erik Nordmark" <[email-masked]> wrote:
> The Monday TSVAREA conflicts with NVO3, which is an issue for myself and,
I suspect, many of the other design team members.

---

From: "Black, David" <[email-masked]>
Date: Wed, 11 Mar 2015 14:55:49 +0000

Thanks,
--David

From: Spencer Dawkins at IETF [mailto:[email-masked]]
Sent: Wednesday, March 11, 2015 8:59 AM
To: Erik Nordmark
Cc: [email-masked]; [email-masked]; Black, David; [email-masked]; Alia Atlas
Subject: Re: draft-rtg-dt-encap-01 & TSV in Dallas

Hi, Erik and David,

I agree that TSVAREA needs to see it if we can work that out, but that can take a back seat, especially if at least a couple of RTG design team members can come to TSVWG.

If that happens, David, do you think sending a heads up to the TSVAREA list would be helpful?

I suppose most folk who would flip out in TSVAREA would be in TSVWG anyway :-)

Spencer

On Mar 10, 2015 11:29 AM, "Erik Nordmark" <[email-masked]<mailto:[email-masked]>> wrote:
> The Monday TSVAREA conflicts with NVO3, which is an issue for myself and, I suspect, many of the other design team members.
>
>   Erik
>
>>
>> Thoughts?
>>
>> Thanks,
>> --David
>>
>>>> *From:*routing-discussion [mailto:[email-masked]<mailto:[email-masked]>]
>>>> *To:* [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
>>>> From: [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>>>> To:     Jon Hudson <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Tom Herbert <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Lawrence Kreeger <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Patricia Thaler <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Patricia Thaler <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Jon Hudson <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Albert Tian <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Jesse Gross <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Albert Tian <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Pankaj Garg <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Pankaj Garg <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Tom Herbert <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Jesse Gross <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Erik Nordmark <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Lawrence Kreeger <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>, Erik Nordmark <[email-masked]<mailto:[email-masked]>
>>>> <mailto:[email-masked]<mailto:[email-masked]>>>
>>>>
>>>>
>>>>
>>>> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>
>>>> <http://tools.ietf.org>.
>>>>
>>>> The IETF Secretariat
>>>>
>>>>
>>>>
>>>> [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>