Subject: Re: [Rtg-dt-encap-considerations] Dallas - draft agenda, speakers, and slides!!

From: Erik Nordmark <[email-masked]>
Date: Mon, 16 Mar 2015 13:17:53 -0700

David,

do the attached slides cover the set up topics you see as relevant for 
TSVWG?
Are there things we can omit such as the next protocol one?

Thanks,
    Erik

On 3/16/15 10:52 AM, Black, David wrote:
> The initial draft agenda for the tsvwg Dallas meetings has been uploaded:
>
> http://www.ietf.org/proceedings/92/agenda/agenda-92-tsvwg
>
> Suggestions for changes are welcome.
>
> If your name appears on the agenda as a presenter or "(TBD)" appears
> next to your draft, we need a confirmation of who will be presenting
> - please send email to [email-masked] (it's ok to change
> presenter name - these are our best guesses).
>
> We (chairs) have accommodated all the time requests that we know
> about - if there are additional time requests, please send an email
> to [email-masked] with the filename and title of the
> draft, speaker's name and time requested.
>
> Please note that meeting time will be tight in Dallas - 110min of
> each 120min session is currently scheduled, so offers to yield time
> in advance will definitely be appreciated (e.g., if some of the
> 20min time slots on Thursday only need 10min).
>
> Slides will be due by midnight Sunday in Dallas for both sessions.
>
> Thanks,
> --David
> ----------------------------------------------------
> David L. Black, Distinguished Engineer
> EMC Corporation, 176 South St., Hopkinton, MA  01748
> +1 (508) 293-7953             FAX: +1 (508) 293-7786
> [email-masked]        Mobile: +1 (978) 394-7754
> ----------------------------------------------------
>

---

From: "Black, David" <[email-masked]>
Date: Mon, 16 Mar 2015 20:51:08 +0000

Erik,

The slides generally look good, and I'm actually going to suggest adding a couple of topics:

- 9 Extensibility: Congestion control is mentioned.
- 10 Layering of multiple encaps: Transport folks care about effects of X-in-Y-in-Z,
		particularly when there's a layer 4 protocol involved in each of them.
		MTU and ECN are two reasons why.

On balance, I think the next header topic can come out unless it's needed to set up the Layering topic.

Here are a few other things that I noticed:

- I wonder whether the word "transport" is always being used in a TSV sense.  I saw at least
	one place (slide 4) where it may have been used in an MPLS (MPLS-TP ?) sense. TSV does
	not consider MPLS to be a "transport" protocol in the TSV sense, if that helps.
- As this is not an RTG meeting, explain what NVO3, SFC and BIER are before putting up slide 7.
- The words "Congestion management" in the middle bullet on slide 8 *will* get you into trouble ;-).
	I don't think this is congestion management; it appears to be primarily traffic engineering
	and related operational traffic management for congestion avoidance.  The MPLS-in-UDP draft
	may contain some useful language to talk about this.
- The last bullet on slide 11 did not parse for me, sorry.

Thanks,
--David

> -----Original Message-----
> From: Erik Nordmark [mailto:[email-masked]]
> Sent: Monday, March 16, 2015 4:18 PM
> Cc: Black, David; [email-masked]; tsvwg-
> [email-masked]
> Subject: Re: Dallas - draft agenda, speakers, and slides!!
> 
> 
> David,
>

---

From: Erik Nordmark <[email-masked]>
Date: Mon, 16 Mar 2015 14:28:07 -0700

> 		MTU and ECN are two reasons why.
OK
> On balance, I think the next header topic can come out unless it's needed to set up the Layering topic.
Right now it looks useful for setup.
> 	not consider MPLS to be a "transport" protocol in the TSV sense, if that helps.

I think it never means TCP/UDP in this slide set, but instead means the 
underlying frame delivery. We'll have hand out (rose-colored?) glasses 
in TSVWG to make the reader see the terms they expect since they need 
those glasses to read the draft ;-)

Or setup google translate to translate between the EN-US-IETF-RTG and 
EN-US-IETF-TSV languages ;-)

More seriously, I'll flag this better in the slides and make sure folks 
are awake.
> - As this is not an RTG meeting, explain what NVO3, SFC and BIER are before putting up slide 7.
OK.
> 	may contain some useful language to talk about this.
How about wording the slide as:
*

  *

    TE/traffic management differs from TCP CC

      o

        The underlay is well-provisioned, policed

      o Due to multi-tenancy, endpoint CC is not trusted

*
> - The last bullet on slide 11 did not parse for me, sorry.
Yes, it doesn't parse.
*What it means to say is more like "**Other encaps could do 
frag/reassembly". Point is that NVO3, SFC, and BIER seems to assume a 
network with sufficient and managed MTU.*

Thanks,
    Erik

> _______________________________________________
> Rtg-dt-encap-considerations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtg-dt-encap-considerations
>