Subject: Re: [Rtg-dt-encap-considerations] routing area design team on dataplane encapsulation considerations

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Thu, 7 May 2015 16:39:36 +0000

Hi RTGWG Chairs,

At the RTGWG meeting in Dallas, I thought it was decided for the WG to either adopt, or call to adopt this document.  Erik is getting ready to publish a new version.  Should he rename it as a WG draft before doing that?

Thanks, Larry

From: Alia Atlas <[email-masked]<mailto:[email-masked]>>
Date: Friday, March 13, 2015 1:16 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: routing area design team on dataplane encapsulation considerations

This design team has delivered a internet-draft, draft-rtg-dt-encap-01.
This draft will be discussed in RTGWG at IETF 92.  I would encourage you to all
read it and send comments to rtgwg.  I'm certain that the draft will be refined
and improved.

I'd like to thank the design team for their excellent work in a short time-frame.
I hope that this draft encourages useful discussion and thought as we move forward
on various encapsulations.

Regards,
Alia

On Tue, Dec 9, 2014 at 5:46 PM, Alia Atlas <[email-masked]<mailto:[email-masked]>> wrote:
I have chartered a Routing Area Design Team to work on data-plane encapsulation considerations.

I've bcc'd nvo3, sfc, bier, and rtgwg as the most directly relevant.  Please keep any conversation in one place on routing-discussion.

Erik Nordmark has kindly agreed to lead this design team.  The members of the design
team are:

  Albert Tian <[email-masked]<mailto:[email-masked]>>
  Erik Nordmark <[email-masked]<mailto:[email-masked]>>
  Jesse Gross <[email-masked]<mailto:[email-masked]>>
  Jon Hudson <[email-masked]<mailto:[email-masked]>>
  Larry Kreeger (kreeger) <[email-masked]<mailto:[email-masked]>>
  Pankaj Garg <[email-masked]<mailto:[email-masked]>>
  Pat Thaler <[email-masked]<mailto:[email-masked]>>
  Tom Herbert <[email-masked]<mailto:[email-masked]>>

The mailing list, [email-masked]<mailto:[email-masked]>, is closed but the archives are
publicly available at:
   http://www.ietf.org/mail-archive/web/rtg-dt-encap-considerations/current/maillist.html

The Design Team is chartered as follows:

There have been multiple efforts over the years that have resulted in new or modified data plane behaviors involving encapsulations. That includes IETF efforts like MPLS, LISP, and TRILL but also industry efforts like Vxlan and NVGRE.  These collectively can be seen as a source of insight into the properties that data planes need to meet.  The IETF is currently working on potentially new encapsulations in NVO3 and SFC and considering working on BIER. In addition there is work on tunneling in the INT area.

This is a short term design team chartered to collect and construct useful advice to parties working on new or modified data plane behaviors that include additional encapsulations.  The goal is for the group to document useful advice gathered from interacting with ongoing efforts.  An Internet Draft will be produced for IETF92 to capture that advice, which will be discussed in RTGWG.

Data plane encapsulations face a set of common issues such as:

  * How to provide entropy for ECMP
  * Issues around packet size and fragmentation/reassembly
  * OAM - what support is needed in an encapsulation format?
  * Security and privacy.
  * QoS
  * Congestion Considerations
  * IPv6 header protection (non-zero UDP checksum over IPv6 issue)
  * Extensibility - e.g., for evolving OAM, security, and/or congestion control
  * Layering of multiple encapsulations e.g., SFC over NVO3 over BIER

The design team will provide advice on those issues. The intention is that even where we have different encapsulations for different purposes carrying different data, each such encapsulation doesn’t have to reinvent the wheel for the above common issues.

The design team will look across the routing area in particular at SFC, NVO3 and BIER. It will not be involved in comparing or analyzing any particular encapsulation formats proposed in those WGs and BoFs but instead focus on common advice.

Regards,
Alia

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Thu, 7 May 2015 16:43:05 +0000

OK, apparently there is no actual alias for routing-discussion-chairs.  Trying again with rtgwg-chairs.

From: Larry Kreeger <[email-masked]<mailto:[email-masked]>>
Date: Thursday, May 7, 2015 9:39 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Alia Atlas <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-dt-encap-considerations] routing area design team on dataplane encapsulation considerations

Hi RTGWG Chairs,

Thanks, Larry

Regards,
Alia

Regards,
Alia

---

From: Chris Bowers <[email-masked]>
Date: Fri, 8 May 2015 12:42:06 +0000

Larry,

I think it makes sense to leave the name as is until the poll for WG adoption takes place on the mailing list.

Regards,
Chris

From: Larry Kreeger (kreeger) [mailto:[email-masked]]
Sent: Thursday, May 07, 2015 11:43 AM
To: Alia Atlas; [email-masked]; [email-masked]
Subject: Re: [Rtg-dt-encap-considerations] routing area design team on dataplane encapsulation considerations

Hi RTGWG Chairs,

Thanks, Larry

Regards,
Alia

The design team will provide advice on those issues. The intention is that even where we have different encapsulations for different purposes carrying different data, each such encapsulation doesn't have to reinvent the wheel for the above common issues.
The design team will look across the routing area in particular at SFC, NVO3 and BIER. It will not be involved in comparing or analyzing any particular encapsulation formats proposed in those WGs and BoFs but instead focus on common advice.

Regards,
Alia

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 08 May 2015 06:37:31 -0700

Chris,

When are you planning to do the WG adoption call?
You could either do that now on -01, or wait for about 2 weeks and we 
will have a -02 out.

Thanks,
    Erik

On 5/8/15 5:42 AM, Chris Bowers wrote:
>
> Larry,
>
> I think it makes sense to leave the name as is until the poll for WG 
> adoption takes place on the mailing list.
>
> Regards,
>
> Chris
>
> *From:*Larry Kreeger (kreeger) [mailto:[email-masked]]
> *Sent:* Thursday, May 07, 2015 11:43 AM
> *To:* Alia Atlas; [email-masked]; 
> [email-masked]
> *Subject:* Re: [Rtg-dt-encap-considerations] routing area design team 
> on dataplane encapsulation considerations
>
> *From: *Larry Kreeger <[email-masked] <mailto:[email-masked]>>
> *Date: *Thursday, May 7, 2015 9:39 AM
> *To: *"[email-masked] 
> <mailto:[email-masked]>" 
> <[email-masked] 
> <mailto:[email-masked]>>, Alia Atlas 
> <[email-masked] <mailto:[email-masked]>>, 
> "[email-masked] 
> <mailto:[email-masked]>" 
> <[email-masked] 
> <mailto:[email-masked]>>
> *Subject: *Re: [Rtg-dt-encap-considerations] routing area design team 
> on dataplane encapsulation considerations
>
> Hi RTGWG Chairs,
>
> At the RTGWG meeting in Dallas, I thought it was decided for the WG to 
> either adopt, or call to adopt this document.  Erik is getting ready 
> to publish a new version.  Should he rename it as a WG draft before 
> doing that?
>
> Thanks, Larry
>
> *From: *Alia Atlas <[email-masked] <mailto:[email-masked]>>
> *Date: *Friday, March 13, 2015 1:16 PM
> *To: *"[email-masked] 
> <mailto:[email-masked]>" <[email-masked] 
> <mailto:[email-masked]>>
> *Subject: *Re: routing area design team on dataplane encapsulation 
> considerations
>
>     I've bcc'd nvo3, sfc, bier, and rtgwg as the most directly
>     relevant.  Please keep any conversation in one place on
>     routing-discussion.
>
>     Erik Nordmark <[email-masked] <mailto:[email-masked]>>
>       Jesse Gross <[email-masked] <mailto:[email-masked]>>
>       Jon Hudson <[email-masked] <mailto:[email-masked]>>
>       Pat Thaler <[email-masked] <mailto:[email-masked]>>
>       Tom Herbert <[email-masked] <mailto:[email-masked]>>
>
>     The mailing list, [email-masked]
>     <mailto:[email-masked]>, is closed but the
>     archives are
>
>     publicly available at:
>
>     There have been multiple efforts over the years that have resulted
>     in new or modified data plane behaviors involving encapsulations.
>     That includes IETF efforts like MPLS, LISP, and TRILL but also
>     industry efforts like Vxlan and NVGRE.  These collectively can be
>     seen as a source of insight into the properties that data planes
>     need to meet.  The IETF is currently working on potentially new
>     encapsulations in NVO3 and SFC and considering working on BIER. In
>     addition there is work on tunneling in the INT area.
>
>     This is a short term design team chartered to collect and
>     construct useful advice to parties working on new or modified data
>     plane behaviors that include additional encapsulations.  The goal
>     is for the group to document useful advice gathered from
>     interacting with ongoing efforts.  An Internet Draft will be
>     produced for IETF92 to capture that advice, which will be
>     discussed in RTGWG.
>
>     The design team will provide advice on those issues. The intention
>     is that even where we have different encapsulations for different
>     purposes carrying different data, each such encapsulation doesn’t
>     have to reinvent the wheel for the above common issues.
>
>     The design team will look across the routing area in particular at
>     SFC, NVO3 and BIER. It will not be involved in comparing or
>     analyzing any particular encapsulation formats proposed in those
>     WGs and BoFs but instead focus on common advice.
>
>     Regards,
>
>     Alia
>
>
>
> _______________________________________________
> Rtg-dt-encap-considerations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtg-dt-encap-considerations

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 8 May 2015 14:09:41 +0000

Erik,

Please publish 02, we will review it as well as  ask for a Routing Directorate QA reviewer and poll WG in parallel.
Chris - what do you think?

Regards,
Jeff

> On May 8, 2015, at 11:38 PM, Erik Nordmark <[email-masked]> wrote:
> 
> 
> Chris,
> 
> You could either do that now on -01, or wait for about 2 weeks and we will have a -02 out.
> 
> Thanks,
>   Erik
> 
>> *To:* Alia Atlas; [email-masked]; [email-masked]
>> *Subject:* Re: [Rtg-dt-encap-considerations] routing area design team on dataplane encapsulation considerations
>> 
>> *To: *"[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, Alia Atlas <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>> *Subject: *Re: [Rtg-dt-encap-considerations] routing area design team on dataplane encapsulation considerations
>> 
>> Hi RTGWG Chairs,
>> 
>> *To: *"[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>> *Subject: *Re: routing area design team on dataplane encapsulation considerations
>> 
>> On Tue, Dec 9, 2014 at 5:46 PM, Alia Atlas <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Chris Bowers <[email-masked]>
Date: Fri, 8 May 2015 14:12:41 +0000

I agree.  WG adoption poll sometimes triggers people to read a draft, so they might as well read the latest version if that is eminent.

Chris

-----Original Message-----
From: Jeff Tantsura [mailto:[email-masked]] 
Sent: Friday, May 08, 2015 9:10 AM
To: Erik Nordmark
Cc: Chris Bowers; Larry Kreeger (kreeger); Alia Atlas; [email-masked]; [email-masked]
Subject: Re: [Rtg-dt-encap-considerations] routing area design team on dataplane encapsulation considerations

Erik,

Regards,
Jeff

>>    purposes carrying different data, each such encapsulation doesn't

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 8 May 2015 14:17:46 +0000

So there's a consensus.

Regards,
Jeff

> On May 9, 2015, at 12:12 AM, Chris Bowers <[email-masked]> wrote:
>

---

From: Erik Nordmark <[email-masked]>
Date: Thu, 14 May 2015 14:29:02 -0700

> Please publish 02, we will review it as well as  ask for a Routing Directorate QA reviewer and poll WG in parallel.
OK, the DT should get 02 out by the end of next week.

   Erik