Subject: Re: [Rtg-ooam-dt] O-OAM Requirements

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Thu, 24 Dec 2015 13:06:22 +0000

Hi Greg,

Merry Christmas and Happy New year!!

It is a good start. A couple of points that quickly popped up are below:

1. ECMP awareness - I think we should also include ECMP awareness as one of the requirement.  We may need a right terminology that depicts ECMP and is applicable on different overlay.
2. Path MTU - I see this as one of the topic coming up with different overlay. It is better to include this in the requirement.

Will read more and share any more comments.

Thanks,
Nagendra

From: Rtg-ooam-dt <[email-masked]<mailto:[email-masked]>> on behalf of Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 23, 2015 at 11:05 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Alia Atlas ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>
Subject: [Rtg-ooam-dt] O-OAM Requirements

Dear All,
happy holidays, Merry Christmas and Happy New Year to All!

I put down some OAM requirements. Greatly appreciate your comments. Can we put it somewhere, somehow for everyone to edit?

You'll notice that some requirements are explicitly point to unidirectional character of OAM. I think that services provided y an overlay network are unidirectional and bi-directional Fault Monitoring and Performance Measurement are unnecessary. Though in some cases egress node may use IP network to send notification to the ingress node. What do you think?

                Regards,
                                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Sun, 27 Dec 2015 16:34:58 +0000

Hi Nagendra,
thank you for your comments.
I agree with PMTUD. Though am not certain about the ECMP as far as pro-active monitoring if only tracing, i.e. on-demand. I think it would be great topic for us to discuss during the next call.
Would January 5th, 2016 @ 07:00 PST work? Would Tuesdays @ 07:00 PST work as regular meeting time?

                Regards,
                                Greg

From: Nagendra Kumar Nainar (naikumar) [mailto:[email-masked]]
Sent: Thursday, December 24, 2015 5:06 AM
To: Gregory Mirsky; [email-masked]
Cc: Alia Atlas ([email-masked])
Subject: Re: [Rtg-ooam-dt] O-OAM Requirements

Hi Greg,

Thanks,
Nagendra

Dear All,

                Regards,
                                Greg

---

From: David Mozes <[email-masked]>
Date: Tue, 29 Dec 2015 08:14:20 +0000

Hi ,
I think we need
 need Route tracing

https://tools.ietf.org/html/rfc5860#page-11

Or the similar on NVO3   proposals

Thx
David
From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Sunday, December 27, 2015 6:35 PM
To: Nagendra Kumar Nainar (naikumar) <[email-masked]>; [email-masked]
Cc: Alia Atlas ([email-masked]) <[email-masked]>
Subject: Re: [Rtg-ooam-dt] O-OAM Requirements

Hi Nagendra,

                Regards,
                                Greg

From: Nagendra Kumar Nainar (naikumar) [mailto:[email-masked]]
Sent: Thursday, December 24, 2015 5:06 AM
To: Gregory Mirsky; [email-masked]<mailto:[email-masked]>
Cc: Alia Atlas ([email-masked]<mailto:[email-masked]>)
Subject: Re: [Rtg-ooam-dt] O-OAM Requirements

Hi Greg,

Thanks,
Nagendra

Dear All,

                Regards,
                                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 30 Dec 2015 21:40:59 +0000

Hi David,
agree, ability to trace a path is one of the most valuable troubleshooting mechanisms. I'll make it clear in the draft.
One question regarding NVO3 environment. For example, BIER architecture is not only allows but requires that transient nodes, Bit-Forwarding Routers, used in BIER domain between Bit-Forwarding Ingress Router (BFIR) and Bit-Forwarding Egress Router (BFER). What may be viewed as transient virtual node in NVO3 reference model? If NVO3 OAM domain among NVEs, then, if I use terminology of connection-oriented networks OAM, where our MIPs to trace? I think I can see only MEPs at NVEs. Greatly appreciate you comments.

Happy New Year to All!

                Regards,
                                Greg

From: David Mozes [mailto:[email-masked]]
Sent: Tuesday, December 29, 2015 12:14 AM
To: Gregory Mirsky; Nagendra Kumar Nainar (naikumar); [email-masked]
Cc: Alia Atlas ([email-masked])
Subject: RE: [Rtg-ooam-dt] O-OAM Requirements

Hi ,
I think we need
 need Route tracing

Thx
David
From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Sunday, December 27, 2015 6:35 PM
To: Nagendra Kumar Nainar (naikumar) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Alia Atlas ([email-masked]<mailto:[email-masked]>) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-ooam-dt] O-OAM Requirements

Hi Nagendra,

                Regards,
                                Greg

Hi Greg,

Thanks,
Nagendra

Dear All,

                Regards,
                                Greg

---

From: Mach Chen <[email-masked]>
Date: Thu, 31 Dec 2015 01:52:01 +0000

Hi  Greg and David,

Indeed, I agree with you that the route tracing is needed  and should be included.

For NVO3, I also think that there seems no MIPs and thus the route tracing may not be applicable.

Best regards,
Mach

Happy New Year to ALL!

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Thursday, December 31, 2015 5:41 AM
To: David Mozes; Nagendra Kumar Nainar (naikumar); [email-masked]
Cc: Alia Atlas ([email-masked])
Subject: Re: [Rtg-ooam-dt] O-OAM Requirements

Hi David,

Happy New Year to All!

                Regards,
                                Greg

To: Gregory Mirsky; Nagendra Kumar Nainar (naikumar); [email-masked]<mailto:[email-masked]>

Hi ,
I think we need
 need Route tracing

Thx
David

Hi Nagendra,

                Regards,
                                Greg

Hi Greg,

Thanks,
Nagendra

Dear All,

                Regards,
                                Greg

---

From: David Mozes <[email-masked]>
Date: Thu, 31 Dec 2015 08:11:29 +0000

Hi Gregory  ,
I thinks the MIP points  that we like to trace is actually the underlay network  path between the NVEs .
One method is to  use the same ideas as in traceroute (ttl)   Erik  has some draft on that  .
There are other methods  using the OAM bits on the  uncap header e.g.  VXLAN-GPE/GENEVE    etc ..

Happy new year to all

David

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Wednesday, December 30, 2015 11:41 PM
To: David Mozes <[email-masked]>; Nagendra Kumar Nainar (naikumar) <[email-masked]>; [email-masked]
Cc: Alia Atlas ([email-masked]) <[email-masked]>
Subject: RE: [Rtg-ooam-dt] O-OAM Requirements

Hi David,

Happy New Year to All!

                Regards,
                                Greg

Hi ,
I think we need
 need Route tracing

Thx
David

Hi Nagendra,

                Regards,
                                Greg

Hi Greg,

Thanks,
Nagendra

Dear All,

                Regards,
                                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 31 Dec 2015 22:03:42 +0000

Hi David,
yes, verification of inter-layer mappings or control plane to data plane mappings, which is  connectivity verification, is valuable and should be among the OAM requirements. But I don't think of these as tracing the network elements at particular layer, i.e. doing the traceroute. In NVO3 reference model I don't find intermediate or transient nodes but only edge nodes. Hence I conclude that ping and traceroute in NVO3 environment will produce the same results.

                Happy New Year!

                                Regards,
                                                Greg

Sent: Thursday, December 31, 2015 12:11 AM

Hi Gregory  ,

Happy new year to all

David

To: David Mozes <[email-masked]<mailto:[email-masked]>>; Nagendra Kumar Nainar (naikumar) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Hi David,

Happy New Year to All!

                Regards,
                                Greg

Hi ,
I think we need
 need Route tracing

Thx
David

Hi Nagendra,

                Regards,
                                Greg

Hi Greg,

Thanks,
Nagendra

Dear All,

                Regards,
                                Greg