Subject: [Rtg-ooam-dt] O-OAM Requirements

From: Gregory Mirsky <[email-masked]>
Date: Thu, 24 Dec 2015 04:05:30 +0000

Dear All,
happy holidays, Merry Christmas and Happy New Year to All!

I put down some OAM requirements. Greatly appreciate your comments. Can we put it somewhere, somehow for everyone to edit?

You'll notice that some requirements are explicitly point to unidirectional character of OAM. I think that services provided y an overlay network are unidirectional and bi-directional Fault Monitoring and Performance Measurement are unnecessary. Though in some cases egress node may use IP network to send notification to the ingress node. What do you think?

                Regards,
                                Greg

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Thu, 24 Dec 2015 05:01:48 +0000

Hi Greg,

Merry Christmas and Happy New year!!

It is a good start. A couple of points that quickly popped up are below:

1. ECMP awareness - I think we should also include ECMP awareness as one of the requirement.  We may need a right terminology that depicts ECMP and is applicable on different overlay.

2. Path MTU - I see this as one of the topic coming up with different overlay. It is better to include this in the requirement.

Will read more and share any more comments.

Thanks,

Nagendra?

________________________________
From: Rtg-ooam-dt <[email-masked]> on behalf of Gregory Mirsky <[email-masked]>
Sent: Wednesday, December 23, 2015 11:05 PM
To: [email-masked]
Cc: Alia Atlas ([email-masked])
Subject: [Rtg-ooam-dt] O-OAM Requirements

Dear All,

                Regards,
                                Greg

---

From: Mach Chen <[email-masked]>
Date: Thu, 24 Dec 2015 07:27:24 +0000

Hi Greg and others,

Merry Christmas and Happy New Year to all of you and your family!

Eirk and I made some experiments to use Office Online for sharing document editing. I think it works although it is harder to use than Google Docs.

I made some modifications(with markups) to performance measurement section. Here are some reasons for the modification:

1) Normally, one-way or two-way is specific to packet delay measurement.
2) For delay measurement, only one-way can be measured in either active or passive way, for two-way, only active method can be used;
3) I also add some requirements about performing per-segment loss/delay measurement, per-segment measurement means measuring a segment of a path, it is useful in fault localization.

Best regards,
Mach

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Thursday, December 24, 2015 12:06 PM
To: [email-masked]
Cc: Alia Atlas ([email-masked])
Subject: [Rtg-ooam-dt] O-OAM Requirements

Dear All,

                Regards,
                                Greg

---

From: David Mozes <[email-masked]>
Date: Thu, 24 Dec 2015 12:55:51 +0000

Hi Nagendra , Greg and All

Merry Christmas and Happy new year  .

I  Agree  for both of them as well

Thx
David

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Nagendra Kumar Nainar (naikumar)
Sent: Thursday, December 24, 2015 7:02 AM
To: Gregory Mirsky <[email-masked]>; [email-masked]
Cc: Alia Atlas ([email-masked]) <[email-masked]>
Subject: Re: [Rtg-ooam-dt] O-OAM Requirements

Hi Greg,

2. Path MTU – I see this as one of the topic coming up with different overlay. It is better to include this in the requirement.

Thanks,

Nagendra​

________________________________
From: Rtg-ooam-dt <[email-masked]<mailto:[email-masked]>> on behalf of Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, December 23, 2015 11:05 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Alia Atlas ([email-masked]<mailto:[email-masked]>)
Subject: [Rtg-ooam-dt] O-OAM Requirements

Dear All,

You’ll notice that some requirements are explicitly point to unidirectional character of OAM. I think that services provided y an overlay network are unidirectional and bi-directional Fault Monitoring and Performance Measurement are unnecessary. Though in some cases egress node may use IP network to send notification to the ingress node. What do you think?

                Regards,
                                Greg