Subject: Re: [Rtg-ooam-dt] Overlay OAM DT meeting - Minutes (Jan-12-2016)

From: Gregory Mirsky <[email-masked]>
Date: Tue, 12 Jan 2016 19:38:28 +0000

Hi Nagendra,
thank you for the contribution, very detailed. Let's discuss it next week.
I'm curious about the NVO3 DT you've mentioned. Does it work on NVO3 OAM or its charter is different?

                Regards,
                                Greg

From: Deepak Kumar (dekumar) [mailto:[email-masked]]
Sent: Tuesday, January 12, 2016 11:29 AM
To: Gregory Mirsky; Nagendra Kumar Nainar (naikumar)
Subject: Re: [Rtg-ooam-dt] Overlay OAM DT meeting - Minutes (Jan-12-2016)

Hi Greg/Nagendra,

Sorry I missed the meeting. My Calendar somehow didn't had the meeting information.

I have uploaded data center topology scenario to the shared space. I am doing the samething for nvo3 design team so I will keep updating the shared space at both places.

Thanks,
Deepak

From: Rtg-ooam-dt <[email-masked]<mailto:[email-masked]>> on behalf of Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, January 12, 2016 at 11:17 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-ooam-dt] Overlay OAM DT meeting - Minutes (Jan-12-2016)

Hi Nagendra,
thank you for capturing the minutes of today meeting.
Here's reference to LSP Self-Ping<http://tools.ietf.org/html/draft-chen-ippm-coloring-based-ipfpm-framework-04> work by Ron Bonica I've mentioned today. I think that functionally it is equivalent to BFD-Echo (which is single-hop only) and S-BFD.
I've added a note on passive PM to the Scratch pad.
Please review Requirements, Scratch and add your content, comments.

                Regards,
                                Greg

From: Nagendra Kumar Nainar (naikumar) [mailto:[email-masked]]
Sent: Tuesday, January 12, 2016 11:09 AM
To: Gregory Mirsky; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Deepak Kumar (dekumar); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Carlos Pignataro (cpignata); [email-masked]<mailto:[email-masked]>
Subject: Re: Overlay OAM DT meeting - Minutes (Jan-12-2016)

Hi All,

Please find the meeting minutes captured from todays call. Please feel free to make any changes if I miss something,

  *   Discussion on ECMP awareness on underlay/overlay - for ease of operation and capacity planning it helps. Not required to be "MUST".
  *   Nagendra to include the ECMP requirement in the document.
  *   One of the requirement is to have a protocol (or a differentiator) for OAM in the overlay header.
  *   For continuity check, BFD multipoint and BFDmultipoint with active tail may be a good start - will be more appropriate without IP/UDP. S-BFD can be explored.
  *   There is another proposal from Ron Bonica as draft-ietf-mpls-self-ping. This machinery also to be considered as part of brain storming.
  *   For Ping/Trace, BIER Ping proposal is a good start as it proposes the basic machinery and TLVs.
  *   RFC6374 and draft-ietf-mpls-rfc6374-udp-return-path could be considered for active performance measurement.
  *   Anyone can include any other machinery that they have in mind in the Scratch Pad document for brainstorming and get the best suited one for Overlay OAM approach.
  *   No plan for BoF proposal this time. But Greg will discuss with Alia. We target to get 3 documents by next IETF - Requirement, Gap Analysis and Solution framework.

Next meeting: Next week. Moving forward, we may have bi-weekly meeting.

Thanks,
Nagendra

---

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Tue, 12 Jan 2016 19:57:37 +0000

Hi,

I updated scratchpad for how to leverage oam channel based on TRILL in scratchpad for review. I see atleast having option to have version, opcode (different message types, as just ping and trace (doesn't make oam hardware friendly or extensible), flags, and opcode specific Information.

Nvo3 Design Team is working on nvo3 encapsulation only and we will work on getting consensus on oam channel. Some work might be common.

Thanks,
Deepak

From: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, January 12, 2016 at 11:38 AM
To: dekumar <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Rtg-ooam-dt] Overlay OAM DT meeting - Minutes (Jan-12-2016)

Hi Nagendra,

                Regards,
                                Greg

Hi Greg/Nagendra,

Thanks,
Deepak

Hi Nagendra,

                Regards,
                                Greg

Hi All,

Thanks,
Nagendra

---

From: Santosh P K <[email-masked]>
Date: Thu, 14 Jan 2016 18:39:55 +0530

Hello All,
    Like we discussed in last meeting below requirement needs to be
reworded?

[R11] [david]Overlay OAM must support Underlay traceroute (Coordinate with
the underlay provider policy )

This is only required to ensure that overlay knows the behavior of underlay
and nothing to do with underlay monitoring right? Shall I reword this to
indicate that?

Thanks

Santosh P K

---

From: David Mozes <[email-masked]>
Date: Thu, 14 Jan 2016 14:13:48 +0000

Hi * ,
I am Ok with rewording .
However ., lets  try  specifies What does it mean underlay behavior .

Thx
David

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Santosh P K
Sent: Thursday, January 14, 2016 3:10 PM
To: Deepak Kumar (dekumar) <[email-masked]>
Cc: Gregory Mirsky <[email-masked]>; [email-masked]
Subject: Re: [Rtg-ooam-dt] Overlay OAM DT meeting - Minutes (Jan-12-2016)

Hello All,
    Like we discussed in last meeting below requirement needs to be reworded?

[R11] [david]Overlay OAM must support Underlay traceroute (Coordinate with the underlay provider policy )

This is only required to ensure that overlay knows the behavior of underlay and nothing to do with underlay monitoring right? Shall I reword this to indicate that?

Thanks

Santosh P K

---

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Thu, 14 Jan 2016 16:25:40 +0000

Hi,

I am not sure if below requirement covers
Ovrerlay OAM should support "accurate tracing of the underlay path for host to host customer traffic flow".
Underlay can be ip unumbered, or redundant deployed in this scenario ip address in reply won't be enough to distinguish underlay devices port.

Thanks,
Deepak

From: David Mozes <[email-masked]<mailto:[email-masked]>>
Date: Thursday, January 14, 2016 at 6:13 AM
To: Santosh P K <[email-masked]<mailto:[email-masked]>>, dekumar <[email-masked]<mailto:[email-masked]>>
Cc: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Rtg-ooam-dt] Overlay OAM DT meeting - Minutes (Jan-12-2016)

Hi * ,
I am Ok with rewording .

Thx
David

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Santosh P K
Sent: Thursday, January 14, 2016 3:10 PM
To: Deepak Kumar (dekumar) <[email-masked]<mailto:[email-masked]>>
Cc: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Rtg-ooam-dt] Overlay OAM DT meeting - Minutes (Jan-12-2016)

Hello All,

Thanks

Santosh P K

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 14 Jan 2016 16:46:43 +0000

Hi,
I agree with Deepak. I think that Overlay OAM may help discover some elements of the underlay (we'll need to formulate requirements toward the underlay and its OAM) but it should not be viewed as the tool to troubleshoot the underlay network. I've suggested to add these requirements to On-demand FM section (or elsewhere):
Overlay OAM MUST support discovery of the multipath in its transport network.
Overlay OAM MUST be able to trigger on-demand FM with responses being directed towards the initiator of such proxy request.
Perhaps combination of the one proposed by David and these may be adopted.

                Regards,
                                Greg

From: Deepak Kumar (dekumar) [mailto:[email-masked]]
Sent: Thursday, January 14, 2016 8:26 AM
To: David Mozes; Santosh P K
Cc: Gregory Mirsky; [email-masked]
Subject: Re: [Rtg-ooam-dt] Overlay OAM DT meeting - Minutes (Jan-12-2016)

Hi,

Thanks,
Deepak

Hi * ,
I am Ok with rewording .

Thx
David

Hello All,

Thanks

Santosh P K

---

From: David Mozes <[email-masked]>
Date: Sun, 17 Jan 2016 09:32:05 +0000

OK

From: Deepak Kumar (dekumar) [mailto:[email-masked]]
Sent: Thursday, January 14, 2016 6:26 PM
To: David Mozes <[email-masked]>; Santosh P K <[email-masked]>
Cc: Gregory Mirsky <[email-masked]>; [email-masked]
Subject: Re: [Rtg-ooam-dt] Overlay OAM DT meeting - Minutes (Jan-12-2016)

Hi,

Thanks,
Deepak

Hi * ,
I am Ok with rewording .

Thx
David

Hello All,

Thanks

Santosh P K