Subject: [Rtg-ooam-dt] Overlay OAM: Gap Analysis

From: Gregory Mirsky <[email-masked]>
Date: Thu, 3 Mar 2016 01:21:29 +0000

Dear All,
attached is the skeleton of the Gap Analysis document. Couple questions:

*         do you think that its structure is about right;

*         which sections or sub-sections you can contribute.
Greatly appreciate your responses.

Regards,
        Greg

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 4 Mar 2016 00:59:28 +0000

Thanks Greg!

All,

Please find a couple of high-level comments.

First of all, I really like the overall structure of separating in Fault, PM, and Telemetry. That is a useful demarcation for identifying Gaps.

One of the drawbacks of such approach, however, is that the Gaps across layers are not directly evident or readily explained. In other words, this structure promotes Flat single-layer gaps.

We need layer-interacting gaps, those are some of the key ones.

Some specific comments:

> The OAM solution for Overlay networks, developed
> 
>    by the design team, has three objectives:

However, only two objectives are listed :-)

>    The Overlay OAM toolset is based on the following existing tools:
> 

Here is where I really disagree — this is a solution statement, not a gap analysis. For example, there are other OAMs considered here, including S-BFD and MPLS LSP Ping. Further, the BFD pointers should include 5882/5883 more than 5884, and potentially 5885 too.

S1.1.1

We need a proper definition / pointer for “Overlay   networks"

Nits:

s/Roting/Routing/
s/OAN/OAM/g

More soon!

Thanks!

— Carlos.

> On Mar 2, 2016, at 8:21 PM, Gregory Mirsky <[email-masked]> wrote:
> 
> Dear All,
> ·         do you think that its structure is about right;
> ·         which sections or sub-sections you can contribute.
> <draft-ooamdt-rtgwg-oam-gap-analysis-00.doc>_______________________________________________
> Rtg-ooam-dt mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/rtg-ooam-dt <https://www.ietf.org/mailman/listinfo/rtg-ooam-dt>

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 4 Mar 2016 01:04:51 +0000

Hi Carlos,
thank you for the review and very helpful comments. I agree with all and will add references to OAM tools you’ve mentioned.
I think that Conclusion or Summary section may be good place to summarize all the discussion we’ll have in previous sections. Let me make changes and I’ll send the update tonight.

                Regards,
                                Greg

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Thursday, March 03, 2016 4:59 PM
To: Gregory Mirsky
Cc: [email-masked]; Alia Atlas
Subject: Re: [Rtg-ooam-dt] Overlay OAM: Gap Analysis

Thanks Greg!

All,

Some specific comments:

S1.1.1

Nits:

s/Roting/Routing/
s/OAN/OAM/g

More soon!

Thanks!

— Carlos.

On Mar 2, 2016, at 8:21 PM, Gregory Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Dear All,
attached is the skeleton of the Gap Analysis document. Couple questions:
•         do you think that its structure is about right;
•         which sections or sub-sections you can contribute.
Greatly appreciate your responses.

Regards,
        Greg
<draft-ooamdt-rtgwg-oam-gap-analysis-00.doc>_______________________________________________
Rtg-ooam-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtg-ooam-dt

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 4 Mar 2016 02:13:07 +0000

Dear All,
please find updated version attached. The list of existing OAM tools been extended, added section Conclusions, characterization changed to less definite statement:
The Overlay OAM toolset may use some or all of the following OAM protocols designed at IETF:
nits corrected.
Your comments, suggestions are most welcome. Please volunteer to contribute.

                Regards,
                                Greg

Thanks Greg!

All,

Some specific comments:

S1.1.1

Nits:

s/Roting/Routing/
s/OAN/OAM/g

More soon!

Thanks!

— Carlos.

Dear All,

Regards,
        Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 4 Mar 2016 02:30:29 +0000

And now with the attachment ☺

From: Gregory Mirsky
Sent: Thursday, March 03, 2016 6:13 PM
To: 'Carlos Pignataro (cpignata)'
Cc: [email-masked]; Alia Atlas
Subject: RE: [Rtg-ooam-dt] Overlay OAM: Gap Analysis

Dear All,

                Regards,
                                Greg

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Thursday, March 03, 2016 4:59 PM
To: Gregory Mirsky
Cc: [email-masked]<mailto:[email-masked]>; Alia Atlas
Subject: Re: [Rtg-ooam-dt] Overlay OAM: Gap Analysis

Thanks Greg!

All,

Some specific comments:

S1.1.1

Nits:

s/Roting/Routing/
s/OAN/OAM/g

More soon!

Thanks!

— Carlos.

Dear All,

Regards,
        Greg