Subject: [Rtg-ooam-dt] Telemetry

From: David Mozes <[email-masked]>
Date: Tue, 29 Mar 2016 12:06:44 +0000

Hi Gorge and all
Attached is Telemetry preliminary  contribution  as was promised
I like to present and add it to our proposal
Let's discuss and  review in today meeting

Thx
David

---

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Tue, 29 Mar 2016 14:23:42 +0000

Hi David,

Thanks for slides.

Please see if below requirements are met

Bandwidth
          use by port (hardware)
          host versus uplink  (software)
          aggregate hosts versus uplink  (software)
                    east-west versus north-south  (software)
          impacts:
               buffers
          impacted by:
               packet size distribution
               drops

ECMP balance
      balance of traffic across equal cost paths
               v4 and v6 individually and in aggregate
          impacts:
               bandwidth and flow distribution when out of balance
          impacted by:
               hashing algorithm/methods
                         v4 and v6 separately versus concatenated
               flow size
                         packet size

Packet size distribution
          packet size with TCP effects bandwidth levels, smaller packets result in lower bandwidth per flow
          can be used to help calculate/extrapolate approximate buffer utilization efficiency
                    used in conjunction with buffer cell utilization

Buffer utilization

Buffer high water mark

Buffer Utilization Efficiency

microburst

congestion monitoring

nput discards

output discards

link/port speed

Switching ASIC bit error

Thanks,
Deepak

From: Rtg-ooam-dt <[email-masked]<mailto:[email-masked]>> on behalf of David Mozes <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, March 29, 2016 at 5:06 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Rtg-ooam-dt] Telemetry

Hi Gorge and all

Thx
David