Subject: [Rtg-ooam-dt] MoM: 04/19/2016

From: Gregory Mirsky <[email-masked]>
Date: Wed, 20 Apr 2016 00:05:54 +0000

Dear All,
we've re-started our weekly meetings.

Present: Yizhou, Mach, David, Ignas, Deepak, Greg

Agenda:

  *   SFC OAM: contribution to the Gap Analysis draft based on our presentation in BA;
  *   NVO3 OAM: contribution based on presentation at NVO3 WG;
  *   Telemetry: OOAM as mechanism to trigger telemetry report, possible transport. Trigger can be by active or passive OAM. Active on-demand trigger by a TLV in ping?

Discussed:

*         Telemetry:

o   OOAM to facilitate reporting and/or collection of telemetry information

o   what to be reported is outside of the scope for our DT

*         SFC:

o   in our presentation in BA we've zeroed on one of models of SFC OAM, the one that does not include SF for proactive OAM but may support verification/discovery of mapping between particular SFF and an SF(s)

o   need to capture that in text for the gap analysis document and have discussion with the SFC WG

*         NVO3:

o   use cases

*         Gap Analysis draft:

o   do we need to demonstrate applicability of, for example, BFD to all overlays or one example, BIER, sufficient and can be extended onto other overlay that recognize OAM as distinctive payload type?

For the next meeting(s):

o   Ignas and Yizhou work on NVO3 use cases for proactive OAM (Continuity Check). How helpful to us is BFD for VXLAN work?

o   David and Deepak work on Telemetry (active and passive triggers)

o   Mach - descriprion of the SFC OAM model we propose (prefer?)

o   Greg - what could be the foundation for Overlay Ping/Traceroute:

o   ICMP

o   MPLS LSP Ping/Traceroute

o   BIER Ping/Traceroute

Please edit, add, comment on the MoM.

                Regards,
                                Greg

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 20 Apr 2016 00:22:15 +0000

Thanks Greg! One comment on the next-steps, inline.

> On Apr 19, 2016, at 8:05 PM, Gregory Mirsky <[email-masked]> wrote:
> 
> For the next meeting(s):
> o   Mach – descriprion of the SFC OAM model we propose (prefer?)
> o   Greg – what could be the foundation for Overlay Ping/Traceroute:
> o   ICMP

Let’s go through the analysis for Ping/Traceroute on Overlays. I’d like for us to consider separating this analysis in two parts:

1. User interface — what are the expectations from a user interface perspective. Is for example a user CLI expected to be able to do traceroute -tree to discover all ECMPs?

2. Protocol — which protocol construct as a foundation. ICMP (+ RFC 4884), Modified LSP Ping (not FECs), etc.

Thanks!

Carlos.

---

From: David Mozes <[email-masked]>
Date: Wed, 20 Apr 2016 07:22:01 +0000

It is important to understand Whether Ping /traceroute  is  a valid tool for high bend with inband active probing  as well ?
What is the user interface for such active probing  should be   ?

Thx
David

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Wednesday, April 20, 2016 3:22 AM
To: Gregory Mirsky <[email-masked]>
Cc: [email-masked]
Subject: Re: [Rtg-ooam-dt] MoM: 04/19/2016

On Apr 19, 2016, at 8:05 PM, Gregory Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

For the next meeting(s):

Thanks!

Carlos.