Subject: [Rtg-ooam-dt] Ping/Traceroute for Overlay OAM

From: Gregory Mirsky <[email-masked]>
Date: Wed, 4 May 2016 20:43:27 +0000

Dear All,
attached is proposal for format of ping/traceroute control packet for Overlay OAM. I've used BIER Ping as the base and made couple changes based on our discussion with Dave Dolson. All registries listed in the draft-kumarzheng-bier-ping would be created but for Overlay Ping with TLVs coming from all interested parties.
Would appreciate your comments, suggestions and questions.

                Regards,
                                Greg

---

From: Liyizhou <[email-masked]>
Date: Thu, 5 May 2016 10:58:47 +0000

Hi Greg,

A clarification question, why are there both message type and proto fields in the proposed header?
In BIER header draft, proto field is set to all 0’s. What is proto field used for?

Thanks,
Yizhou　

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Thursday, May 05, 2016 4:43 AM
To: [email-masked]
Cc: Dave Dolson ([email-masked])
Subject: [Rtg-ooam-dt] Ping/Traceroute for Overlay OAM

Dear All,
attached is proposal for format of ping/traceroute control packet for Overlay OAM. I’ve used BIER Ping as the base and made couple changes based on our discussion with Dave Dolson. All registries listed in the draft-kumarzheng-bier-ping would be created but for Overlay Ping with TLVs coming from all interested parties.
Would appreciate your comments, suggestions and questions.

                Regards,
                                Greg

---

From: Dave Dolson <[email-masked]>
Date: Thu, 5 May 2016 13:27:32 +0000

Greg,
Would you also propose a base header, along the lines of bier-oam packet header:

      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |  Ver  | Message Type  | Proto |             Reserved          |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     ~                  Message Type Dependent Data                  ~
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

(That's the BIER one)

I'm guessing the generic one would be:
      0                   1                   2                   3
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |  Ver  | Message Type  | Proto |     Length    |      Flags    |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     ~                  Message Type Dependent Data                  ~
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

In my opinion, Ver, Message Type and Proto all serve the same purpose of describing what comes next, using too many bits (for a handful of message types),
whereas 8 bits for Length is not enough to provide a packet with a full MTU of data.

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Wednesday, May 04, 2016 4:43 PM
To: [email-masked]
Cc: Dave Dolson
Subject: Ping/Traceroute for Overlay OAM

Dear All,

                Regards,
                                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 5 May 2016 19:18:44 +0000

Hi Dave and Yizhou,
thank you for your thoughtful comments and great questions! Got me thinking and attached you'll find the changed proposal:

*         OAM Header

*         Echo format is as in RFC 4379 of MPSL Echo.
Comments, questions always welcome and greatly appreciated.

                Regards,
                                Greg

From: Dave Dolson [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 6:28 AM
To: Gregory Mirsky; [email-masked]
Subject: RE: Ping/Traceroute for Overlay OAM

Greg,

      0                   1                   2                   3

(That's the BIER one)

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Wednesday, May 04, 2016 4:43 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Dave Dolson
Subject: Ping/Traceroute for Overlay OAM

Dear All,

                Regards,
                                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 5 May 2016 20:14:55 +0000

Now in different format and with updated OAM Header.

                Regards,
                                Greg

From: Gregory Mirsky
Sent: Thursday, May 05, 2016 12:19 PM
To: 'Dave Dolson'; [email-masked]
Subject: RE: Ping/Traceroute for Overlay OAM

Hi Dave and Yizhou,

*         OAM Header

                Regards,
                                Greg

From: Dave Dolson [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 6:28 AM
To: Gregory Mirsky; [email-masked]<mailto:[email-masked]>
Subject: RE: Ping/Traceroute for Overlay OAM

Greg,

      0                   1                   2                   3

(That's the BIER one)

Dear All,

                Regards,
                                Greg