Subject: Re: [Rtg-ooam-dt] Updated Gap Analysis document

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Tue, 17 May 2016 11:07:35 +0000

Hi,

I can start the meeting.

-Nagendra

From: Rtg-ooam-dt <[email-masked]<mailto:[email-masked]>> on behalf of Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Monday, May 16, 2016 at 3:13 PM
To: Liyizhou <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Dave Dolson ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-ooam-dt] Updated Gap Analysis document

Hi Yizhou,
thank you for great comments. We now need at least one new draft to define the OOAM header and optional Timestamp block as the Gap Analysis, I think, should remain as informational document. And if we conclude that the new Echo Request/Reply control packet is required that may be our second draft on standards track.

Would appreciate others chiming in.

RE: our meeting tomorrow. I have another meeting that I'll have to jump to at 8:00 a.m. Would anyone like to open the meeting and run it through all 90 minutes?

                Regards,
                                Greg

From: Liyizhou [mailto:[email-masked]]
Sent: Friday, May 13, 2016 2:14 AM
To: Gregory Mirsky; [email-masked]<mailto:[email-masked]>; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: RE: Updated Gap Analysis document

Hi Greg,

For Figure 1 Overlay OAM Header format, I think there should be a field called something like "Flag indicated field (optional)" between the length and ooam control packet.

The sequence of Flags is relevant to the sequence of "Flag indicated field".
For example, assume we have defined T flag for "timestamp block" in ooam header flags. Then if a new flag X is defined and some new field called "X block" has to be put before ooam control packet, we will want to make sure timestamp block placed before X block field for easy parsing.

So we may want to add something like: the optional Flag Indicated Field must be placed in the same sequence of Flags set.

I agree the new header should not belong to a gap analysis document.

Thanks,
Yizhou

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Friday, May 13, 2016 11:20 AM
To: [email-masked]<mailto:[email-masked]>; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: [Rtg-ooam-dt] Updated Gap Analysis document

Hi,
I haven't sent MoM from our last meeting but updated the Gap Analysis draft based on what we've discussed. You'll find the OOAM Header, Timestamp block and OOAM Ping control message added. After adding them I've realized that these likely should be in another, new document as with these we're proposing not just re-use of existing protocol, as with BFD, but introduce something new even though it looks much like LSP Ping. What do you think? Should the gap analysis then just state that existing protocols, e.g. LSP Ping, are too transport oriented and suggest the new protocol? And we can start the new draft on OOAM Ping?

Comments, suggestions, questions - most welcome and greatly appreciated.

                Regards,
                                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 17 May 2016 13:32:51 +0000

Thank you, Nagendra. I'll then join in couple minutes past 7.

Regards,
                                Greg

From: Nagendra Kumar Nainar (naikumar) [mailto:[email-masked]]
Sent: Tuesday, May 17, 2016 4:08 AM
To: Gregory Mirsky; Liyizhou; [email-masked]; Dave Dolson ([email-masked])
Subject: Re: [Rtg-ooam-dt] Updated Gap Analysis document

Hi,

I can start the meeting.

-Nagendra

Hi Yizhou,

                Regards,
                                Greg

Hi Greg,

Thanks,
Yizhou

Hi,

                Regards,
                                Greg

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Tue, 17 May 2016 15:08:41 +0000

Hi,

Thanks for the discussion. Please find the minutes below:

OOAM minutes:

  *   Agreed on having a separate document for OOAM header and format (Solution document)
  *   Team to check differnet BFD scenario (applicability and bootstrapping) for BIER/SFC/NSH/NVO3. A study to be done to see how the header/bootstrapping to be done for different overlay and include in Gap Analysis.
  *   Nagendra took SFC BFD. Deepak took NVO3. Analysis conclusion to be done by End of May 2016.

Alarm Indication Signal

  *   This one is an interesting topic for LIME working group.
  *   A simple background - Simialr to 1731. Singal from maintanance domain to upper level about any defect/failure.
  *   We need some text in this section.

Active PM

  *   There are 2 possible ways - TWAMP and RFC6374.
  *   TWAMP - Format of packet are not symmetrical and is not format friendly. But is godo in terms of otehr features like authentication etc.
  *   RFC6374 - The Format follows 1731. Might be simpler.
  *   No conclusion yet. But to be consider more on the above approach.
  *   Greg to prepare some text around this before next meeting.

Passive PM

  *   Proposal available for BIER encapsulation. This requires certain recommendation for other encapsulation.
  *   We can refer BIER and ask/propose a similar method for other encapsulation header.
  *   NVO3 WG proposed a similar one.  There is no draft, but a proposed mechanism in some slides. It includes all the 3 encapsulation. but with 1 bit in the header.
  *   NVO3 Design team is working on this. Not sure if they plan to propose anything before next IETF.

Telemetry

  *   David to share more details on Telemetry section by next meeting.
  *   To explore both active and passive mode of data collection.
  *   Telemetry needs some text to be included in Gap Analysis document and then a solution document.

Please feel free to add/modify if anything is missing.

Thanks,
Nagendra

From: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, May 17, 2016 at 9:32 AM
To: Nagendra Kumar Nainar <[email-masked]<mailto:[email-masked]>>, Liyizhou <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Dave Dolson ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Rtg-ooam-dt] Updated Gap Analysis document

Thank you, Nagendra. I’ll then join in couple minutes past 7.

Regards,
                                Greg

From: Nagendra Kumar Nainar (naikumar) [mailto:[email-masked]]
Sent: Tuesday, May 17, 2016 4:08 AM
To: Gregory Mirsky; Liyizhou; [email-masked]<mailto:[email-masked]>; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: Re: [Rtg-ooam-dt] Updated Gap Analysis document

Hi,

I can start the meeting.

-Nagendra

Hi Yizhou,

RE: our meeting tomorrow. I have another meeting that I’ll have to jump to at 8:00 a.m. Would anyone like to open the meeting and run it through all 90 minutes?

                Regards,
                                Greg

Hi Greg,

For Figure 1 Overlay OAM Header format, I think there should be a field called something like “Flag indicated field (optional)” between the length and ooam control packet.

The sequence of Flags is relevant to the sequence of “Flag indicated field”.
For example, assume we have defined T flag for “timestamp block” in ooam header flags. Then if a new flag X is defined and some new field called “X block” has to be put before ooam control packet, we will want to make sure timestamp block placed before X block field for easy parsing.

Thanks,
Yizhou

Hi,
I haven’t sent MoM from our last meeting but updated the Gap Analysis draft based on what we’ve discussed. You’ll find the OOAM Header, Timestamp block and OOAM Ping control message added. After adding them I’ve realized that these likely should be in another, new document as with these we’re proposing not just re-use of existing protocol, as with BFD, but introduce something new even though it looks much like LSP Ping. What do you think? Should the gap analysis then just state that existing protocols, e.g. LSP Ping, are too transport oriented and suggest the new protocol? And we can start the new draft on OOAM Ping?

Comments, suggestions, questions – most welcome and greatly appreciated.

                Regards,
                                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 17 May 2016 21:46:35 +0000

Hi Nagendra,
many thanks for the great minutes!

I've uploaded the current version of the gap analysis draft onto the OneDrive https://onedrive.live.com/?id=5D38B642A6E789F8%21113&cid=6E9E4CEF3CC39D35

                Regards,
                                Greg

From: Nagendra Kumar Nainar (naikumar) [mailto:[email-masked]]
Sent: Tuesday, May 17, 2016 8:09 AM
To: Gregory Mirsky; Liyizhou; [email-masked]; Dave Dolson ([email-masked])
Subject: Re: [Rtg-ooam-dt] Updated Gap Analysis document

Hi,

OOAM minutes:

Thanks,
Nagendra

Regards,
                                Greg

Hi,

I can start the meeting.

-Nagendra

Hi Yizhou,

                Regards,
                                Greg

Hi Greg,

Thanks,
Yizhou

Hi,

                Regards,
                                Greg

---

From: David Mozes <[email-masked]>
Date: Wed, 18 May 2016 10:59:07 +0000

Are this activity is align with us  ?

https://wiki.opnfv.org/display/pinpoint

Thx
David

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Wednesday, May 18, 2016 12:47 AM
To: Nagendra Kumar Nainar (naikumar) <[email-masked]>; Liyizhou <[email-masked]>; [email-masked]
Subject: Re: [Rtg-ooam-dt] Updated Gap Analysis document

Hi Nagendra,

                Regards,
                                Greg

Hi,

OOAM minutes:

Thanks,
Nagendra

Regards,
                                Greg

Hi,

I can start the meeting.

-Nagendra

Hi Yizhou,

                Regards,
                                Greg

Hi Greg,

Thanks,
Yizhou

Hi,

                Regards,
                                Greg