Subject: [Rtg-ooam-dt] Updated Gap Analysis document

From: Gregory Mirsky <[email-masked]>
Date: Fri, 13 May 2016 03:19:36 +0000

Hi,
I haven't sent MoM from our last meeting but updated the Gap Analysis draft based on what we've discussed. You'll find the OOAM Header, Timestamp block and OOAM Ping control message added. After adding them I've realized that these likely should be in another, new document as with these we're proposing not just re-use of existing protocol, as with BFD, but introduce something new even though it looks much like LSP Ping. What do you think? Should the gap analysis then just state that existing protocols, e.g. LSP Ping, are too transport oriented and suggest the new protocol? And we can start the new draft on OOAM Ping?

Comments, suggestions, questions - most welcome and greatly appreciated.

                Regards,
                                Greg

---

From: Liyizhou <[email-masked]>
Date: Fri, 13 May 2016 09:13:35 +0000

Hi Greg,

For Figure 1 Overlay OAM Header format, I think there should be a field called something like "Flag indicated field (optional)" between the length and ooam control packet.

The sequence of Flags is relevant to the sequence of "Flag indicated field".
For example, assume we have defined T flag for "timestamp block" in ooam header flags. Then if a new flag X is defined and some new field called "X block" has to be put before ooam control packet, we will want to make sure timestamp block placed before X block field for easy parsing.

So we may want to add something like: the optional Flag Indicated Field must be placed in the same sequence of Flags set.

I agree the new header should not belong to a gap analysis document.

Thanks,
Yizhou

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Friday, May 13, 2016 11:20 AM
To: [email-masked]; Dave Dolson ([email-masked])
Subject: [Rtg-ooam-dt] Updated Gap Analysis document

Hi,

                Regards,
                                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 16 May 2016 19:13:56 +0000

Hi Yizhou,
thank you for great comments. We now need at least one new draft to define the OOAM header and optional Timestamp block as the Gap Analysis, I think, should remain as informational document. And if we conclude that the new Echo Request/Reply control packet is required that may be our second draft on standards track.

Would appreciate others chiming in.

RE: our meeting tomorrow. I have another meeting that I'll have to jump to at 8:00 a.m. Would anyone like to open the meeting and run it through all 90 minutes?

                Regards,
                                Greg

From: Liyizhou [mailto:[email-masked]]
Sent: Friday, May 13, 2016 2:14 AM
To: Gregory Mirsky; [email-masked]; Dave Dolson ([email-masked])
Subject: RE: Updated Gap Analysis document

Hi Greg,

Thanks,
Yizhou

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Friday, May 13, 2016 11:20 AM
To: [email-masked]<mailto:[email-masked]>; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: [Rtg-ooam-dt] Updated Gap Analysis document

Hi,

                Regards,
                                Greg