Subject: Re: [Rtg-ooam-dt] Generic YANG Data Model for Connection Less Operations, Administration, and Maintenance(OAM) protocols

From: David Mozes <[email-masked]>
Date: Wed, 1 Jun 2016 08:42:23 +0000

Hi  * ,
Look into it  have some  beginning quotations for start  discussions

3.3.2.  Path Packet Counters

   Path-packet-counters feature is part of the passive OAM feature set,
   where the meta-data carried is to be interpreted by the passive OAM
   domain's encapsulating and decapsulating nodes.  Sequence numbers are
   the main meta-data added and can be used to detect packet loss,
   packet reordering or packet duplication.

David> Can we have more details on that :
- What is the mechanism ?
- what is the packet format  ?

3.3.3 Proof of Transit

   Proof of transit feature is part of the passive OAM feature set,
   where the path or the service chain is verified.  Service or path
   verification uses methods like nested hashing or nested encryption of
   the meta-data.  By definition of a service chain or a path, some of
   the nodes in the domain participate and some do not.

David> the same  ?

Thx
David

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Tuesday, May 31, 2016 5:45 PM
To: [email-masked]
Subject: [Rtg-ooam-dt] Generic YANG Data Model for Connection Less Operations, Administration, and Maintenance(OAM) protocols

Dear All,
I found that part on "passive OAM" in the latest version of the draft Generic YANG Data Model for Connection Less Operations, Administration, and Maintenance(OAM) protocols<https://datatracker.ietf.org/doc/draft-kumar-lime-yang-connectionless-oam/?include_text=1> is, in my opinion, about the telemetry collection. Would appreciate your reviews, comments. Feel free to share on LIME WG list as well.

                Regards,
                                Greg

---

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Sun, 5 Jun 2016 15:18:17 +0000

Hi,

Inline +++DK:

Sent from my iPhone

On Jun 5, 2016, at 7:51 AM, David Mozes <[email-masked]<mailto:[email-masked]>> wrote:

Hi Deepak ,
I saw you are the main contributor on thus draft  .
Can you share more details  ?
See my q below

Thx
David

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of David Mozes
Sent: Wednesday, June 01, 2016 11:42 AM
To: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Rtg-ooam-dt] Generic YANG Data Model for Connection Less Operations, Administration, and Maintenance(OAM) protocols

Hi  * ,

+++DK:
It's real data traffic determined by configured policy matching traffic.

3.3.3 Proof of Transit

David> the same  ?

 +++DK:

It's real data traffic determined by policy matching the traffic.

Thanks
Deepak
Thx
David

From: Rtg-ooam-dt [mailto:[email-masked]] On Behalf Of Gregory Mirsky
Sent: Tuesday, May 31, 2016 5:45 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Rtg-ooam-dt] Generic YANG Data Model for Connection Less Operations, Administration, and Maintenance(OAM) protocols

Dear All,

                Regards,
                                Greg
_______________________________________________
Rtg-ooam-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtg-ooam-dt

---

From: David Mozes <[email-masked]>
Date: Sun, 5 Jun 2016 15:34:35 +0000

Hi ,
Thx Deepak ,
There are as ecial TLV defined  ?
Is it should be done in the data path  ?

Thx
David

From: Deepak Kumar (dekumar) [mailto:[email-masked]]
Sent: Sunday, June 05, 2016 6:18 PM
To: David Mozes <[email-masked]>
Cc: [email-masked]
Subject: Re: Generic YANG Data Model for Connection Less Operations, Administration, and Maintenance(OAM) protocols

Hi,

Inline +++DK:

Sent from my iPhone

Thx
David

Hi  * ,

+++DK:

3.3.3 Proof of Transit

David> the same  ?

 +++DK:

Thanks
Deepak

Thx
David

Dear All,

                Regards,
                                Greg

---

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Mon, 6 Jun 2016 18:20:42 +0000

Hi David,

For counting for real data packet it has to be done in data path (similar to acl/Qos counters) but if packet generation is slower then it can be done in software, This is protocol and how flexible is matching criterion.

Only tracing require adding meta data to packet and that's also protocol specific.

Thanks
Deepak

On Jun 5, 2016, at 8:34 AM, David Mozes <[email-masked]<mailto:[email-masked]>> wrote:

Hi ,
Thx Deepak ,

Thx
David

From: Deepak Kumar (dekumar) [mailto:[email-masked]]
Sent: Sunday, June 05, 2016 6:18 PM
To: David Mozes <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: Generic YANG Data Model for Connection Less Operations, Administration, and Maintenance(OAM) protocols

Hi,

Inline +++DK:

Sent from my iPhone

Thx
David

Hi  * ,

+++DK:

3.3.3 Proof of Transit

David> the same  ?

 +++DK:

Thanks
Deepak

Thx
David

Dear All,

                Regards,
                                Greg

---

From: David Mozes <[email-masked]>
Date: Mon, 6 Jun 2016 19:18:23 +0000

Hi Deepak
Understood , for the trace there is meta data protocol definition ?

Is it based on INT  ?

Thx
David

From: Deepak Kumar (dekumar) [mailto:[email-masked]]
Sent: Monday, June 06, 2016 9:21 PM
To: David Mozes <[email-masked]>
Cc: [email-masked]
Subject: Re: Generic YANG Data Model for Connection Less Operations, Administration, and Maintenance(OAM) protocols

Hi David,

Thanks
Deepak

Thx
David

Hi,

Inline +++DK:

Sent from my iPhone

Thx
David

Hi  * ,

+++DK:

3.3.3 Proof of Transit

David> the same  ?

 +++DK:

Thanks
Deepak

Thx
David

Dear All,

                Regards,
                                Greg

---

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Mon, 6 Jun 2016 19:26:00 +0000

+Srihari to share link.

Thanks
Deepak

On Jun 6, 2016, at 12:18 PM, David Mozes <[email-masked]<mailto:[email-masked]>> wrote:

Hi Deepak

Is it based on INT  ?

Thx
David

Hi David,

Thanks
Deepak

Thx
David

Hi,

Inline +++DK:

Sent from my iPhone

Thx
David

Hi  * ,

+++DK:

3.3.3 Proof of Transit

David> the same  ?

 +++DK:

Thanks
Deepak

Thx
David

Dear All,

                Regards,
                                Greg

---

From: "Srihari Raghavan (srihari)" <[email-masked]>
Date: Tue, 7 Jun 2016 12:06:38 +0000

Hi all

Please take a look at https://github.com/ciscodevnet/ioam for some of the details about the in-band OAM active and ongoing research project being done currently, based on which the passive-oam aspects are being proposed.

Thanks
Srihari

From: "Deepak Kumar (dekumar)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 7 June 2016 at 12:56 AM
To: David Mozes <[email-masked]<mailto:[email-masked]>>, Cisco Employee <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: Generic YANG Data Model for Connection Less Operations, Administration, and Maintenance(OAM) protocols

+Srihari to share link.

Thanks
Deepak

Hi Deepak

Is it based on INT  ?

Thx
David

Hi David,

Thanks
Deepak

Thx
David

Hi,

Inline +++DK:

Sent from my iPhone

Thx
David

Hi  * ,

+++DK:

3.3.3 Proof of Transit

David> the same  ?

 +++DK:

Thanks
Deepak

Thx
David

Dear All,

                Regards,
                                Greg

---

From: David Mozes <[email-masked]>
Date: Tue, 7 Jun 2016 12:22:45 +0000

Thx !
Will review

David

From: Srihari Raghavan (srihari) [mailto:[email-masked]]
Sent: Tuesday, June 07, 2016 3:07 PM
To: Deepak Kumar (dekumar) <[email-masked]>; David Mozes <[email-masked]>
Cc: [email-masked]
Subject: Re: Generic YANG Data Model for Connection Less Operations, Administration, and Maintenance(OAM) protocols

Hi all

Thanks
Srihari

+Srihari to share link.

Thanks
Deepak

Is it based on INT  ?

Thx
David

Hi David,

Thanks
Deepak

Thx
David

Hi,

Inline +++DK:

Sent from my iPhone

Thx
David

Hi  * ,

+++DK:

3.3.3 Proof of Transit

David> the same  ?

 +++DK:

Thanks
Deepak

Thx
David

Dear All,

                Regards,
                                Greg