Subject: [Rtg-ooam-dt] Tentative agenda for 28/06 meeting

From: Gregory Mirsky <[email-masked]>
Date: Tue, 28 Jun 2016 00:12:56 +0000

Dear All,
we have two meeting and about 10 days till the draft cut-off submission. Would like to discuss:

*         comments from Tal (attached);

*         update to the Requirements draft;

*         update to the Gap Analysis draft;

*         scope of the new draft (Overlay Ping/Traceroute?).

On Overlay Domain Identifiers, perhaps we need the new requirement. In the gap analysis can reference RFC 6370 as work being done for MPLS-TP and conclude that work for Overlay networks yet to be done.

Please send you suggestions.

Looking forward to see you, talk to you tomorrow.

                Regards,
                                Greg

Subject: RE: Comments about the OOAM Drafts
From: Tal Mizrahi <[email-masked]>
To: Gregory Mirsky <[email-masked]>
Date: Fri, 24 Jun 2016 20:40:55 +0000

Hi Greg,

That makes sense. I will send my comments to the mailing lists at the beginning of next week.

Where can I find the details of the OOAM call?

Thanks,
Tal.

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Thursday, June 23, 2016 11:22 PM
To: Tal Mizrahi
Subject: RE: Comments about the OOAM Drafts

Hi Tal,
many thanks for taking time to review the drafts. We’re working on updates to both documents and it may be better to discuss them at our next call. We have weekly calls on Tuesday at 7:00 a.m. Pacific time (that should be 17:00 for you, right?) There’ll be two calls before the cut-off date and we can discuss your comments and address them. If you share your comments with RTGWG, NVO3, SFC, and BIER groups and join in the calls that would be most helpful. What do you think?

                Regards,
                                Greg

From: Tal Mizrahi [mailto:[email-masked]]
Sent: Thursday, June 23, 2016 4:15 AM
To: Gregory Mirsky
Subject: Comments about the OOAM Drafts

Hi Greg,

I reviewed the two OOAM drafts and I have some comments.
I wonder whether it would be best to send the comments  just to the authors, or should I send them to the RTGWG mailing list.

Cheers,
Tal.

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 28 Jun 2016 07:40:41 -0700

On the OOAM call this morning a question was raised whether we should 
present anywhere than RTFWG.

I wonder whether having an OOAM presentation in SFC would help to get 
more interest and contributions from SFC.
(I don't think we need it for BIER and NOV3 since we seem to have 
sufficient engagement with those WGs.)

Thoughts?
    Erik

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 28 Jun 2016 14:44:45 +0000

I think it’s a great idea, Erik!

— Carlos.

> On Jun 28, 2016, at 10:40 AM, Erik Nordmark <[email-masked]> wrote:
> 
> On the OOAM call this morning a question was raised whether we should present anywhere than RTFWG.
> 
> I wonder whether having an OOAM presentation in SFC would help to get more interest and contributions from SFC.
> (I don't think we need it for BIER and NOV3 since we seem to have sufficient engagement with those WGs.)
> 
> Thoughts?
>   Erik
> 
> _______________________________________________
> Rtg-ooam-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtg-ooam-dt

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 28 Jun 2016 16:53:43 +0200

Good idea!

Regards,
Jeff

> On Jun 28, 2016, at 4:40 PM, Erik Nordmark <[email-masked]> wrote:
>

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Tue, 28 Jun 2016 14:59:27 +0000

Hi Erik,

Yes. Good idea. Carlos and myself were preparing a gap analysis doc on SFC. I got some issues with he data that I am dealing with. I can share the same with the team.

Sent from my iPhone

> On Jun 28, 2016, at 10:46 AM, Carlos Pignataro (cpignata) <[email-masked]> wrote:
>

---

From: Fioccola Giuseppe <[email-masked]>
Date: Wed, 29 Jun 2016 08:57:01 +0000

Hi Erik,
Yes It is a very good idea.
If all of us agree, we could detail the marking method application in the SFC scenario, by considering some use cases.

Regards,

Giuseppe

-----Messaggio originale-----
Da: Rtg-ooam-dt [mailto:[email-masked]] Per conto di Erik Nordmark
Inviato: martedì 28 giugno 2016 16:41
A: Gregory Mirsky; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked])
Oggetto: [Rtg-ooam-dt] How to better engage SFC?

Thoughts?
    Erik

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 29 Jun 2016 19:53:27 +0000

Hi Giuseppe,

I think it would be interesting to discuss considering proposals that may be addressed using the marking method:

·         draft-browne-sfc-nsh-timestamp

·         draft-spv-ippm-monitor-implementation-services-kpi

Would you have contribution for the gap analysis document too? That would be absolutely great.

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked])
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Regards,

Giuseppe

-----Messaggio originale-----

A: Gregory Mirsky; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'

Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)

Thoughts?

    Erik

Rtg-ooam-dt mailing list

[email-masked]<mailto:[email-masked]>

---

From: Dave Dolson <[email-masked]>
Date: Wed, 29 Jun 2016 22:03:01 +0000

Recall you asked me not to submit a document to SFC, since you wanted the design team to provide guidelines.
What should I look at now as guidelines?

From: Gregory Mirsky
Sent: Wednesday, June 29, 2016 3:53 PM
To: Fioccola Giuseppe; Erik Nordmark; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson
Subject: RE: [Rtg-ooam-dt] How to better engage SFC?

Hi Giuseppe,

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked])
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Regards,

Giuseppe

-----Messaggio originale-----

Thoughts?

    Erik

Rtg-ooam-dt mailing list

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 30 Jun 2016 02:07:30 +0000

Hi Dave,
I never intended to cause any delay to your draft. I believe that discussion with the DT would benefit us all and hence I've been inviting you to take part in our weekly meetings. My apologies if I wasn't clear about that.

	Regards,
		Greg

-----Original Message-----
From: Dave Dolson [mailto:[email-masked]] 
Sent: Wednesday, June 29, 2016 3:03 PM
To: Gregory Mirsky; Fioccola Giuseppe; Erik Nordmark; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi
Subject: Re: [Rtg-ooam-dt] How to better engage SFC?

From: Gregory Mirsky

Hi Giuseppe,

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked])
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Regards,

Giuseppe

-----Messaggio originale-----

Thoughts?

    Erik

Rtg-ooam-dt mailing list

---

From: Dave Dolson <[email-masked]>
Date: Thu, 30 Jun 2016 03:18:18 +0000

Greg,

I think my question came across the wrong way.

I'd like to work on SFC path health checking. How can I best move forward?

(Sorry I was unable to attend the meeting this week.)

-Dave

-----Original Message-----
From: Gregory Mirsky [mailto:[email-masked]] 
Sent: Wednesday, June 29, 2016 10:08 PM
To: Dave Dolson; Fioccola Giuseppe; Erik Nordmark; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi
Subject: RE: [Rtg-ooam-dt] How to better engage SFC?

Hi Dave,

	Regards,
		Greg

-----Original Message-----
From: Dave Dolson [mailto:[email-masked]] 
Sent: Wednesday, June 29, 2016 3:03 PM
To: Gregory Mirsky; Fioccola Giuseppe; Erik Nordmark; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi
Subject: Re: [Rtg-ooam-dt] How to better engage SFC?

From: Gregory Mirsky

Hi Giuseppe,

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked])
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Regards,

Giuseppe

-----Messaggio originale-----

Thoughts?

    Erik

Rtg-ooam-dt mailing list

---

From: Fioccola Giuseppe <[email-masked]>
Date: Thu, 30 Jun 2016 10:05:58 +0000

Hi Greg, All
That's for sure! I appreciate your consideration.
The documents you suggested are precious.
In particular, draft-browne-sfc-nsh-timestamp could be considered for the timestamping of NSH packets and be combined to the marking method very well.
The proposed extension to TWAMP to carry services KPI data, proposed in draft-spv-ippm-monitor-implementation-services-kpi, is also suitable for the purpose.
And draft-agv-sfc-performance-measurement-architecture should be the reference for the PM architecture for SFCs

If all of us agree, I could propose some text for the "PM over SFP" Section of the gap analysis document with reference to draft-ietf-ippm-alt-mark and documents quoted above.
I could send you proposed text before next Tuesday call.

Best Regards,

Giuseppe

Da: Gregory Mirsky [mailto:[email-masked]]
Inviato: mercoledì 29 giugno 2016 21:53
A: Fioccola Giuseppe; Erik Nordmark; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked])
Oggetto: RE: [Rtg-ooam-dt] How to better engage SFC?

Hi Giuseppe,

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Regards,

Giuseppe

-----Messaggio originale-----

Thoughts?

    Erik

Rtg-ooam-dt mailing list

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 30 Jun 2016 19:28:13 +0000

Hi Giuseppe,
thank you for volunteering to help with PM story. It would be great to make it about the marking method in SFC pointing to flexibility of placing the Test Point either at Classifier, SF or SFF. And, as done in PM with the Marking Method in BIER Layer, demonstrate benefit of two-bit long vs. one-bit long field for marking.

As for the listed drafts I have serious concerns that I'll sum and share with the team before our meeting next Tuesday. I'd like to look not into particular solutions described in these drafts but for the problems they are addressing. I think these are real-life problems and we can propose solutions to, solutions based on Common Overlay OAM.

                Regards,
                                Greg

From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Thursday, June 30, 2016 3:06 AM
To: Gregory Mirsky; Erik Nordmark; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked])
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Greg, All

Best Regards,

Giuseppe

A: Fioccola Giuseppe; Erik Nordmark; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'

Hi Giuseppe,

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Regards,

Giuseppe

-----Messaggio originale-----

Thoughts?

    Erik

Rtg-ooam-dt mailing list