Subject: Re: [Rtg-ooam-dt] [nvo3] Comments to OOAM Requirements draft from Ron Bonica

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Mon, 4 Jul 2016 10:27:11 +0000

Hi Greg,

I have following queries on  Overlay OAM Requirements<https://tools.ietf.org/html/draft-ooamdt-rtgwg-ooam-requirement-00>:

>>>>> REQ#6:  Overlay OAM packets SHOULD be fate sharing with data traffic,
            i.e. in-band with the monitored traffic, i.e. follow exactly
            the same path as data plane traffic, in forward direction,
            i.e. from ingress toward egress end point(s) of the OAM test
            session.

"Exactly same path", should be made explicit if it's referring to the underlay transport path.

"OAM packets SHOULD be fate sharing with data traffic" will not apply to "REQ#3:  centralized controller".
I think "SHOULD" should be treated as a "MUST" if the reference is within the document :)

>>>>> REQ#11: Overlay OAM MUST support fault localization of Loss of
            Continuity check.

Does the "localization" maps to overlay node/link context ? Can we have a "MAY" requirement for mapping
it to underlay. Since in datacenter, with more of east-west traffic, there might be deployment requirement
to narrow down to underlay for a speedier fault management.

REQ#22 - REQ#25 refer to "per-segment".
A "segment" maps to a NVO-tunnel?  Shouldn't there be on a  per-VNI basis as well.

>>>>> REQ#7:  Overlay OAM MUST support bi-directional OAM methods.  Such
            OAM methods MAY combine in-band monitoring or measurement in
            forward direction and out-of-band notification in the
            reverse direction, i.e. from egress to ingress end point of
            the OAM test session.

In case of optical deployments like, fiber management (both request and response) can be out-of-band, hence may
need a mention here.

Thanks
Saumya

From: nvo3 <[email-masked]<mailto:[email-masked]>> on behalf of Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 5, 2016 at 1:39 AM
To: "BIER ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [nvo3] Comments to OOAM Requirements draft from Ron Bonica

Dear All,
Ron reviewed the Overlay OAM Requirements<https://tools.ietf.org/html/draft-ooamdt-rtgwg-ooam-requirement-00> draft and shared his comments under RB> tag. The attached copy has my responses in under GIM> tag as well. We invite members of BIER, NVO3, SCC and RTG WGs to join in the discussion. Appreciate you review, comments on OOAM Requirements draft and OAM for Overlay Networks: Gap Analysis.

                Regards,
                                Greg

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Mon, 4 Jul 2016 11:09:26 +0000

HI Saumya,

Please see inline..

Hi Greg,

<Nagendra> Yes, that is the intention. We will clarify it.

            Continuity check.

<Nagendra> MAY statement sounds reasonable.

REQ#22 - REQ#25 refer to "per-segment".
A "segment" maps to a NVO-tunnel?

<Nagendra> Yes, a segment referes to NVO tunnel between NVEs. Multiple such segments may comprise an end-to-end tunnel.

 Shouldn't there be on a  per-VNI basis as well.

<Nagendra>I think  the granularity should definitely at per-VNI level.

In case of optical deployments like, fiber management (both request and response) can be out-of-band, hence may
need a mention here.
<Nagendra> I see. We will check this.

Thanks for your comments.

Regards,
Nagendra

Thanks
Saumya

Dear All,

                Regards,
                                Greg

---

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Mon, 4 Jul 2016 18:09:02 +0000

Hi Nagendra,

Thanks for the response. I missed this one in the below email:

>>>>> REQ#14: Overlay OAM MUST have the ability to discover and exercise
            equal cost multipath (ECMP) paths in its transport network.

This will require the underlay nodes/router/switches to support OAM semantics, which may not be possible
in case of brownfield deployments (deploying NVO tunnels over existing IP-core network).

Regards,
Saumya.

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 4, 2016 at 4:39 PM
To: sadikshi <[email-masked]<mailto:[email-masked]>>, Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, "BIER ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Bier] [nvo3] Comments to OOAM Requirements draft from Ron Bonica

HI Saumya,

Please see inline..

Hi Greg,

            Continuity check.

Regards,
Nagendra

Thanks
Saumya

Dear All,

                Regards,
                                Greg

---

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Wed, 20 Jul 2016 13:03:17 +0000

Hi Greg, Authors of ooam-dt set of drafts

Other than current requirements, it will be great to explicitly support the OAM PDU semantics.

  *   apply OAM function_set to group of VNI or band of VNI’s and this information carried in same OAM PDU. Although the response can be discrete on a per VNI basis based on how and where the response is triggered from. If It’s proxy from remote NVE, then the response can be a replication to the request. This is will reduce the number of probes which need to be send to perform the OAM functions.
  *   It will be great to designate VNI’s as L2 or L3 and apply function_Set to them. This is implicitly derived in data-path, but for OAM PDUs, it will help to make it explicit either via using some flags or some other semantics. Hence we can carry bunch of L2 and L3 vnis with corresponding function-set

In case these are valid requirements, which I feel they are. Can they find a place in existing document.
I can also come out with a peripheral draft defining these.

Thanks
Saumya.

From: nvo3 <[email-masked]<mailto:[email-masked]>> on behalf of sadikshi <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 4, 2016 at 8:09 PM
To: "Nagendra Kumar Nainar (naikumar)" <[email-masked]<mailto:[email-masked]>>, Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, "BIER ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [nvo3] [Bier] Comments to OOAM Requirements draft from Ron Bonica

Hi Nagendra,

Regards,
Saumya.

HI Saumya,

Please see inline..

Hi Greg,

“Exactly same path”, should be made explicit if it’s referring to the underlay transport path.

"OAM packets SHOULD be fate sharing with data traffic” will not apply to "REQ#3:  centralized controller”.
I think “SHOULD” should be treated as a “MUST” if the reference is within the document :)

            Continuity check.

Does the “localization” maps to overlay node/link context ? Can we have a “MAY” requirement for mapping
it to underlay. Since in datacenter, with more of east-west traffic, there might be deployment requirement
to narrow down to underlay for a speedier fault management.

REQ#22 — REQ#25 refer to “per-segment”.
A “segment” maps to a NVO-tunnel?

 Shouldn’t there be on a  per-VNI basis as well.

Regards,
Nagendra

Thanks
Saumya

Dear All,

                Regards,
                                Greg

---

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Thu, 21 Jul 2016 22:07:17 +0000

Hi,

Below requirement looks like deal with ability of OAM to be extensible. We should add requirement regarding Extensibility for OAM protocol without adding details of VNI, etc.

Thanks,
Deepak

From: Rtg-ooam-dt <[email-masked]<mailto:[email-masked]>> on behalf of "Saumya Dikshit (sadikshi)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 20, 2016 at 6:03 AM
To: "Saumya Dikshit (sadikshi)" <[email-masked]<mailto:[email-masked]>>, "Nagendra Kumar Nainar (naikumar)" <[email-masked]<mailto:[email-masked]>>, Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, "BIER ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-ooam-dt] [nvo3] [Bier] Comments to OOAM Requirements draft from Ron Bonica

Thanks
Saumya.

Hi Nagendra,

Regards,
Saumya.

HI Saumya,

Please see inline..

Hi Greg,

            Continuity check.

Regards,
Nagendra

Thanks
Saumya

Dear All,

                Regards,
                                Greg

---

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Thu, 21 Jul 2016 22:44:00 +0000

Thanks Deepak. I think we should also new define TLVs in draft-ooamdt-rtgwg-ooam-header or any alternative publication addressing the requirement.

From: "Deepak Kumar (dekumar)" <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 22, 2016 at 12:07 AM
To: sadikshi <[email-masked]<mailto:[email-masked]>>, "Nagendra Kumar Nainar (naikumar)" <[email-masked]<mailto:[email-masked]>>, Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, "BIER ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-ooam-dt] [nvo3] [Bier] Comments to OOAM Requirements draft from Ron Bonica

Hi,

Thanks,
Deepak

Thanks
Saumya.

Hi Nagendra,

Regards,
Saumya.

HI Saumya,

Please see inline..

Hi Greg,

            Continuity check.

Regards,
Nagendra

Thanks
Saumya

Dear All,

                Regards,
                                Greg

---

From: "Saumya Dikshit (sadikshi)" <[email-masked]>
Date: Wed, 27 Jul 2016 23:13:12 +0000

Hello Authors,

Please do know your views on having these requirements as part of the document, as deepak also mentioned in the below format.

Thanks
Saumya.

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of sadikshi <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 22, 2016 at 12:44 AM
To: "Deepak Kumar (dekumar)" <[email-masked]<mailto:[email-masked]>>, "Nagendra Kumar Nainar (naikumar)" <[email-masked]<mailto:[email-masked]>>, Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, "BIER ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-ooam-dt] [nvo3] [Bier] Comments to OOAM Requirements draft from Ron Bonica

Hi,

Thanks,
Deepak

Thanks
Saumya.

Hi Nagendra,

Regards,
Saumya.

HI Saumya,

Please see inline..

Hi Greg,

            Continuity check.

Regards,
Nagendra

Thanks
Saumya

Dear All,

                Regards,
                                Greg