Subject: Re: [Rtg-ooam-dt] OOAM Ping update

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Fri, 8 Jul 2016 14:53:47 +0000

Hi,

"Reply to Sender" looks reasonable and applicable for most cases. Comments?

Onething I have also noticied is that for out of band reply, if it's in different vrf (other than incoming packet, management or default) how we can handle it? We will need a TLV to add vrf information.

Thanks,
Deepak

From: Rtg-ooam-dt <[email-masked]<mailto:[email-masked]>> on behalf of Dave Dolson <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 8, 2016 at 7:43 AM
To: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-ooam-dt] OOAM Ping update

OOAM Design team,

Would it be reasonable to add a Reply Mode of "Respond to Sender", which is applicable in some cases?

I outlined my SFC use-case for SFFs probing the liveliness of SFs, which is not met by either "Do not reply" or "Reply via IPv4/IPv6 UDP packet".

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Wednesday, July 06, 2016 5:00 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Dave Dolson; Tal Mizrahi
Subject: OOAM Ping update

Dear All,
I've expanded IANA section and added text to how the Reply Mode field controls/instructs the responding overlay node.

Please review, share your comments, suggestions.

                Regards,
                                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Sat, 9 Jul 2016 07:21:40 +0000

Hi Deepak, Dave, et. al,
the interpretation of the "Reply via IPv4/IPv6 UDP packet", will make it clearer in the next version, is "Reply to the Sender". And that is what may be used with proxy Echo Request. I've planned to add it in the next update as need to understand whether overlay encapsulations carry Sender ID. And the Proxy Echo Request/Reply are distinct Message Types. And then, if we continue with functional analogy to LSP Ping, Sender may define the return path thus sending Echo Reply to the third party altogether.

                Regards,
                                Greg

From: Deepak Kumar (dekumar) [mailto:[email-masked]]
Sent: Friday, July 08, 2016 7:54 AM
To: Dave Dolson <[email-masked]>; Gregory Mirsky <[email-masked]>; [email-masked]
Cc: Tal Mizrahi <[email-masked]>
Subject: Re: [Rtg-ooam-dt] OOAM Ping update

Hi,

Thanks,
Deepak

OOAM Design team,

Dear All,

                Regards,
                                Greg

---

From: Dave Dolson <[email-masked]>
Date: Sat, 9 Jul 2016 13:07:19 +0000

I should have been clearer; I'm asking for in-band reply, which is possible on some overlay technologies.

From: Gregory Mirsky
Sent: Saturday, July 9, 2016 3:21 AM
To: Deepak Kumar (dekumar); Dave Dolson; [email-masked]
Cc: Tal Mizrahi
Subject: RE: [Rtg-ooam-dt] OOAM Ping update

Hi Deepak, Dave, et. al,
the interpretation of the “Reply via IPv4/IPv6 UDP packet”, will make it clearer in the next version, is “Reply to the Sender”. And that is what may be used with proxy Echo Request. I’ve planned to add it in the next update as need to understand whether overlay encapsulations carry Sender ID. And the Proxy Echo Request/Reply are distinct Message Types. And then, if we continue with functional analogy to LSP Ping, Sender may define the return path thus sending Echo Reply to the third party altogether.

                Regards,
                                Greg

Hi,

Thanks,
Deepak

OOAM Design team,

Would it be reasonable to add a Reply Mode of “Respond to Sender”, which is applicable in some cases?

I outlined my SFC use-case for SFFs probing the liveliness of SFs, which is not met by either “Do not reply” or “Reply via IPv4/IPv6 UDP packet”.

Dear All,
I’ve expanded IANA section and added text to how the Reply Mode field controls/instructs the responding overlay node.

                Regards,
                                Greg

---

From: Gregory Mirsky <[email-masked]>
Date: Sat, 9 Jul 2016 18:29:43 +0000

Hi Dave,
you're right, some overlays may be interested in using in-band relies. The plan is to add Reply Over Control Channel to the Reply Modes and have new Return Path TLV for different path specification types via sub-TLV. We can have section Future Work in our presentation to mention this.

	Regards,
		Greg

-----Original Message-----
From: Dave Dolson [mailto:[email-masked]] 
Sent: Saturday, July 09, 2016 6:07 AM
To: Gregory Mirsky <[email-masked]>; Deepak Kumar (dekumar) <[email-masked]>; [email-masked]
Cc: Tal Mizrahi <[email-masked]>
Subject: Re: [Rtg-ooam-dt] OOAM Ping update

From: Gregory Mirsky

Hi Deepak, Dave, et. al,

                Regards,
                                Greg

Hi,

Thanks,
Deepak

OOAM Design team,

Dear All,

                Regards,
                                Greg