Subject: [Rtg-ooam-dt] R: How to better engage SFC?

From: Fioccola Giuseppe <[email-masked]>
Date: Fri, 1 Jul 2016 09:30:44 +0000

Hi Greg,
Excellent, we'll discuss the problems these drafts are addressing next Tuesday.

Regarding marking method application in SFC, what is you plan for now?
Is a contribution for the gap analysis document good for this goal? or are you thinking of a new draft as is in BIER?

Regards,

Giuseppe

Da: Gregory Mirsky [mailto:[email-masked]]
Inviato: giovedì 30 giugno 2016 21:28
A: Fioccola Giuseppe; Erik Nordmark; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked])
Oggetto: RE: [Rtg-ooam-dt] How to better engage SFC?

Hi Giuseppe,
thank you for volunteering to help with PM story. It would be great to make it about the marking method in SFC pointing to flexibility of placing the Test Point either at Classifier, SF or SFF. And, as done in PM with the Marking Method in BIER Layer, demonstrate benefit of two-bit long vs. one-bit long field for marking.

As for the listed drafts I have serious concerns that I'll sum and share with the team before our meeting next Tuesday. I'd like to look not into particular solutions described in these drafts but for the problems they are addressing. I think these are real-life problems and we can propose solutions to, solutions based on Common Overlay OAM.

                Regards,
                                Greg

From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Thursday, June 30, 2016 3:06 AM
To: Gregory Mirsky; Erik Nordmark; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Greg, All
That's for sure! I appreciate your consideration.
The documents you suggested are precious.
In particular, draft-browne-sfc-nsh-timestamp could be considered for the timestamping of NSH packets and be combined to the marking method very well.
The proposed extension to TWAMP to carry services KPI data, proposed in draft-spv-ippm-monitor-implementation-services-kpi, is also suitable for the purpose.
And draft-agv-sfc-performance-measurement-architecture should be the reference for the PM architecture for SFCs

If all of us agree, I could propose some text for the "PM over SFP" Section of the gap analysis document with reference to draft-ietf-ippm-alt-mark and documents quoted above.
I could send you proposed text before next Tuesday call.

Best Regards,

Giuseppe

Da: Gregory Mirsky [mailto:[email-masked]]
Inviato: mercoledì 29 giugno 2016 21:53
A: Fioccola Giuseppe; Erik Nordmark; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Oggetto: RE: [Rtg-ooam-dt] How to better engage SFC?

Hi Giuseppe,

I think it would be interesting to discuss considering proposals that may be addressed using the marking method:

·         draft-browne-sfc-nsh-timestamp

·         draft-spv-ippm-monitor-implementation-services-kpi

Would you have contribution for the gap analysis document too? That would be absolutely great.

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Yes It is a very good idea.

If all of us agree, we could detail the marking method application in the SFC scenario, by considering some use cases.

Regards,

Giuseppe

-----Messaggio originale-----

Da: Rtg-ooam-dt [mailto:[email-masked]] Per conto di Erik Nordmark

Inviato: martedì 28 giugno 2016 16:41

A: Gregory Mirsky; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'

Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)

Oggetto: [Rtg-ooam-dt] How to better engage SFC?

On the OOAM call this morning a question was raised whether we should present anywhere than RTFWG.

I wonder whether having an OOAM presentation in SFC would help to get more interest and contributions from SFC.

(I don't think we need it for BIER and NOV3 since we seem to have sufficient engagement with those WGs.)

Thoughts?

    Erik

_______________________________________________

Rtg-ooam-dt mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/rtg-ooam-dt

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 1 Jul 2016 13:47:17 +0000

Hi Giuseppe,
I was thinking that it would be logical in the gap analysis with conclusion that allocating field for the marking in an overlay header enables use of such flexible measurement method in passive-like OAM manner.

                Regards,
                                Greg

From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Friday, July 01, 2016 2:31 AM
To: Gregory Mirsky; Erik Nordmark; [email-masked]; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked])
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Greg,

Regards,

Giuseppe

Hi Giuseppe,

                Regards,
                                Greg

Hi Greg, All

Best Regards,

Giuseppe

Hi Giuseppe,

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Regards,

Giuseppe

-----Messaggio originale-----

Thoughts?

    Erik

Rtg-ooam-dt mailing list

---

From: Fioccola Giuseppe <[email-masked]>
Date: Fri, 1 Jul 2016 14:47:17 +0000

Hi Greg,
Nice, I will propose a paragraph by Tuesday.

Thanks,

Giuseppe

Inviato: venerdì 1 luglio 2016 15:47

Hi Giuseppe,

                Regards,
                                Greg

Hi Greg,

Regards,

Giuseppe

Hi Giuseppe,

                Regards,
                                Greg

Hi Greg, All

Best Regards,

Giuseppe

Hi Giuseppe,

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Regards,

Giuseppe

-----Messaggio originale-----

Thoughts?

    Erik

Rtg-ooam-dt mailing list

---

From: Fioccola Giuseppe <[email-masked]>
Date: Mon, 4 Jul 2016 15:00:34 +0000

Hi All,
You can find below the proposed text for the gap analysis document that we can discuss tomorrow:

3.2.2.1.  Passive PM in BIER
[I-D.mirsky-bier-pmmm-oam] describes how the Marking Method can be used in BIER domain over MPLS networks.

3.2.2.2.  Passive PM in NVO3
The Generic Protocol Extension for VXLAN [I-D.ietf-nvo3-vxlan-gpe], Generic Network Virtualization Encapsulation [I-D.ietf-nvo3-geneve], Generic UDP Encapsulation [I-D.draft-ietf-nvo3-gue] are just some examples of the new encapsulations to support network virtualization.
NVO3 PM would be used to probe the NV Edge to NV Edge tunnels and NV Edge entity status for a DC network.
The main requirement for Performance Management is to support measurement of per VNI frame loss, delay and delay variation between two NV Edge devices that support the same VNI within a given NVO3 domain. Alternate Marking Method [I-D.ietf-ippm-alt-mark] allows these metrics efficiently.
Marking Method has been discussed in NVO3 sessions, but there is no draft in the working group.

3.2.2.3.  Passive PM over SFP
In the SFC architecture SF, SFF, Classifier and NSH Proxy Agent are the elements that can incorporate the measurement agent functionality to support SFC performance measurement.
The required OAM Performance Measurement, as described in [I-D.ietf-sfc-oam-framework], highlight the capability to assess the monitoring at SF and SFF or a Set of SF/SFF, both in case of SFC-aware SF and SFC-unaware SF; the monitoring of SFP (and RSP) that comprises a set of SFs that may be ordered or unordered; the monitoring of the Classifiers operation and the monitoring of the SFC as a whole.
The Alternate Marking Method for passive performance monitoring can be used for all these cases .
Performance management functions involve measuring of packet loss, delay, delay variance and could be well performed by the marking method proposed in [I-D.ietf-ippm-alt-mark].

Best Regards,

Giuseppe

Da: Rtg-ooam-dt [mailto:[email-masked]] Per conto di Fioccola Giuseppe
Inviato: venerdì 1 luglio 2016 16:47
A: Gregory Mirsky; Erik Nordmark; [email-masked]; 'Alia Atlas'
Cc: Dave Dolson ([email-masked]); Tal Mizrahi
Oggetto: [Rtg-ooam-dt] R: How to better engage SFC?

Hi Greg,

Thanks,

Giuseppe

Hi Giuseppe,

                Regards,
                                Greg

Hi Greg,

Regards,

Giuseppe

Hi Giuseppe,

                Regards,
                                Greg

Hi Greg, All

Best Regards,

Giuseppe

Hi Giuseppe,

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Regards,

Giuseppe

-----Messaggio originale-----

Thoughts?

    Erik

Rtg-ooam-dt mailing list

---

From: Dave Dolson <[email-masked]>
Date: Mon, 4 Jul 2016 16:43:18 +0000

I see that the SFC chairs are still looking for content for the SFC meeting in Berlin.
Does this group want to discuss OOAM in the SFC meeting?

From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Monday, July 04, 2016 11:01 AM
To: Gregory Mirsky; Erik Nordmark; [email-masked]; 'Alia Atlas'
Cc: Dave Dolson; Tal Mizrahi
Subject: R: [Rtg-ooam-dt] R: How to better engage SFC?

Hi All,

Best Regards,

Giuseppe

Da: Rtg-ooam-dt [mailto:[email-masked]] Per conto di Fioccola Giuseppe
Inviato: venerdì 1 luglio 2016 16:47
A: Gregory Mirsky; Erik Nordmark; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'
Cc: Dave Dolson ([email-masked]<mailto:[email-masked]>); Tal Mizrahi
Oggetto: [Rtg-ooam-dt] R: How to better engage SFC?

Hi Greg,

Thanks,

Giuseppe

Hi Giuseppe,

                Regards,
                                Greg

Hi Greg,

Regards,

Giuseppe

Hi Giuseppe,

                Regards,
                                Greg

Hi Greg, All

Best Regards,

Giuseppe

Hi Giuseppe,

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Regards,

Giuseppe

-----Messaggio originale-----

Thoughts?

    Erik

Rtg-ooam-dt mailing list

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 5 Jul 2016 02:23:42 +0000

Hi Giuseppe,
the most helpful, thank you. I've used some in the conclusion to point to the fact that encapsulation of an overlay network should provide special field so that marking method behaves as passive OAM as defined in RFC 7799 (added as reference). Perhaps we can reference BIER in MPLS encapsulation as example  that enables use of the marking method as passive PM OAM.

                Regards,
                                Greg

Sent: Monday, July 04, 2016 8:01 AM

Hi All,

Best Regards,

Giuseppe

Hi Greg,

Thanks,

Giuseppe

Hi Giuseppe,

                Regards,
                                Greg

Hi Greg,

Regards,

Giuseppe

Hi Giuseppe,

                Regards,
                                Greg

Hi Greg, All

Best Regards,

Giuseppe

Hi Giuseppe,

                Regards,

                                Greg

-----Original Message-----
From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Wednesday, June 29, 2016 1:57 AM
To: Erik Nordmark; Gregory Mirsky; [email-masked]<mailto:[email-masked]>; 'Alia Atlas'
Cc: Tal Mizrahi; Dave Dolson ([email-masked]<mailto:[email-masked]>)
Subject: R: [Rtg-ooam-dt] How to better engage SFC?

Hi Erik,

Regards,

Giuseppe

-----Messaggio originale-----

Thoughts?

    Erik

Rtg-ooam-dt mailing list