Subject: RE: Review Call: draft-hsmit-mpls-igp-spf-01.txt

From: "Manfredi, Albert E" <[email-masked]>
Date: Sat, 20 Mar 2004 18:36:29 -0500

This reminds me of the ATM shortcut I-D of years ago. One issue with that concept was proof of being loop-free, and another was that security holes might occur if certain routers along the path are allowed to be bypassed. But I always found the idea very interesting, and again here.

Anyway, I believe this is a typo?

4. Enhancement to the Shortest Path First computation

   During each step of the SPF computation, a router discovers the path
   to one node in the network. If that node is directly connected to the
   calculating router, the first-hop information is derived from the
   adjacency database. If a node is not directly connected to the
   calculating router, it ***inherents*** the first-hop information from the
   parent(s) of that node.

Assume that's meant to be "inherits," yes?

Bert

> -----Original Message-----
> From: Alex Zinin [mailto:[email-masked]]
> Sent: Friday, March 19, 2004 8:51 PM
> To: [email-masked]
> Subject: Review Call: draft-hsmit-mpls-igp-spf-01.txt
> 
> 
> Folks-
> 
>  In preparation for the WG Last Call that will be started in 
> a few weeks, we
>  would like to solicit reviews of the 
> draft-hsmit-mpls-igp-spf-01.txt document.
>  The document is a WG item with the target status as an 
> Informational RFC.
> 
>  Abstract below:
> 
>    This document describes how conventional hop-by-hop link-state
>    routing protocols interact with new Traffic Engineering 
> capabilities
>    to create IGP shortcuts.  In particular this document describes how
>    Dijkstra's SPF algorithm should be adapted so that link-state IGPs
>    will calculate IP routes to forward traffic over tunnels that are
>    set up by Traffic Engineering.
> 
>  The document is available at
>  http://www.ietf.org/internet-drafts/draft-hsmit-mpls-igp-spf-01.txt
>    
>  Please send your comments to [email-masked]
>    
> -- 
> Alex
> http://www.psg.com/~zinin/
> 
> 
> _______________________________________________
> Rtgwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/rtgwg
> 

_______________________________________________
Rtgwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/rtgwg

---

From: Naiming Shen <[email-masked]>
Date: Sat, 20 Mar 2004 23:33:09 -0800

Bert,

 ] This reminds me of the ATM shortcut I-D of years ago. One issue with  ] that concept was proof of being loop-free,

Since we are sending traffic to a downstream node, or to a downstream's
downstream nodes, it has to be loop-free in the steady state. Allowing
the traffic to pass multi nodes in the middle to reach the same
tunnel-end node should not change the loop status. Although this
is not a formal proof;-)

 ] and another was that security  ] holes might occur if certain routers along the path are allowed to be  ] bypassed. But I always found the idea very interesting, and again here.

The IGP is running in the same area/level, usually is admined by
the same organization. If in some weired cases a provider runs IGP
to it's customers and also allow their customers setting MPLS TEs
directly into their center of the backbone nodes, then we have to
assume those providers know how to check security on those backbone nodes...

 ] 
 ] Anyway, I believe this is a typo?
 ] 
 ] 4. Enhancement to the Shortest Path First computation
 ] 
 ]    During each step of the SPF computation, a router discovers the path
 ]    to one node in the network. If that node is directly connected to the
 ]    calculating router, the first-hop information is derived from the
 ]    adjacency database. If a node is not directly connected to the
 ]    calculating router, it ***inherents*** the first-hop information from  ] the
 ]    parent(s) of that node.
 ] 
 ] Assume that's meant to be "inherits," yes?

yes, this is a typo, will correct that.

thanks!

 ] 
 ] Bert
 ] 
 ] 
 ] > -----Original Message-----
 ] > From: Alex Zinin [mailto:[email-masked]]
 ] > Sent: Friday, March 19, 2004 8:51 PM
 ] > To: [email-masked]
 ] > Subject: Review Call: draft-hsmit-mpls-igp-spf-01.txt
 ] > 
 ] > 
 ] > Folks-
 ] > 
 ] >  In preparation for the WG Last Call that will be started in 
 ] > a few weeks, we
 ] >  would like to solicit reviews of the 
 ] > draft-hsmit-mpls-igp-spf-01.txt document.
 ] >  The document is a WG item with the target status as an 
 ] > Informational RFC.
 ] > 
 ] >  Abstract below:
 ] > 
 ] >    This document describes how conventional hop-by-hop link-state
 ] >    routing protocols interact with new Traffic Engineering 
 ] > capabilities
 ] >    to create IGP shortcuts.  In particular this document describes how
 ] >    Dijkstra's SPF algorithm should be adapted so that link-state IGPs
 ] >    will calculate IP routes to forward traffic over tunnels that are
 ] >    set up by Traffic Engineering.
 ] > 
 ] >  The document is available at
 ] >  http://www.ietf.org/internet-drafts/draft-hsmit-mpls-igp-spf-01.txt
 ] >    
 ] >  Please send your comments to [email-masked]
 ] >    
 ] > -- 
 ] > Alex
 ] > http://www.psg.com/~zinin/
 ] > 
 ] > 
 ] > _______________________________________________
 ] > Rtgwg mailing list
 ] > [email-masked]
 ] > https://www1.ietf.org/mailman/listinfo/rtgwg
 ] > 
 ] 
 ] _______________________________________________
 ] Rtgwg mailing list
 ] [email-masked]
 ] https://www1.ietf.org/mailman/listinfo/rtgwg

- Naiming