Subject: Question on draft-ietf-rtgwg-routing-types

From: "Susan Hares" <[email-masked]>
Date: Wed, 29 Mar 2017 11:35:59 -0400

RTGWG DT: 

Just curious, did the DT consider BGP routing types?  If so, where did you
decide BGP routing types were not common routing types?  

Sue

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 29 Mar 2017 15:46:32 +0000

Hi Sue,
We incorporated the types that were required for L3VPN/L2VPN models. Specifically, route-distinguisher, route-target, route-target-type, and the vpn-route-target. There was an extensive discussion with the authors of these models.
Thanks,
Acee

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 29, 2017 at 10:35 AM
To: Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: Question on draft-ietf-rtgwg-routing-types

RTGWG DT:

Just curious, did the DT consider BGP routing types?  If so, where did you decide BGP routing types were not common routing types?

Sue

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 29 Mar 2017 11:57:21 -0400

Acee: 

Thank you.   Just to clarify your answer, does mean you had a discussion
with the operators (e.g. openconfig) who implement the basic BGP model as
well? 

Sue  

From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: Wednesday, March 29, 2017 11:47 AM
To: Susan Hares; [email-masked]
Subject: Re: Question on draft-ietf-rtgwg-routing-types

Hi Sue, 

We incorporated the types that were required for L3VPN/L2VPN models.
Specifically, route-distinguisher, route-target, route-target-type, and the
vpn-route-target. There was an extensive discussion with the authors of
these models. 

Thanks,

Acee

From: rtgwg <[email-masked]> on behalf of Susan Hares
<[email-masked]>
Date: Wednesday, March 29, 2017 at 10:35 AM
To: Routing WG <[email-masked]>
Subject: Question on draft-ietf-rtgwg-routing-types

RTGWG DT: 

Sue

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 29 Mar 2017 16:11:56 +0000

From: Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 29, 2017 at 10:57 AM
To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: Question on draft-ietf-rtgwg-routing-types

Acee:

Thank you.   Just to clarify your answer, does mean you had a discussion with the operators (e.g. openconfig) who implement the basic BGP model as well?

If you have looked OpenConfig models in Github, they have their own factoring of types. The bigger question of OpenConfig and IETF models is certainly not addressed by this model.

Acee

Sue

From: Acee Lindem (acee) [mailto:[email-masked]]
Sent: Wednesday, March 29, 2017 11:47 AM
To: Susan Hares; [email-masked]<mailto:[email-masked]>
Subject: Re: Question on draft-ietf-rtgwg-routing-types

Hi Sue,

RTGWG DT:

Sue

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 29 Mar 2017 12:19:04 -0400

Acee: 

I was querying about operational experience with
draft-ietf-rtgwg-routing-types as input for IDR.  IDR has adopted BGP model
that predates this work. 

Sue 

From: Acee Lindem (acee) [mailto:[email-masked]] 
Sent: Wednesday, March 29, 2017 12:12 PM
To: Susan Hares; [email-masked]
Subject: Re: Question on draft-ietf-rtgwg-routing-types

From: Susan Hares <[email-masked]>
Date: Wednesday, March 29, 2017 at 10:57 AM
To: Acee Lindem <[email-masked]>, Routing WG <[email-masked]>
Subject: RE: Question on draft-ietf-rtgwg-routing-types

Acee: 

If you have looked OpenConfig models in Github, they have their own
factoring of types. The bigger question of OpenConfig and IETF models is
certainly not addressed by this model. 

Acee 

Sue  

Hi Sue, 

Thanks,

Acee

RTGWG DT: 

Sue