Subject: New Document

From: Sanjiv Kapoor <[email-masked]>
Date: Wed, 15 Mar 2017 16:18:12 -0500

A new  Internet Draft

   https://www.ietf.org/internet-drafts/draft-kapoor-rtgwg-
dynamic-multipath-routing-00.txt

has been posted.

Please send us comments.

Thanks

Sanjiv Kapoor

---

From: Sanjiv Kapoor <[email-masked]>
Date: Tue, 21 Mar 2017 09:12:58 -0500

As Jeff suggested, I am inviting  discussion on
Re: https://www.ietf.org/internet-drafts/draft-kapoor-rtgwg-
dynamic-multipath-routing-00.txt

This document introduces a method for simultaneous routing and congestion
control across multi-path flows. The basic methods for change of flow is an
additive increase and multiplicative decrease on congestion (like TCP).
Extra flow requirements and  congestion is dealt with by finding additional
(shortest ) paths using the queue length as a measure for congestion at the
links. This requires knowledge of the link state.

There are two methods described, the second method achieves fair
distribution of traffic flow by using a concurrency parameter, Gamma, which
alters the cost of paths being used by a particular source destination
traffic flow.

These methods  have been simulated (by Fab) using  NS3 and results may be
found on

http://www.cs.iit.edu/~kapoor/papers/reducerate.pdf

On Wed, Mar 15, 2017 at 4:18 PM, Sanjiv Kapoor <[email-masked]> wrote:

> A new  Internet Draft
>
>    https://www.ietf.org/internet-drafts/draft-kapoor-rtgwg
> -dynamic-multipath-routing-00.txt
>
> has been posted.
>
> Please send us comments.
>
> Thanks
>
> Sanjiv Kapoor
>

---

From: Tony Przygienda <[email-masked]>
Date: Tue, 21 Mar 2017 08:34:20 -0700

welcome, IME this still largely holds  (as Acee uses to describe those
things "oldie but goodie" ;-)

http://zoo.cs.yale.edu/classes/cs433/cs433-2013-fall/readings/arpanet_routing.pdf

On Tue, Mar 21, 2017 at 7:12 AM, Sanjiv Kapoor <[email-masked]> wrote:

> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>
>

-- 
*We’ve heard that a million monkeys at a million keyboards could produce
the complete works of Shakespeare; now, thanks to the Internet, we know
that is not true.*
—Robert Wilensky

---

From: Sanjiv Kapoor <[email-masked]>
Date: Tue, 21 Mar 2017 10:44:07 -0500

Thanks for the link.

(At least) One key  difference to note is that we utilize multiple paths to
increase throughput.

On Tue, Mar 21, 2017 at 10:34 AM, Tony Przygienda <[email-masked]>
wrote:

>>>    https://www.ietf.org/internet-drafts/draft-kapoor-rtgwg-d
>>> ynamic-multipath-routing-00.txt
>>>
>>> has been posted.
>>>
>>> Please send us comments.
>>>
>>> Thanks
>>>
>>> Sanjiv Kapoor
>>>
>>
>>