Subject: Re: Question on draft-ietf-rtgwg-routing-types

From: Christian Hopps <[email-masked]>
Date: Sun, 02 Apr 2017 09:15:35 -0400

Susan Hares <[email-masked]> writes:

> Acee:
>
> I was querying about operational experience with draft-ietf-rtgwg-routing-types as input for IDR. IDR has adopted BGP model that predates this work.

Hi Sue,

There are a few openconfig folks on the design team although there are
differing levels of participation so something may have been missed in
the initial revisions. Please feel free to suggest types from the
OpenConfig BGP model that would be useful for other routing modules. :)

Thanks,
Chris.

> Sue
>
> From: Acee Lindem (acee) [mailto:[email-masked]]
> Sent: Wednesday, March 29, 2017 12:12 PM
> To: Susan Hares; [email-masked]
> Subject: Re: Question on draft-ietf-rtgwg-routing-types
>
> From: Susan Hares <[email-masked]>
> Date: Wednesday, March 29, 2017 at 10:57 AM
> To: Acee Lindem <[email-masked]>, Routing WG <[email-masked]>
> Subject: RE: Question on draft-ietf-rtgwg-routing-types
>
>  Acee:
>
>  Thank you. Just to clarify your answer, does mean you had a discussion with the operators (e.g. openconfig) who implement the basic BGP model as well?
>
> If you have looked OpenConfig models in Github, they have their own factoring of types. The bigger question of OpenConfig and IETF models is certainly not addressed by this model.
>
> Acee
>
>  Sue
>
>  From: Acee Lindem (acee) [mailto:[email-masked]]
>  Sent: Wednesday, March 29, 2017 11:47 AM
>  To: Susan Hares; [email-masked]
>  Subject: Re: Question on draft-ietf-rtgwg-routing-types
>
>  Hi Sue,
>
>  We incorporated the types that were required for L3VPN/L2VPN models. Specifically, route-distinguisher, route-target, route-target-type, and the vpn-route-target. There was an extensive discussion with the authors of these models.
>
>  Thanks,
>
>  Acee
>
>  From: rtgwg <[email-masked]> on behalf of Susan Hares <[email-masked]>
>  Date: Wednesday, March 29, 2017 at 10:35 AM
>  To: Routing WG <[email-masked]>
>  Subject: Question on draft-ietf-rtgwg-routing-types
>
>  RTGWG DT:
>
>  Just curious, did the DT consider BGP routing types? If so, where did you decide BGP routing types were not common routing types?
>
>  Sue

---

From: Jeffrey Haas <[email-masked]>
Date: Sun, 2 Apr 2017 09:26:55 -0400

> On Mar 29, 2017, at 11:35 AM, Susan Hares <[email-masked]> wrote:
> 
> RTGWG DT: 
>  

FWIW, I had already flagged to a few members of the design team that the route-target types are not sufficiently general.

I owe them an email about the details, which I'll do when I have a pause in my travels.

-- Jeff

---

From: Lou Berger <[email-masked]>
Date: Sun, 02 Apr 2017 11:16:49 -0400

Hi Sue,

I took another look at bgp types and the only thing that jumps out at me as 
common that isn't already covered is enumeration of protocols  (for 
potential use in route redistribution and interface config).  We can 
certainly consider this if this what you were thinking about.

Are there are types you think we overlooked?

Lou

On March 29, 2017 11:41:25 AM "Susan Hares" <[email-masked]> wrote:

> RTGWG DT:
>
>
>
> Just curious, did the DT consider BGP routing types?  If so, where did you
> decide BGP routing types were not common routing types?
>
>
>
> Sue
>
>
>
>
>
>
>
>
> ----------
> _______________________________________________
> rtgwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtgwg
>

---

From: Lou Berger <[email-masked]>
Date: Sun, 02 Apr 2017 11:17:18 -0400

Also afi...

On March 29, 2017 11:47:28 AM "Acee Lindem (acee)" <[email-masked]> wrote:

> Hi Sue,
> We incorporated the types that were required for L3VPN/L2VPN models. 
> Specifically, route-distinguisher, route-target, route-target-type, and the 
> vpn-route-target. There was an extensive discussion with the authors of 
> these models.
> Thanks,
> Acee
>
> From: rtgwg <[email-masked]<mailto:[email-masked]>> on 
> behalf of Susan Hares <[email-masked]<mailto:[email-masked]>>
> To: Routing WG <[email-masked]<mailto:[email-masked]>>

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 5 Apr 2017 09:15:41 -0400

Lou:

Let me recheck.  I thought there was something relating to the MP-BGP that
was not covered.   I'll get back to you by Thursday am. 

Sue 

From: Lou Berger [mailto:[email-masked]] 
Sent: Sunday, April 2, 2017 11:17 AM
To: Susan Hares; [email-masked]
Subject: Re: Question on draft-ietf-rtgwg-routing-types

Hi Sue,

Lou

RTGWG DT: 

Sue 

_______________________________________________
rtgwg mailing list
[email-masked] <mailto:rtgwg%40ietf.org> 
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Fri, 21 Apr 2017 15:30:05 +0000

Hi Sue,

Since you are referring to RFC 4760, is it the SAFIs that you would like to see defined here? One thing that is different from the IETF style is that if I add these they will not be all upper case like they are in the OC BGP types model.

BTW, what is the target timeframe for an update of the BGP YANG model? I know you had mentioned it was in the works in the IDR meeting.

Thanks,
Acee

From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, April 5, 2017 at 9:15 AM
To: 'Lou Berger' <[email-masked]<mailto:[email-masked]>>, Routing WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: Question on draft-ietf-rtgwg-routing-types

Lou:

Let me recheck.  I thought there was something relating to the MP-BGP that was not covered.   I’ll get back to you by Thursday am.

Sue

From: Lou Berger [mailto:[email-masked]]
Sent: Sunday, April 2, 2017 11:17 AM
To: Susan Hares; [email-masked]<mailto:[email-masked]>
Subject: Re: Question on draft-ietf-rtgwg-routing-types

Hi Sue,

I took another look at bgp types and the only thing that jumps out at me as common that isn't already covered is enumeration of protocols  (for potential use in route redistribution and interface config).  We can certainly consider this if this what you were thinking about.

Lou

On March 29, 2017 11:41:25 AM "Susan Hares" <[email-masked]<mailto:[email-masked]>> wrote:
RTGWG DT:

Sue

_______________________________________________
rtgwg mailing list
[email-masked]<mailto:rtgwg%40ietf.org>
https://www.ietf.org/mailman/listinfo/rtgwg