Subject: I-D Action: draft-ietf-rtgwg-srv6-egress-protection-00.txt

From: [email-masked]
Date: Wed, 18 Mar 2020 22:01:44 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Routing Area Working Group WG of the IETF.

        Title           : SRv6 Path Egress Protection
        Authors         : Zhibo Hu
                          Huanan Chen
                          Huaimo Chen
                          Peng Wu
                          Mehmet Toy
                          Chang Cao
                          Lei Liu
                          Xufeng Liu
	Filename        : draft-ietf-rtgwg-srv6-egress-protection-00.txt
	Pages           : 16
	Date            : 2020-03-18

Abstract:
   This document describes protocol extensions for protecting the egress
   node of a Segment Routing for IPv6 (SRv6) path or tunnel.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-srv6-egress-protection/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-rtgwg-srv6-egress-protection-00
https://datatracker.ietf.org/doc/html/draft-ietf-rtgwg-srv6-egress-protection-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 18 Mar 2020 22:40:13 -0700

Dear Chris and Jeff,
as I've mentioned, my comments were not acknowledged during the WGAP. In my
comment I've indicated that I consider the problem fundamental and don't
believe that without addressing it the solution is plausible. My comments
were not acknowledged and only earlier today I received a very terse
reference to a potential resolution that I didn't have time to review. And
without my acknowledgement and confirmation the WG draft has been
published. I don't think that demonstrates the professional courtesy.

Regards,
Greg

---------- Forwarded message ---------
From: <[email-masked]>
Date: Wed, Mar 18, 2020, 22:02
Subject: I-D Action: draft-ietf-rtgwg-srv6-egress-protection-00.txt
To: <[email-masked]>
Cc: <[email-masked]>

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Routing Area Working Group WG of the IETF.

Abstract:

_______________________________________________
rtgwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rtgwg

---

From: Huaimo Chen <[email-masked]>
Date: Thu, 19 Mar 2020 13:26:20 +0000

Hi Greg,

    The comments received, including yours, have been addressed in the updated draft posted on March 1, 2020.
    https://mailarchive.ietf.org/arch/msg/rtgwg/LD2mKe0-I8DjxW1vHrOmSnmg9gg/

https://datatracker.ietf.org/doc/draft-hu-rtgwg-srv6-egress-protection/

Best Regards,
Huaimo
________________________________
From: rtgwg <[email-masked]> on behalf of Greg Mirsky <[email-masked]>
Sent: Thursday, March 19, 2020 1:40 AM
To: rtgwg-chairs <[email-masked]>; RTGWG <[email-masked]>
Subject: Fwd: I-D Action: draft-ietf-rtgwg-srv6-egress-protection-00.txt

Dear Chris and Jeff,
as I've mentioned, my comments were not acknowledged during the WGAP. In my comment I've indicated that I consider the problem fundamental and don't believe that without addressing it the solution is plausible. My comments were not acknowledged and only earlier today I received a very terse reference to a potential resolution that I didn't have time to review. And without my acknowledgement and confirmation the WG draft has been published. I don't think that demonstrates the professional courtesy.

Regards,
Greg

---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Wed, Mar 18, 2020, 22:02
Subject: I-D Action: draft-ietf-rtgwg-srv6-egress-protection-00.txt
To: <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-srv6-egress-protection/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-rtgwg-srv6-egress-protection%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C7e9d4fdb639c48a4f92d08d7cbc804df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637201932257969222&sdata=dOQeocqfX1WNFJtntyxweW7xCVkET%2FrCdI5lDzu5sX8%3D&reserved=0>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-rtgwg-srv6-egress-protection-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-rtgwg-srv6-egress-protection-00&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C7e9d4fdb639c48a4f92d08d7cbc804df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637201932257969222&sdata=MCWCFk0cRfgQzE41bHgHIdpFhMcKe%2FU1Vmjz8HTebfw%3D&reserved=0>
https://datatracker.ietf.org/doc/html/draft-ietf-rtgwg-srv6-egress-protection-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-rtgwg-srv6-egress-protection-00&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C7e9d4fdb639c48a4f92d08d7cbc804df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637201932257979190&sdata=bTHV1dubGGrjJ5XdZ1gaavtL6wHVKVHjq6W3LU271Hs%3D&reserved=0>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C7e9d4fdb639c48a4f92d08d7cbc804df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637201932257979190&sdata=Ak1WRk5blrw888vOLt6ljXRFgK08GIDFQMoZfD%2FXGys%3D&reserved=0>.

_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frtgwg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C7e9d4fdb639c48a4f92d08d7cbc804df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637201932257989133&sdata=p%2F1%2BGzvGeo1JCYmXAvhnUYpzJRKxupxoZKlszrVcdGg%3D&reserved=0>

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 19 Mar 2020 15:07:51 -0700

Hi Huaimo,
thank you for your response. I couldn't find a response to me from the
authors, nor an explanation of how they have addressed my comments. Perhaps
you can help with that. Also, the note you've referenced was not addressed
to me, probably you've meant to reference another email.
Hence, I cannot conclude that my comments were considered and resolved. As
I've noted, the problems I've pointed to were serious enough to require
resolution before this work is adopted by the group.
I much appreciate WG Chairs consideration and suggestions to me and the
authors on how we can proceed.

Regards,
Greg

On Thu, Mar 19, 2020 at 6:26 AM Huaimo Chen <[email-masked]>
wrote:

> ------------------------------
> *From:* rtgwg <[email-masked]> on behalf of Greg Mirsky <
> [email-masked]>
> *Sent:* Thursday, March 19, 2020 1:40 AM
> *To:* rtgwg-chairs <[email-masked]>; RTGWG <[email-masked]>
> *Subject:* Fwd: I-D Action: draft-ietf-rtgwg-srv6-egress-protection-00.txt
>
> Dear Chris and Jeff,
> as I've mentioned, my comments were not acknowledged during the WGAP. In
> my comment I've indicated that I consider the problem fundamental and don't
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-rtgwg-srv6-egress-protection%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C7e9d4fdb639c48a4f92d08d7cbc804df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637201932257969222&sdata=dOQeocqfX1WNFJtntyxweW7xCVkET%2FrCdI5lDzu5sX8%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-rtgwg-srv6-egress-protection-00&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C7e9d4fdb639c48a4f92d08d7cbc804df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637201932257969222&sdata=MCWCFk0cRfgQzE41bHgHIdpFhMcKe%2FU1Vmjz8HTebfw%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-rtgwg-srv6-egress-protection-00&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C7e9d4fdb639c48a4f92d08d7cbc804df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637201932257979190&sdata=bTHV1dubGGrjJ5XdZ1gaavtL6wHVKVHjq6W3LU271Hs%3D&reserved=0>
>
>
> until the htmlized version and diff are available at tools.ietf.org
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C7e9d4fdb639c48a4f92d08d7cbc804df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637201932257979190&sdata=Ak1WRk5blrw888vOLt6ljXRFgK08GIDFQMoZfD%2FXGys%3D&reserved=0>
> .
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frtgwg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C7e9d4fdb639c48a4f92d08d7cbc804df%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C1%7C637201932257989133&sdata=p%2F1%2BGzvGeo1JCYmXAvhnUYpzJRKxupxoZKlszrVcdGg%3D&reserved=0>
>

---

From: Huaimo Chen <[email-masked]>
Date: Thu, 19 Mar 2020 22:20:20 +0000

Hi Greg,

    I found that your email was replied by another author and your comments were addressed
    https://mailarchive.ietf.org/arch/msg/rtgwg/J2fJ3PF-bIYIeRzeWG83QpqpAR4/

Best Regards,
Huaimo
________________________________
From: Greg Mirsky <[email-masked]>
Sent: Thursday, March 19, 2020 6:07 PM
To: Huaimo Chen <[email-masked]>
Cc: rtgwg-chairs <[email-masked]>; RTGWG <[email-masked]>
Subject: Re: I-D Action: draft-ietf-rtgwg-srv6-egress-protection-00.txt

Hi Huaimo,
thank you for your response. I couldn't find a response to me from the authors, nor an explanation of how they have addressed my comments. Perhaps you can help with that. Also, the note you've referenced was not addressed to me, probably you've meant to reference another email.
Hence, I cannot conclude that my comments were considered and resolved. As I've noted, the problems I've pointed to were serious enough to require resolution before this work is adopted by the group.
I much appreciate WG Chairs consideration and suggestions to me and the authors on how we can proceed.

Regards,
Greg

On Thu, Mar 19, 2020 at 6:26 AM Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Greg,

    The comments received, including yours, have been addressed in the updated draft posted on March 1, 2020.
    https://mailarchive.ietf.org/arch/msg/rtgwg/LD2mKe0-I8DjxW1vHrOmSnmg9gg/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Frtgwg%2FLD2mKe0-I8DjxW1vHrOmSnmg9gg%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881697715&sdata=%2BNR4p50O7eMH3jOg2TB3QRFlVKiIOBCjjLb0bpF2C68%3D&reserved=0>

https://datatracker.ietf.org/doc/draft-hu-rtgwg-srv6-egress-protection/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-hu-rtgwg-srv6-egress-protection%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881707710&sdata=H0Ch%2B6xGDZLyykRft7oOcuD8SOGz8R1W1lfvr8u4XWY%3D&reserved=0>

Best Regards,
Huaimo
________________________________
From: rtgwg <[email-masked]<mailto:[email-masked]>> on behalf of Greg Mirsky <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, March 19, 2020 1:40 AM
To: rtgwg-chairs <[email-masked]<mailto:[email-masked]>>; RTGWG <[email-masked]<mailto:[email-masked]>>
Subject: Fwd: I-D Action: draft-ietf-rtgwg-srv6-egress-protection-00.txt

Dear Chris and Jeff,

Regards,
Greg

---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Wed, Mar 18, 2020, 22:02
Subject: I-D Action: draft-ietf-rtgwg-srv6-egress-protection-00.txt
To: <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-rtgwg-srv6-egress-protection/<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-rtgwg-srv6-egress-protection%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881717718&sdata=DVZfAtKCcX7D6fB8ZSDrbjHX3FhlwSzJgoK3%2BaFI2ow%3D&reserved=0>

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-rtgwg-srv6-egress-protection-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-rtgwg-srv6-egress-protection-00&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881717718&sdata=BX8oWFRmbWzjqfa5bv3x%2BjBLXKlr%2Fu2GBM%2FaXMXDEp4%3D&reserved=0>
https://datatracker.ietf.org/doc/html/draft-ietf-rtgwg-srv6-egress-protection-00<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-rtgwg-srv6-egress-protection-00&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881727710&sdata=TahS7kdqJNJvVyWE8h5DixxLFJWk%2BXgT6l7hOvpO6f4%3D&reserved=0>

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881737702&sdata=ZDuqURDlL76cloneh%2B7n3%2B3PHWbKBrunQAoME%2BZnWNs%3D&reserved=0>.

_______________________________________________
rtgwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtgwg<https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frtgwg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881737702&sdata=hBR5M7QRMTzWk3uqogAtS%2Bl5et5NzF%2FYXc26TR%2F3AQA%3D&reserved=0>

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 19 Mar 2020 15:32:08 -0700

Hi Huiamo,
thank you for your quick response but I cannot connect that reference to
other documents with my comments and the document we discuss. I much
appreciate it if authors can respond to each of my questions with the
specific text in the current document. Thank you in advance.

Regards,
Greg

On Thu, Mar 19, 2020 at 3:20 PM Huaimo Chen <[email-masked]>
wrote:

> *From:* Greg Mirsky <[email-masked]>
> *Sent:* Thursday, March 19, 2020 6:07 PM
> *To:* Huaimo Chen <[email-masked]>
> *Cc:* rtgwg-chairs <[email-masked]>; RTGWG <[email-masked]>
> *Subject:* Re: I-D Action: draft-ietf-rtgwg-srv6-egress-protection-00.txt
>
> Hi Huaimo,
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Frtgwg%2FLD2mKe0-I8DjxW1vHrOmSnmg9gg%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881697715&sdata=%2BNR4p50O7eMH3jOg2TB3QRFlVKiIOBCjjLb0bpF2C68%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-hu-rtgwg-srv6-egress-protection%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881707710&sdata=H0Ch%2B6xGDZLyykRft7oOcuD8SOGz8R1W1lfvr8u4XWY%3D&reserved=0>
>
>
> Best Regards,
> Huaimo
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-rtgwg-srv6-egress-protection%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881717718&sdata=DVZfAtKCcX7D6fB8ZSDrbjHX3FhlwSzJgoK3%2BaFI2ow%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-rtgwg-srv6-egress-protection-00&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881717718&sdata=BX8oWFRmbWzjqfa5bv3x%2BjBLXKlr%2Fu2GBM%2FaXMXDEp4%3D&reserved=0>
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-ietf-rtgwg-srv6-egress-protection-00&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881727710&sdata=TahS7kdqJNJvVyWE8h5DixxLFJWk%2BXgT6l7hOvpO6f4%3D&reserved=0>
>
>
> <https://nam11.safelinks.protection.outlook.com/?url=http%3A%2F%2Ftools.ietf.org%2F&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881737702&sdata=ZDuqURDlL76cloneh%2B7n3%2B3PHWbKBrunQAoME%2BZnWNs%3D&reserved=0>
> .
>
> <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Frtgwg&data=02%7C01%7Chuaimo.chen%40futurewei.com%7C694d15f8e948425ea4ae08d7cc520016%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637202524881737702&sdata=hBR5M7QRMTzWk3uqogAtS%2Bl5et5NzF%2FYXc26TR%2F3AQA%3D&reserved=0>
>
>