Subject: Genart last call review of draft-ietf-rtgwg-policy-model-15

From: Francesca Palombini via Datatracker <[email-masked]>
Date: Tue, 16 Jun 2020 11:55:16 -0700

Reviewer: Francesca Palombini
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-rtgwg-policy-model-15
Reviewer: Francesca Palombini
Review Date: 2020-06-16
IETF LC End Date: None
IESG Telechat date: Not scheduled for a telechat

Summary: This draft is basically ready but has one minor issue, described in
the review.

Minor issues:

In the last paragraph of Section 4 there are a number of non-normative may,
should, must. I believe the last "should" at least could be normative:

>  Also, implementations should have validation to assure
>  that there is no recursion amongst nested routing policies.

(More of a question than an issue) I was surprised that all but one references
were considered normative. Is that common to consider the RFC that appear in
the model as normative references for the document?

Note that for the version reviewed, the Yang Validation for
draft-ietf-rtgwg-policy-model-15 failed: err : Data model "ietf-if-extensions"
not found.

---

From: Yingzhen Qu <[email-masked]>
Date: Thu, 18 Jun 2020 23:17:26 +0000

Hi Francesca,

Thanks for your review and comments. 

Please see my answers inline.

Thanks,
Yingzhen

On 6/16/20, 11:56 AM, "Francesca Palombini via Datatracker" <[email-masked]> wrote:

    
    
    <https://nam11.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fgen%2Fwiki%2FGenArtfaq&amp;data=02%7C01%7Cyingzhen.qu%40futurewei.com%7Ca69d57e8e5b14f27e14208d81226efb2%7C0fee8ff2a3b240189c753a1d5591fedc%7C1%7C0%7C637279305729780422&amp;sdata=XNrSYJ7%2BI3RsLS%2Fx3GkhexO2cuiBagLRyYSDHpFfihs%3D&amp;reserved=0>.

    
    Minor issues:

    >  that there is no recursion amongst nested routing policies.
[YQ]: I'm not sure this should be normative. These are suggestions. The model provides some flexibilities, and it's up to the users to decide how to use the model.
    
    (More of a question than an issue) I was surprised that all but one references
    were considered normative. Is that common to consider the RFC that appear in
    the model as normative references for the document?
[YQ]: This has been our practice. Is there a particular one you see that should not be normative?
    
    Note that for the version reviewed, the Yang Validation for
    draft-ietf-rtgwg-policy-model-15 failed: err : Data model "ietf-if-extensions"
    not found.
[YQ]: this is a tool issue. The model has been compiled using pyang and the examples also verified with yanglint.