Subject: RE: Two questions about the draft-hu-rtgwg-srv6-egress-protection-08

From: Huzhibo <[email-masked]>
Date: Wed, 8 Jul 2020 02:37:58 +0000

Hi minhong:
Question 1: draft-hu-rtgwg-srv6-egress-protection-08 compliance draft-ietf-spring-srv6-network-programming，It use H.Encaps Encapsulating the Repair List。
Question 2: Only if SL == 0 or No SRH, It will execut the mirror behavior。If the End Sid is the last sid,It will mirror behavior。Or It will execut other protect behavior.

Thanks
Zhibo
From: Heminhong [mailto:[email-masked]]
Sent: Wednesday, July 8, 2020 9:42 AM
To: Huzhibo <[email-masked]>; [email-masked]; [email-masked]; Wupeng (Baggio, VRP MKT) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Two questions about the draft-hu-rtgwg-srv6-egress-protection-08

Dear,

1.     About P1 how to encapsulate the packet
draft-hu-rtgwg-srv6-egress-protection-07, the following description : “When PE3 fails, node P1 protects PE3 through sending the packet to PE4 via the backup path pre-computed. P1 modifies the packet before sending it to PE4. The modified packet has destination PE4 with mirror SID A4:1::3, and SRH with PE3’s VPN SID A3:1::B100 and the mirror SID A4:1::3 (i.e., "A3:1::B100, A4:1::3; SL=1"). ”
However，draft-hu-rtgwg-srv6-egress-protection-08,the following description:  “When PE3 fails, P1 as PLR sends the packet to PE4 via the backup path pre-computed.  P1 encapsulates the packet using H.Encaps before sending it to PE4.”

2、
                                   END SID: A2:1::B100
                 *******  *******  VPN SID: A3:1::B100
             [PE1]-----[P1]-----[PE3]---[CE2]      PE3 Egress
             / |        |&        | \   /          PE4 Backup Egress
            /  |        |&        |  \ /           CEx Customer Edge
       [CE1]   |        |&        |   X            Px  Non-Provider Edge
            \  |        |&        |  / \           *** SR Path
             \ |        |& &&&&&  | /   \          &&& Backup Path
             [PE2]-----[P2]-----[PE4]---[CE3]
                                   VPN SID: A4:1::B100
                                Mirror SID: A4:1::3, protect PE3

               Figure 2: PE4 Protects Egress PE3 of SR Path

   Suppose that the packet received by P1 is represented by Pkt = (SA =
   A1:1::, DA = A2:1::B100)Pkt0, where DA = A2:1::B100 is PE3's END SID,
   and Pkt0 is the rest of the packet.  The encapsulated packet Pkt'
   will be one of the followings:

l  Pkt' = (T, Mirror SID A4:1::3) (A1:1::, A2:1::B100)( A3:1::B100, A2:1::B100)Pkt0, how to process?

Processing on the receiver or on the sender?

Thanks for your time, Looking forward to your reply.
Best regards.
Sincerely yours,
minhong
-------------------------------------------------------------------------------------------------------------------------------------
本邮件及其附件含有新华三集团的保密信息，仅限于发送给上面地址中列出
的个人或群组。禁止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、
或散发）本邮件中的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本
邮件！
This e-mail and its attachments contain confidential information from New H3C, which is
intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender
by phone or email immediately and delete it!

---

From: Huzhibo <[email-masked]>
Date: Wed, 8 Jul 2020 08:21:31 +0000

Yes, If it isn`t the last Sid,It will execut other protection behavior.

Thanks
Zhibo
From: Heminhong [mailto:[email-masked]]
Sent: Wednesday, July 8, 2020 2:37 PM
To: Huzhibo <[email-masked]>; [email-masked]; [email-masked]; Wupeng (Baggio, VRP MKT) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: 答复: Two questions about the draft-hu-rtgwg-srv6-egress-protection-08

Excuse

if SL ==1 or  (T, Mirror SID A4:1::3) (A1:1::, A2:1::B100)( A3:1::B100, A2:1::B100)(SRH),when A2:1::B100 is PE3's END SID, it will execut midpoint-protection ?

发件人: Huzhibo [mailto:[email-masked]]
发送时间: 2020年7月8日 10:38
收件人: heminhong (RD) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Wupeng (Baggio, VRP MKT) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: RE: Two questions about the draft-hu-rtgwg-srv6-egress-protection-08

Hi minhong:

Thanks
Zhibo
From: Heminhong [mailto:[email-masked]]
Sent: Wednesday, July 8, 2020 9:42 AM
To: Huzhibo <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Wupeng (Baggio, VRP MKT) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Two questions about the draft-hu-rtgwg-srv6-egress-protection-08

Dear,

2、
                                   END SID: A2:1::B100