Subject: RE: [Fwd: [Saad] Some initiating thoughts...]

From: "Harrington, David" <[email-masked]>
Date: Wed, 29 Oct 2003 09:31:47 -0500

Hi Brian,

I'm having difficulty understanding the use-case scenario. Can you
expand on a scenario when this would be needed so I can better grasp
your point?

Thanks,
dbh

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]] 
> Sent: Wednesday, October 29, 2003 6:00 AM
> To: [email-masked]
> Subject: Re: [Fwd: [Saad] Some initiating thoughts...]
> 
> 
> Leslie Daigle wrote:
> > 
> > I posted this a few days ago -- before, I think, people had
> > a chance to get subscribed.  So, let me re-post it for
> > further discussion...
> 
> And I've been carrying the attached minor comment around for 
> two weeks...
> ...
> > 
> > 3.2.  Addressing Requirements of Enterprises
> ...
> > Some enterprises have addressing requirements caused by the 
> need to set
> > up inter-enterprise Virtual Private Networks (VPNs).  Also, at some
> > point in their existence most enterprises undergo some form 
> of merger or
> > acquisition, and discover that they need to merge internal 
> networks.  In
> > both these circumstances there is a requirement to avoid the need to
> > renumber or to suffer from ambiguous addressing resulting from the
> > merger of two private address spaces.
> 
> I think this misses another related requirement that may become very
> significant, in a future consisting of virtual organizations 
> and on-demand
> computing environments. It may often be required for a set of 
> enterprises
> to create a short-term "closed user group" of hosts that need 
> transparent
> (firewall-free) interconnection for a period of time; this is 
> like a dynamic
> merger followed some time later by a demerger. This is more 
> demanding on the
> addressing (and routing) architecture than relatively static 
> VPNs or one-time
> events like mergers.
> 
>    Brian
> 
> _______________________________________________
> Saad mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/saad
> 

_______________________________________________
Saad mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/saad

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 29 Oct 2003 17:33:45 +0100

David,

Virtual organizations are a fundamental feature of grid computing. A group
of users scattered around a selection of sites come together to tackle
a particular problem during a particular period of time. (In existing grids
it would typically be a particular computational scientific problem.) During that
time they pool their resources across organizations and these resources (servers,
storage, etc) need to communicate transparently among themselves as if they were
a single physical site, separate from their normal organizational affiliation
(i.e. NATs and firewalls are a big barrier, so today's addressing and security
model is a problem). You could conceive this as a set of VPN connnections but
that is a clumsy way to actually implement it.

There is some discussion of virtual organizations at 
https://forge.gridforum.org/docman2/ViewProperties.php?group_id=42&document_content_id=919

   Brian