Subject: [sacm] Cyber Physical Systems

From: "Waltermire, David A." <[email-masked]>
Date: Fri, 25 Oct 2013 17:18:04 +0000

One other area to consider defining as a use case or two around is monitoring expected vs. actual state for cyber physical systems. Another option is to provide some discussion around how the current use cases apply to this domain.

Control systems and sensors used to manage and monitor manufacturing, communications, power, medical, and many other critical infrastructure areas fit into our definition of endpoints. The have many of the same properties as classical IT devices. They are networked, configurable, and have software and firmware that need to be managed. They also often provide high-velocity sensor data that reflects the current operational posture of the device or a mechanism that they manage. It seems like the availability and integrity over the operational state of these devices represent a security concern that is relevant to our charter.

I am working to get some participation from individuals involved more intimately in this space.

Thoughts?

Dave

---

From: Gunnar Engelbach <[email-masked]>
Date: Fri, 25 Oct 2013 13:26:39 -0400

Such use cases would help show the breadth of SACM applicability, but 
would they create any new requirements?  Worth a try just to see.

On 10/25/2013 1:18 PM, Waltermire, David A. wrote:
> One other area to consider defining as a use case or two around is
> monitoring expected vs. actual state for cyber physical systems. Another
> option is to provide some discussion around how the current use cases
> apply to this domain.
>
> Control systems and sensors used to manage and monitor manufacturing,
> communications, power, medical, and many other critical infrastructure
> areas fit into our definition of endpoints. The have many of the same
> properties as classical IT devices. They are networked, configurable,
> and have software and firmware that need to be managed. They also often
> provide high-velocity sensor data that reflects the current operational
> posture of the device or a mechanism that they manage. It seems like the
> availability and integrity over the operational state of these devices
> represent a security concern that is relevant to our charter.
>
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>

---

From: "Waltermire, David A." <[email-masked]>
Date: Fri, 25 Oct 2013 19:23:47 +0000

> would they create any new requirements?  Worth a try just to see.

I think so too.

Dave

---

From: Adam Montville <[email-masked]>
Date: Fri, 25 Oct 2013 19:57:36 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Waltermire, David A.
> Sent: Friday, October 25, 2013 2:23 PM
> To: Gunnar Engelbach; [email-masked]
> Subject: Re: [sacm] Cyber Physical Systems
> 

I actually believe we'll find some requirements in there, but mainly in terms of environmental constraints.  The "Ice Station Zebra" Use Case touches on some of these by describing the reliance on a satellite link, but embedded device and other "Internet of Things" environments may present additional environmental constraints we might need to consider in terms of intermittent connectivity, acceptable collection windows, network latency, and so on.  

> ...

. . .