Subject: [sacm] My Comments on draft-ietf-sacm-use-cases-01.txt

From: Stephen Hanna <[email-masked]>
Date: Thu, 3 Oct 2013 19:33:33 +0000

I just finished a review of the latest SACM
use cases draft. Here are my comments.

* I agree with Nancy that Section 4 (Functional
  Capabilities) does not belong in a Use Case
  document. We may need to add this back later
  but I think we should first focus on agreeing
  on what problems we want to solve (use cases).
  I suggest that we remove section 4 for now.

* I definitely like the new use cases vs. the
  old ones in the -00 version. The new use cases
  are specific. I know what they mean. The old
  ones were too general and lengthy. I was never
  sure that I understood them and it seemed
  quite likely that two people reading them would
  understand them differently. Thanks for making
  these changes.

* All the current use cases seem to be in scope
  for this group.

* At the start of section 3.1, you ask

QUESTION: This use case applies equally to vendors representing other
endpoint types.  Should this be generalized to capture this notion?

  I suggest that you keep the current text. It's
  good to have specific use cases that span the
  problem space. If you want, you can add a sentence
  at the end that says this use case could apply to
  other endpoint types just as easily.

* At the end of section 3.1, you ask

QUESTION: Is providing traceability to functional capabilities
useful?  If so, we need to replicate this for the other use cases.

  As I mentioned above, I don't think it's a good
  idea to add a list of abstract capabilities to
  this document. Let's agree on the problems that
  we want to solve. Then we can talk about which
  concepts to use to solve those problems. So I'd
  like to delete the list of capabilities at the
  end of section 3.1.

* In section 3.2, the checklists might come from
  sources other than vendors. For example, the
  financial services company might get checklists
  from a financial industry group or develop its
  own checklists. I'm perfectly happy leaving this
  use case mainly as it is but adding a sentence
  at the end saying that the checklists could also
  come from sources other than the application or
  OS vendor. Similar text should also go at the
  end of section 3.1.

* Here are a few more use cases: Search for Signs
  of Infection, Remediation & Mitigation, and
  Endpoint Information Analysis & Reporting.
  Do you want me to write a few paragraphs
  on those?

Thanks,

Steve

---

From: Ira McDonald <[email-masked]>
Date: Fri, 4 Oct 2013 16:46:55 -0400

Hi,

+1 to all of Steve Hanna and Nancy Cam-Winget's comments on this draft.

Section 4 Functional Capabilities does not belong in this Use Cases
document.
It descends into solution details that obscure the simple use cases.

Steve - please do send paragraphs on your 3 suggested additional use cases:
- Search for Signs of Infection
- Remediation & Mitigation
- Endpoint Information Analysis & Reporting

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG IPP WG
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - TCG Embedded Systems Hardcopy SG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music/High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto:[email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Thu, Oct 3, 2013 at 3:33 PM, Stephen Hanna <[email-masked]> wrote:

> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>