Subject: Re: [sacm] Is latency is important for you?

From: "Moriarty, Kathleen" <[email-masked]>
Date: Wed, 4 Dec 2013 14:45:58 -0500

Hello Hosnieh,

Could you provide a little more background and relevance to the list members for your request?

I have had the pleasure of meeting Hosnieh at several IETF related events and she has some active drafts related to secure transport.  She is in the process of starting up a mailing list for discussion on that topic and I am guessing this request is related to that new mailing list.

The question as worded below may be tough for this group as their focus is on security automation.  This work will require the exchange of information over secure protocols, but the group is working through use cases and requirements at this stage.

Maybe a quick/brief explanation would be helpful and then you could have people contact you directly or on the new mailing list once it is established.  We shouldn’t clutter other mailing lists.  You could send that request with an announcement message to SAAG list once the list has been created.

Thank you,
Kathleen

From: sacm [mailto:[email-masked]] On Behalf Of Hosnieh
Sent: Thursday, November 21, 2013 9:46 AM
To: Apps Discuss, IETF; [email-masked]
Cc: Nordmark, Erik
Subject: [sacm] Is latency is important for you?

Hello,

I do not know in which WG I saw a message and a discussion of IID generation and latency problems. If it was not in this mailinglist but I guess it is a good place to start since it really relates to this WG.
I have a very important question. Please rate  your experience about the latency you encountered in any network that was because of IP configuration of your node.

Thanks,

---
Smile,
Hosnieh
Sorry for tpyos from my chubby fingers typing on my phone

---

From: "Hosnieh Rafiee" <[email-masked]>
Date: Sun, 8 Dec 2013 21:06:14 +0100

Hi Kathleen,
I guess my question was so ambiguous. 

>Could you provide a little more background and relevance to the list members for your request?  

My question here was about the delay that might cause by network layer. It might be any reason such as IP address generation, authentication, etc (any security approach that used in network layer that caused this delay). This delay can vary from a few seconds to minutes. 
Since my experience in application layer is as a developer or end user, I would like to hear the opinion of people who have more experience in operational level, security, realtime applications, etc in application area (and welcome them to join to the new mailing list). Are all services in application layer can be/might be delay tolerance? If so how many seconds/minutes ? 
Is it better to avoid delay in network layer (any security approach that caused this delay, just stop it or if it is because of packet size, decrease the packet size, etc)?
Is it better to consider this in application layer? How?
What about realtime applications? What is the best solution to avoid delay? What are their delay threshold? (if we need to apply security)

>The question as worded below may be tough for this group as their focus is on security automation.  This work will require the exchange of information over secure protocols, but the group is working…

As you already explained briefly here, the focus of mailing list is around the topic of security automation. How network layer can be helpful to provide a means for the application layer with a good security level. How this can be automated. We might also discuss about the privacy topic during this automation. How we should also consider the privacy issue. How we can improve performance in this approach? One example would be SIP protocol and proxy servers. 
 Is it good to have an authentication library (an interface library) between application layer and network layer so that the application uses network layer security as a means of authentication or (also) use this means of authentication to have a good level of security assurance and many other topics that might come to our mind during the discussion or focusing on these areas.

Thanks,
Smile,
Hosnieh

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Sun, 8 Dec 2013 23:04:14 +0000

I think delay is a valid concern  to think about but it highly depends on the usecase. 

As for "an authentication library (an interface library) between application layer and network layer so that the application uses network layer security as a means of authentication", I am not sure how that would work, as authentication at Layer X is traditionally decoupled from Layer Y security according to the OSI or TCP/IP models.

Rgs,
Panos

-----Original Message-----
From: sacm [mailto:[email-masked]] On Behalf Of Hosnieh Rafiee
Sent: Sunday, December 08, 2013 3:06 PM
To: 'Moriarty, Kathleen'; [email-masked]
Subject: Re: [sacm] Is latency is important for you?

Hi Kathleen,

Thanks,
Smile,
Hosnieh

_______________________________________________
sacm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sacm

---

From: "Hosnieh Rafiee" <[email-masked]>
Date: Mon, 9 Dec 2013 00:09:37 +0100

Hi Panos,

> 
> I think delay is a valid concern  to think about but it highly depends on
the
> usecase.
> 
> As for "an authentication library (an interface library) between
application
> layer and network layer so that the application uses network layer
security as
> a means of authentication", I am not sure how that would work, as
> authentication at Layer X is traditionally decoupled from Layer Y security
> according to the OSI or TCP/IP models.
> 

This is what we actually want to discuss and find out. Of course it is not
only the discussion in that mailing list. But this is one of the topic of
discussion to find the best solution to avoid delay and provide an automated
security in a better way.

Thanks,
Smile,
Hosnieh