Subject: [sacm] comments on draft‐ietf‐sacm‐architecture‐02

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 12 Feb 2015 14:19:29 +0000

Hi,

Please find below my comments on draft‐ietf‐sacm‐architecture‐02. I also  addressed in my comments some of the open questions raised in the I-D.

1.       The first sentence contains a logical repetition – the SACM reference architecture is obviously related to SACM (even if one is with acronyms expanded and the other is not). Please find some more inspiring words avoiding the repetition.

2.       The open question at the end of Section 2:

Ø  Why does the charter not suffice?

Ø  What is the purpose of inserting this section in this draft?

The answer is that the charter is a temporary document visible and accessible while the WG is active (and subject to change during this period) but tends to disappeared when the WG is concluded. A recap of the problem statement in the introductory sections of the architecture document provides background information for the architecture that follows and can be very useful for understanding some of the fundamental decisions.

3.       Editorial issues in Section 3.1.3:

s/The introduction of the controller supports use cases/ The controller supports use cases/
s/Consumer’s/Consumers/
s/Provider’s/Providers/
s/interface “C” shown in Figure 1 demonstrates/ interface “C” shown in Figure 1 illustrates/

4.       In order to understand the sentence ‘a controller may also provide the proxy or broker (and possibly routing) function in the data plane’ I went back to the terminology document.

What I found is that the following terms are defined:

        Broker - An entity providing and/or connecting services on the behalf of
      other architectural components.

        Proxy - An architectural component providing functions, information, or

      services on behalf of another component, which is not directly

      participating in the architecture.

These definitions seem to need more work. They are partially redundant – is this by design? Proxy is not ‘participating in the architecture’? Then how is it between the 2-3 fundamental functions of the controller? There needs to be more work in the terminology document I guess.

5.  TODO ‐ add text around the usage of various protocols for endpoint
data collection (SNMP, NETCONF, etc.?)

                do we really need these in an architecture document?

Thanks and Regards,

Dan

---

From: "Jim Schaad" <[email-masked]>
Date: Fri, 20 Feb 2015 15:38:40 -0800

I am confused.   When are we sending these to the mailing list and when are we raising issues on github?  I don’t see any of these on github at the moment.

Jim

From: sacm [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Thursday, February 12, 2015 6:19 AM
To: [email-masked]
Subject: [sacm] comments on draft-ietf-sacm-architecture-02

Hi, 

s/Consumer’s/Consumers/

s/Provider’s/Providers/

Thanks and Regards,

Dan

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 22 Feb 2015 08:57:18 +0000

Hi Jim,

These comments were written before Github was in place. But yes, I should set an example ☺ so I created github issues for each. The (strong) recommendation is to use Github!

Regards,

Dan

From: Jim Schaad [mailto:[email-masked]]
Sent: Saturday, February 21, 2015 1:39 AM
To: Romascanu, Dan (Dan); [email-masked]
Subject: RE: [sacm] comments on draft-ietf-sacm-architecture-02

Jim

From: sacm [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Thursday, February 12, 2015 6:19 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [sacm] comments on draft-ietf-sacm-architecture-02

Hi,

Thanks and Regards,

Dan

---

From: Jerome Athias <[email-masked]>
Date: Sun, 22 Feb 2015 10:15:56 +0100

I'm afraid I would have too many comments to list them all after
review of new ETSI Deliverables related to M2M (few thousands pages),
including Functional Architecture, Requirements, Terminology,
Security, Management, Bindings, etc.

I don't know how to proceed...

Would some of you have some time to quickly review some documents?
Guidance regarding the order of suggested readings could be provided if needed.

This one, for example, is 'only' 100 pages
http://www.etsi.org/deliver/etsi_ts/118100_118199/118103/01.00.00_60/ts_118103v010000p.pdf

You can find few more here (search ETSI TS 118):
http://webapp.etsi.org/action/pu/20150222/20150222.htm

Best regards

2015-02-12 15:19 GMT+01:00 Romascanu, Dan (Dan) <[email-masked]>:
> Hi,
>
>
>
> Please find below my comments on draft‐ietf‐sacm‐architecture‐02. I also
> addressed in my comments some of the open questions raised in the I-D.
>
>
>
> 1.       The first sentence contains a logical repetition – the SACM
> reference architecture is obviously related to SACM (even if one is with
> acronyms expanded and the other is not). Please find some more inspiring
> words avoiding the repetition.
>
>
>
> The answer is that the charter is a temporary document visible and
> accessible while the WG is active (and subject to change during this period)
> but tends to disappeared when the WG is concluded. A recap of the problem
> statement in the introductory sections of the architecture document provides
> background information for the architecture that follows and can be very
> useful for understanding some of the fundamental decisions.
>
>
>
> 4.       In order to understand the sentence ‘a controller may also provide
> the proxy or broker (and possibly routing) function in the data plane’ I
> went back to the terminology document.
>
>
>
> These definitions seem to need more work. They are partially redundant – is
> this by design? Proxy is not ‘participating in the architecture’? Then how
> is it between the 2-3 fundamental functions of the controller? There needs
> to be more work in the terminology document I guess.
>
>
>
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 22 Feb 2015 09:38:20 +0000

Hi Jerome, 

I am afraid that you will need to make the effort of sorting out the comments that you believe are important and relevant to the SACM charter and work-in-progress and enter them in Github, as issues to be tracked for the SACM documents. Referring to publicly available documents from ETSI is fine, but not all are relevant and asking the SACM WG participants to review all these is I am afraid a burden that many of us who are not already involved in the ETSI work cannot afford.  

Thanks and Regards,

Dan

> -----Original Message-----
> From: Jerome Athias [mailto:[email-masked]]
> Sent: Sunday, February 22, 2015 11:16 AM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: Re: [sacm] comments on draft‐ietf‐sacm‐architecture‐02
> 
> I'm afraid I would have too many comments to list them all after review of
> new ETSI Deliverables related to M2M (few thousands pages), including
> Functional Architecture, Requirements, Terminology, Security, Management,
> Bindings, etc.
> 
> https://urldefense.proofpoint.com/v2/url?u=http-
> 3A__www.etsi.org_deliver_etsi-5Fts_118100-5F118199_118103_01.00.00-
> 5F60_ts-
> 5F118103v010000p.pdf&d=AwIFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGx
> R31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=D_EUJ97QuSAfZQtEcPSsOyFI
> qJw1E9U4rWgBhKHU28c&s=eYh9XpEA8WYhjOHOgzjeAiaFaiakbLEI-
> yNa_mWSSiU&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=http-
> 3A__webapp.etsi.org_action_pu_20150222_20150222.htm&d=AwIFaQ&c=B
> FpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpB
> sFA&m=D_EUJ97QuSAfZQtEcPSsOyFIqJw1E9U4rWgBhKHU28c&s=Nle3x6-
> gogyuNU2Gry-HtVGGQvjushl5jXBqg8oYBjk&e=
> 
> Best regards
> 
> 
> 
> > Please find below my comments on draft‐ietf‐sacm‐architecture‐02. I
> > also addressed in my comments some of the open questions raised in the
> I-D.
> >
> >
> >
> > reference architecture is obviously related to SACM (even if one is
> > with acronyms expanded and the other is not). Please find some more
> > inspiring words avoiding the repetition.
> >
> >
> >
> > accessible while the WG is active (and subject to change during this
> > period) but tends to disappeared when the WG is concluded. A recap of
> > the problem statement in the introductory sections of the architecture
> > document provides background information for the architecture that
> > follows and can be very useful for understanding some of the fundamental
> decisions.
> >
> >
> >
> > the proxy or broker (and possibly routing) function in the data plane’
> > I went back to the terminology document.
> >
> >
> >
> > These definitions seem to need more work. They are partially redundant
> > – is this by design? Proxy is not ‘participating in the architecture’?
> > Then how is it between the 2-3 fundamental functions of the
> > controller? There needs to be more work in the terminology document I
> guess.
> >
> >
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> >
> man_listinfo_sacm&d=AwIFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31
> OcNXCJf
> >
> QzvlsiLQfucBXRucPvdrphpBsFA&m=D_EUJ97QuSAfZQtEcPSsOyFIqJw1E9U4r
> WgBhKHU
> > 28c&s=o_w170WvMZrGRmbAiijyA9FCJZ4QcRXWYc8Ko_zSfRg&e=
> >

---

From: Jerome Athias <[email-masked]>
Date: Sun, 22 Feb 2015 10:48:26 +0100

Hi,

thanks for the quick feedback.
I get your point.
Your answer is fair enough.

I could be wrong, but I think you could save moths, or years, of work
by spending few hours looking at it.

Have a nice week-end
Best regards

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 22 Feb 2015 10:11:51 +0000

Hi Jerome, 

As I said, we can use your help here. You seem to be familiar with the ETSI M2M work, many of us are not. Guidance would be appreciated with a short explanation about the relation between the ETSI M2M work and SACM WG scope and work-in-progress, and what you believe can be used or referred. We can also make room for a short introduction at IETF 92 if agenda allows. 

Thanks and Regards,

Dan

> Sent: Sunday, February 22, 2015 11:48 AM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> I could be wrong, but I think you could save moths, or years, of work by
> spending few hours looking at it.
> 
> Have a nice week-end
> Best regards
> 
> 
> > I am afraid that you will need to make the effort of sorting out the
> comments that you believe are important and relevant to the SACM charter
> and work-in-progress and enter them in Github, as issues to be tracked for
> the SACM documents. Referring to publicly available documents from ETSI is
> fine, but not all are relevant and asking the SACM WG participants to review
> all these is I am afraid a burden that many of us who are not already involved
> in the ETSI work cannot afford.
> >
> > Thanks and Regards,
> >
> > Dan
> >
> >
> >> > period) but tends to disappeared when the WG is concluded. A recap
> >> > of the problem statement in the introductory sections of the
> >> > architecture document provides background information for the
> >> > architecture that follows and can be very useful for understanding
> >> > some of the fundamental
> >> decisions.
> >> >
> >> >
> >> >
> >> > These definitions seem to need more work. They are partially
> >> > redundant – is this by design? Proxy is not ‘participating in the
> architecture’?