Subject: Re: [sacm] poll: Trac or GitHub or None?

From: Kathleen Moriarty <[email-masked]>
Date: Sun, 8 Feb 2015 11:13:57 -0500

Sent from my iPhone

>> On Jan 29, 2015, at 2:25 PM, Sean Turner <[email-masked]> wrote:
>> 
>> On Jan 23, 2015, at 20:29, Lorenzin, Lisa <[email-masked]> wrote:
>> 
>> If it was just me, I'd use Trac because it seems simpler to me. But if the rest of the group prefers Github, I will endeavor to wrap my head around it. :)
> 
> I’ve got some links to some pointers for GitHub that Martin Thompson provided when I had to get my head around GitHub too.
> 
> For ID authors there’s:
> https://github.com/martinthomson/i-d-template
> 
> If the chairs make a WG repo (and make you a contributor) then it’ll look slightly more official - and they can add note well and the like.
> 
> Personally, I like github because there’s a whole lotta open source folks using it.

+1. I believe the WG is only talking about issue tracking right now, but WGs using this for document editing seem to really prefer the ability to see updates/draft management in between IETF versions.

Kathleen
No hat
> 
> spt
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm

---

From: Chris Inacio <[email-masked]>
Date: Mon, 9 Feb 2015 15:44:49 +0000

+1 for GitHub.

--
Chris Inacio
[email-masked]

> On Feb 8, 2015, at 11:13 AM, Kathleen Moriarty <[email-masked]> wrote:
> 
> 
> 
> Sent from my iPhone
>

---

From: Kathleen Moriarty <[email-masked]>
Date: Mon, 9 Feb 2015 10:51:19 -0500

Is the WG interested in editing drafts via GitHub as well or just tracking
issues?  Other WGs find editing drafts via GitHub very helpful.  I believe
both Sean and I have sent links for examples and how to do this.

Thanks.

On Mon, Feb 9, 2015 at 10:44 AM, Chris Inacio <[email-masked]> wrote:

> >>> If it was just me, I'd use Trac because it seems simpler to me. But if
> the rest of the group prefers Github, I will endeavor to wrap my head
> around it. :)
> >>
> >> I’ve got some links to some pointers for GitHub that Martin Thompson
> provided when I had to get my head around GitHub too.
> >>
> >> For ID authors there’s:
> >> If the chairs make a WG repo (and make you a contributor) then it’ll
> look slightly more official - and they can add note well and the like.
> >>
> > +1. I believe the WG is only talking about issue tracking right now, but
> WGs using this for document editing seem to really prefer the ability to
> see updates/draft management in between IETF versions.
> >
> > Kathleen
> > No hat
> >>
> >> spt

-- 

Best regards,
Kathleen

---

From: Jerome Athias <[email-masked]>
Date: Mon, 9 Feb 2015 16:57:29 +0100

+1 for GitHub for issues, and drafts
Could we also track an actions plan/risks register?

Best regards

2015-02-09 16:51 GMT+01:00 Kathleen Moriarty <[email-masked]>:
>> > On Feb 8, 2015, at 11:13 AM, Kathleen Moriarty
>> > <[email-masked]> wrote:
>> >
>> >
>> >
>> > Sent from my iPhone
>> >
>> >>> the rest of the group prefers Github, I will endeavor to wrap my head around
>> >>> it. :)
>> >>
>> > WGs using this for document editing seem to really prefer the ability to see
>> > updates/draft management in between IETF versions.
>> >
>> > Kathleen
>> > No hat
>> >>
>> >> spt

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 10 Feb 2015 10:13:36 -0800

One of the issues that was not discussed on the call is the structure that is going to be used for the repository.

TLS has a project which is the working group and then a different repository for each different document https://github.com/tlswg

I have also seen a single repository with a different subdirectory for each different 

One could also I suppose have a single repository with different files in that repository for each draft.

The choice makes a difference in terms of how issues are going to be tracked.  The first means that each different draft has its own issue tracker.  There is no easy way to look at all of the issues in a single view.  It can also be a problem if an issue is attached to two different drafts as the issue either needs to cross point to the other one or be duplicated.  

The first is easier if you are using all of the fancy makefiles that have been created for doing releases and automatic building of files during merges.   I don’t know that doing tagging works well for doing tags on different directories of different strings.

Jim

From: sacm [mailto:[email-masked]] On Behalf Of Kathleen Moriarty
Sent: Monday, February 09, 2015 7:51 AM
To: Chris Inacio
Cc: Dan Romascanu; Sean Turner; [email-masked]; Lorenzin, Lisa
Subject: Re: [sacm] poll: Trac or GitHub or None?

Is the WG interested in editing drafts via GitHub as well or just tracking issues?  Other WGs find editing drafts via GitHub very helpful.  I believe both Sean and I have sent links for examples and how to do this.

Thanks.

+1 for GitHub.

--
Chris Inacio
[email-masked]

 

-- 

Best regards,

Kathleen

---

From: Aziz Mohaisen <[email-masked]>
Date: Tue, 10 Feb 2015 13:42:08 -0500

That is perhaps something that the working group or chairs have to decide.
I am not sure if the TLS WG is using GitHub for issue tracking, editing
documents, or both, so cannot speak for their choice.

If we are going to use GitHub for issue tracking only, I think it would be
reasonable to have all document in a single repository for cross-reference
of issues -- just the way Jim explained it.

However, if we are to use GitHub for tracking and authoring -- contributing
to documents, it becomes infeasible to have a single repository with a
directory structure for documents.

As of now, I have created a single repository for each document that's
posted on the WG page:

https://github.com/sacm

I need everyone who wants to be a collaborator on any document to send me
their user id on github.

Thanks,
Aziz

---------
Aziz Mohaisen
www.mohaisen.net

On Tue, Feb 10, 2015 at 1:13 PM, Jim Schaad <[email-masked]> wrote:

> TLS has a project which is the working group and then a different
> repository for each different document https://github.com/tlswg
>
>
>
> The choice makes a difference in terms of how issues are going to be
> tracked.  The first means that each different draft has its own issue
> tracker.  There is no easy way to look at all of the issues in a single
> view.  It can also be a problem if an issue is attached to two different
> drafts as the issue either needs to cross point to the other one or be
> duplicated.
>
>
>
> The first is easier if you are using all of the fancy makefiles that have
> been created for doing releases and automatic building of files during
> merges.   I don’t know that doing tagging works well for doing tags on
> different directories of different strings.
>
>
>
> Jim
>
>
>
>
>
> *From:* sacm [mailto:[email-masked]] *On Behalf Of *Kathleen
> Moriarty
> *Sent:* Monday, February 09, 2015 7:51 AM
> *To:* Chris Inacio
> *Cc:* Dan Romascanu; Sean Turner; [email-masked]; Lorenzin, Lisa
> *Subject:* Re: [sacm] poll: Trac or GitHub or None?
>
>
>

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 10 Feb 2015 14:36:22 -0800

Note – You don’t need to be a collaborator on a document in order to 

1)      Open issues

2)      Clone and make pull requests

The collaborators should be the main document editors.

Jim

From: Aziz Mohaisen [mailto:[email-masked]] 
Sent: Tuesday, February 10, 2015 10:42 AM
To: Jim Schaad
Cc: [email-masked]
Subject: Re: [sacm] poll: Trac or GitHub or None?

That is perhaps something that the working group or chairs have to decide. I am not sure if the TLS WG is using GitHub for issue tracking, editing documents, or both, so cannot speak for their choice. 

If we are going to use GitHub for issue tracking only, I think it would be reasonable to have all document in a single repository for cross-reference of issues -- just the way Jim explained it. 

However, if we are to use GitHub for tracking and authoring -- contributing to documents, it becomes infeasible to have a single repository with a directory structure for documents. 

As of now, I have created a single repository for each document that's posted on the WG page:

https://github.com/sacm

I need everyone who wants to be a collaborator on any document to send me their user id on github.

Thanks,
Aziz

---------

Aziz Mohaisen

www.mohaisen.net <http://www.mohaisen.net/> 

Jim

Thanks.

+1 for GitHub.

--
Chris Inacio
[email-masked]

 

-- 

Best regards,

Kathleen

---

From: Aziz Mohaisen <[email-masked]>
Date: Tue, 10 Feb 2015 20:53:59 -0500

That is correct. Collaborators (and owners of an organizations in the terms
of github) are only main authors on documents.

My earlier comment is concerning manageability of large repositories.

Aziz
On Feb 10, 2015 5:37 PM, "Jim Schaad" <[email-masked]> wrote:

> *From:* Aziz Mohaisen [mailto:[email-masked]]
> *Sent:* Tuesday, February 10, 2015 10:42 AM
> *To:* Jim Schaad
> *Cc:* [email-masked]
> However, if we are to use GitHub for tracking and authoring --
> contributing to documents, it becomes infeasible to have a single
> repository with a directory structure for documents.
>