Subject: [sacm] GitHub Issue Types

From: "Adam W. Montville" <[email-masked]>
Date: Sat, 28 Mar 2015 08:13:56 -0500

When we work with issues in GitHub, we can use labels provided.  These are:

bug
duplicate
enhancement
help wanted
invalid
question
wontfix

I think we can use these to our advantage. Any suggestions as to how?  Here’s what I was thinking, but usually you all have different perspectives…

On the submission side:
- Your issue is a bug if you’re submitting for a change to existing content
- Your issue is an enhancement if you’re submitting for content addition
- Your issue is a question if you’re unclear about the meaning of some piece of content

On the issue handling side:
- The issue is a duplicate if it’s already tracked elsewhere
- The issue is invalid if it’s, well, invalid or not applicable

I’m not sure the other labels (help wanted, wontfix) are going to be that useful for us.

Thoughts?

Adam

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 30 Mar 2015 08:51:30 +0000

Seems reasonable. Let's try to use these. 

Thanks and Regards,

Dan

> -----Original Message-----
> From: sacm [mailto:[email-masked]] On Behalf Of Adam W.
> Montville
> Sent: Saturday, March 28, 2015 4:14 PM
> To: [email-masked]
> Subject: [sacm] GitHub Issue Types
> 
> I think we can use these to our advantage. Any suggestions as to how?
> Here’s what I was thinking, but usually you all have different perspectives…
> 
> On the submission side:
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_sacm&d=AwIGaQ&c=BFpWQw8bsuKpl
> 1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=R3kCtw
> jEAJisqCig-
> cK8zocUhR5nUwxPOwy4jGvvIqs&s=acvIDrBxQaBYoDt6wwnMGjdkivvgraFpX
> s4o6A3_aKE&e=