Subject: [sacm] Information Model vs Data Model

From: "Jim Schaad" <[email-masked]>
Date: Fri, 10 Apr 2015 12:41:03 -0700

Before I finish entering the issues that I have on the requirements
document, I need to get some clarification in my mind about the differences
between the IM and the DM and where some of the requirements belong.

I believe that most of the IM requirements would naturally devolve into DM
requirements.  Thus stating them as IM requirements seems to me to be more
natural.  This is especially true if you believe that a DM is just a
"usable" implementation of an IM.  Thus if you say you need an IP address in
the IM, it would be up to the DM to decide if that included both v4 and v6
addresses as well as deciding on the internal representation (i.e. a string
vs a sequence of integers).  On the other had the IM could be more specific
about the types of IP addresses it requires and that would restrict the
choices of the DM.

I am not sure, but I believe that evaluation criteria are actually written
against an IM and not a DM.  A extant evaluator would take in the criteria
and perhaps only be able to do the validation against one DM, but could use
multiple DMs in the process of doing the evaluation.  (Similarly an
evaluation criteria could reference multiple IMs by inclusion as well.)

This type of thinking comes into effect when you are looking at requirements
like DM-005.  This is the type of requirement that I believe could just as
easily be an IM requirement, and thus more likely to be universal across
multiple DM both in existence and consistency of the type of data that would
be kept.

Am I wrong in my thinking.

Jim

---

From: "Adam W. Montville" <[email-masked]>
Date: Fri, 10 Apr 2015 16:33:25 -0500

> On Apr 10, 2015, at 2:41 PM, Jim Schaad <[email-masked]> wrote:
> 
> Before I finish entering the issues that I have on the requirements document, I need to get some clarification in my mind about the differences between the IM and the DM and where some of the requirements belong.
>  
> I believe that most of the IM requirements would naturally devolve into DM requirements.  Thus stating them as IM requirements seems to me to be more natural.  This is especially true if you believe that a DM is just a “usable” implementation of an IM.  Thus if you say you need an IP address in the IM, it would be up to the DM to decide if that included both v4 and v6 addresses as well as deciding on the internal representation (i.e. a string vs a sequence of integers).  On the other had the IM could be more specific about the types of IP addresses it requires and that would restrict the choices of the DM.
>  
> I am not sure, but I believe that evaluation criteria are actually written against an IM and not a DM.  A extant evaluator would take in the criteria and perhaps only be able to do the validation against one DM, but could use multiple DMs in the process of doing the evaluation.  (Similarly an evaluation criteria could reference multiple IMs by inclusion as well.)
>  
> This type of thinking comes into effect when you are looking at requirements like DM-005.  This is the type of requirement that I believe could just as easily be an IM requirement, and thus more likely to be universal across multiple DM both in existence and consistency of the type of data that would be kept.
>  

Probably not - at least not entirely.  Are you suggesting that the DM requirements should simply be IM requirements (where they don’t already exist)?  Does your thinking change at all between considering existing data models and those we might define?  

>  
> Jim
>  
> _______________________________________________
> sacm mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sacm <https://www.ietf.org/mailman/listinfo/sacm>

---

From: "Jim Schaad" <[email-masked]>
Date: Fri, 10 Apr 2015 16:26:12 -0700

From: sacm [mailto:[email-masked]] On Behalf Of Adam W. Montville
Sent: Friday, April 10, 2015 2:33 PM
To: Jim Schaad
Cc: [email-masked]
Subject: Re: [sacm] Information Model vs Data Model

[JLS] Yes, I am thinking that several of the DM requirements should be stated as IM requirements.  I don’t  think that my thoughts would change at all if one is considering using existing data models.  If that is the case then they either meet what the group believes are requirements or they don’t.  If they don’t then that would be for the group to grapple with at that time.

Jim

_______________________________________________
sacm mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/sacm> https://www.ietf.org/mailman/listinfo/sacm

---

From: "Adam W. Montville" <[email-masked]>
Date: Sat, 11 Apr 2015 08:26:29 -0500

> On Apr 10, 2015, at 6:26 PM, Jim Schaad <[email-masked]> wrote:
> 
>  
>  
> From: sacm [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Adam W. Montville
> Cc: [email-masked] <mailto:[email-masked]>
>> On Apr 10, 2015, at 2:41 PM, Jim Schaad <[email-masked] <mailto:[email-masked]>> wrote:
>>  

It sounds, then, that proposals to move the specific DM requirements to IM requirements would best be captured as issues in GitHub.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sat, 11 Apr 2015 17:32:00 +0000

I would be cautious in making such a change (i.e. suggesting that the DM requirements should simply be IM requirements). I am concerned that by making the requirements on the IM we are turning them into non-testable. What eventually matters are the on-wire representations, and these are DML-specific. I know how to test DM requirements which refer to DM objects stored, carried, exchanged by entities. I do not know how to test IEs which are abstract entities defined in documents.

Regards,

Dan

From: sacm [mailto:[email-masked]] On Behalf Of Adam W. Montville
Sent: Saturday, April 11, 2015 4:26 PM
To: Jim Schaad
Cc: [email-masked]
Subject: Re: [sacm] Information Model vs Data Model

On Apr 10, 2015, at 6:26 PM, Jim Schaad <[email-masked]<mailto:[email-masked]>> wrote:

From: sacm [mailto:[email-masked]] On Behalf Of Adam W. Montville
Sent: Friday, April 10, 2015 2:33 PM
To: Jim Schaad
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [sacm] Information Model vs Data Model

On Apr 10, 2015, at 2:41 PM, Jim Schaad <[email-masked]<mailto:[email-masked]>> wrote:

Jim

_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=AwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=s93MZx1sW6nQa7zs0yE00MoHL2IPp2OyBBVrec905Oo&s=N7YQPPxVxdETECfMpBhJSjbIxL0cQYlvmPcAXMm3tuU&e=>

---

From: "Jim Schaad" <[email-masked]>
Date: Sat, 11 Apr 2015 11:35:52 -0700

This makes me even more nervous about some things.  Are you saying that there is no good way to test that a DM meets the requirements of an IM because there is no formal language for an IM?   This makes it difficult to make evaluation criteria based on an IM rather than a DM as well.  It also means that there is no way to know if there are two different DMs in an organization that are supposed to support the same IM that they in fact do so.

Jim

From: sacm [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Saturday, April 11, 2015 10:32 AM
To: Adam W. Montville; Jim Schaad
Cc: [email-masked]
Subject: Re: [sacm] Information Model vs Data Model

Regards,

Dan

 

 

From: sacm [ <mailto:[email-masked]> mailto:[email-masked]] On Behalf Of Adam W. Montville
Sent: Friday, April 10, 2015 2:33 PM
To: Jim Schaad
Cc:  <mailto:[email-masked]> [email-masked]
Subject: Re: [sacm] Information Model vs Data Model

On Apr 10, 2015, at 2:41 PM, Jim Schaad < <mailto:[email-masked]> [email-masked]> wrote:

 

 

Jim

_______________________________________________
sacm mailing list
 <mailto:[email-masked]> [email-masked]
 <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=AwMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=s93MZx1sW6nQa7zs0yE00MoHL2IPp2OyBBVrec905Oo&s=N7YQPPxVxdETECfMpBhJSjbIxL0cQYlvmPcAXMm3tuU&e=> https://www.ietf.org/mailman/listinfo/sacm

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 12 Apr 2015 18:49:41 +0000

I was rather reacting to the proposal ‘the DM requirements should simply be IM requirements’. Again – I do not know how to test some of the requirements on IM. When we instantiate a DM we can test the DM level requirements, but meeting the IM requirements for a specific DML does not necessarily mean that they will be met for other DMs expressed in other DMLs. That is why I believe that there are two levels of requirements here, and we cannot go to the extreme of one level (IM) replacing the other (DM).

Regards,

Dan

From: Jim Schaad [mailto:[email-masked]]
Sent: Saturday, April 11, 2015 9:36 PM
To: Romascanu, Dan (Dan); 'Adam W. Montville'
Cc: [email-masked]
Subject: RE: [sacm] Information Model vs Data Model

Jim

Regards,

Dan

Jim