Subject: Re: [sacm] [draft-ietf-sacm-requirements] DM-002: <no pithy title> (#27)

From: ncamwing <[email-masked]>
Date: Sun, 03 May 2015 20:00:38 -0700

Hi Jim,
The information model should not dictate any specific structure; though i would think a data model would infer one.  That is, some applications may choose a relational vs. graph structure or an unstructured model altogether but that imho is not to be forced by the information model.

To your #3, implementation should not be specified in the IM....again that is up to the DM's implementation (and even there, I may leave implementation out of scope as there may be optimizations a vendor may use to better render their version of a DM).....so I'm not sure how a DM may be broken into well defined modules as that may be implementation specific details?

     Nancy.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/27#issuecomment-98577594

---

From: llorenzin <[email-masked]>
Date: Fri, 08 May 2015 13:54:53 -0700

To #4 (If a DM can be structured, what happens if there are multiple DMs that can represent a submodule? Does the customer need to negoitate just the DM or does it need to negotiate all of the submodule DMs as well?) - I don't see how negotiating all the submodule DMs could be avoided.  

To #3 (If I am implementing a customer against an IM, should I be expected to need to know that the DM is broken down into multiple modules? Is the requirement really that while the DM can be structured, from a query point of view it should not appear to be broken down that way.) - Ideally the DM should appear as one data model to a querent even if it's constructed of multiple hierarchical DMs.

It seems that the theory here is that the querent negotiates all the data model modules, assembles the individual modules into the superset data model, and then queries it as one data model. Is that reasonable in practice?

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/27#issuecomment-100361464

---

From: Nancy <[email-masked]>
Date: Wed, 20 May 2015 14:16:50 -0700

Hi Jim,  I will add your clarifications, but if it's OK, I changed "monolithically or into" to "as one single module or separated into"

Will show up in 06.

Thanks, Nancy

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/27#issuecomment-104041528

---

From: Jim Schaad <[email-masked]>
Date: Wed, 20 May 2015 15:22:23 -0700

That is fine.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/27#issuecomment-104061006

---

From: Jim Schaad <[email-masked]>
Date: Wed, 27 May 2015 14:35:21 -0700

Closed #27.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/27#event-315401809

---

From: Jim Schaad <[email-masked]>
Date: Wed, 27 May 2015 14:35:21 -0700

Fixed in -06

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/27#issuecomment-106086227