Subject: Re: [sacm] [draft-ietf-sacm-requirements] IM-002: Ephemerality (#25)

From: llorenzin <[email-masked]>
Date: Fri, 08 May 2015 14:10:05 -0700

The endpoint generates the data, but is not necessarily (and probably won't be, in most cases) the component publishing the information. The provider is the component publishing the information.  Further, this requirement refers not to a means to _request_ data (requested data is by definition solicited), but a means to _publish_ data.  So I'd revise to:

"Posture Data Publication: The Information Model SHOULD account for the Posture information's ephemerality as the data may be provided by an endpoint either solicited or unsolicited. That is, data models MUST support at least one or both means to publish data: solicited or unsolicited. For example, a compliance-server provider may publish endpoint posture information in response to a request from a consumer (solicited), or it may publish posture information driven by a change in the posture of the endpoint (unsolicited)."

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/25#issuecomment-100368765

---

From: ncamwing <[email-masked]>
Date: Fri, 08 May 2015 16:16:16 -0700

So, I think the first sentence is not clear....and yes, I had to look up the definition of "ephemeral" to see if we were using it correctly and I believe we are not:

>From http://www.merriam-webster.com/dictionary/ephemeral:
adjective ephem·er·al \i-ˈfem-rəl, -ˈfēm-; -ˈfe-mə-, -ˈfē-\
1
:  lasting one day only <an ephemeral fever>
2
:  lasting a very short time <ephemeral pleasures>

Which is NOT the intent of requirement; I believe the requirement is about ensuring the Information Model allow for the information to be acquired solicted or unsolicited.  So, another suggested update:

"Posture Data Publication: The Information Model SHOULD allow for the data to be provided by an endpoint either solicited or unsolicited. That is, data models MUST support at least one or both means to publish data: solicited or unsolicited. For example, a compliance-server provider may publish endpoint posture information in response to a request from a consumer (solicited), or it may publish posture information driven by a change in the posture of the endpoint (unsolicited)."

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/25#issuecomment-100392108

---

From: Jim Schaad <[email-masked]>
Date: Sun, 10 May 2015 13:46:26 -0700

Looks fine in -05.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/25#issuecomment-100698686