Subject: Re: [sacm] [draft-ietf-sacm-requirements] Requirement G-001 - Solution Extensibility (#7)

From: llorenzin <[email-masked]>
Date: Fri, 08 May 2015 15:13:16 -0700

#2 Please do not remove "non-standard extensions".  The point there is that SACM is defining a set of standard data models, protocols, and transports - but we want the SACM ecosystem to not be constrained to _only_ use those data models, protocols, and transports.  So, for example, if we define a data model for endpoint posture data, and someone else defines a data model for endpoint behavior data, that is a non-standard data model - but if SACM is created with the appropriate extensibility, you should still be able to carry that data model over the standard transport.  Likewise, we will define a standard transport, but ideally that won't be the _only_ transport you can use. That's what "non-standard" means to me in this context.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/7#issuecomment-100381019

---

From: Jim Schaad <[email-masked]>
Date: Fri, 08 May 2015 15:49:46 -0700

Can you give an example of something that would not fit into the concept of "future extensions" that would fit into the concept of "non-standard extensions"?

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/7#issuecomment-100388724