Subject: [sacm] [draft-ietf-sacm-requirements] OP-001 Time Synchronization (#39)

From: Jim Schaad <[email-masked]>
Date: Thu, 14 May 2015 09:48:53 -0700

Version -05

1.  It really feels as if this items is imposing an architectural requirement.  That requirement being that there is a time synchronization between the components in the architecture.

ARCH-XXX Time Synchronization:  Actions or decisions based on time-sensitive data (such as user logon/logoff endpoint connection/disconnection, endpoint behaviour events, etc.) are all predicated on a synchronized understanding of time.  The SACM architecture MUST provide a mechanism for all components to be able to query for a synchronized time.  A mechanism for detecting and reporting time discrepancies SHOULD be provided by the architecture and reflected in the Information Model.

2.  I am not sure if this requirement is stating that the timestamp needs to be in the interface or if it can merely be that the recipient does the timestamp operation.  This may be different if one is looking at publishing vs querying of data.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/39

---

From: Nancy <[email-masked]>
Date: Wed, 20 May 2015 15:09:15 -0700

Hi Jim,

I think you are referring to OP-001 (Time Synchronization), where we want to impose requirements that both the requests and responses be timestamped by the consumer and provider respectively.

Which does imply that there SHOULD be the means to provide a mechanism to synchronize time.  The question is whether the architecture requirement is a SHOULD vs. a MUST.....I pose the SHOULD because not all systems will want or use it, but as it is "the" SACM arch then it has to have a means to facilitate it for those who do want it.....is that why you placed the MUST?

BTW, I will add it as IM-006 and leave it as a MUST for now....

Thanks,  Nancy

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/39#issuecomment-104057388

---

From: Jim Schaad <[email-masked]>
Date: Wed, 20 May 2015 15:22:06 -0700

I think that this is a MUST requirement in terms of the architecture itself.  There is no requirement for this to be deployed in a specific location.  However if any OP is going to require that it exists, then it needs to be part of the basic architecture.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/39#issuecomment-104060968

---

From: Nancy <[email-masked]>
Date: Wed, 20 May 2015 15:26:45 -0700

Agreed, I'll leave it as a MUST......

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/39#issuecomment-104061736

---

From: Jim Schaad <[email-masked]>
Date: Wed, 27 May 2015 14:51:44 -0700

Closed #39.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/39#event-315412038

---

From: Jim Schaad <[email-masked]>
Date: Wed, 27 May 2015 14:51:44 -0700

Looks done in -06

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/39#issuecomment-106088819