Subject: Re: [sacm] [draft-ietf-sacm-requirements] IM-001: Extensible Attribute Dictionary (#24)

From: ncamwing <[email-masked]>
Date: Sun, 03 May 2015 22:29:16 -0700

Hi Jim,

Please suggest a better wording....the intent is to ensure that the information model provides a required set (e.g. minimally) to ensure interoperability between data models.  But also, I think there can be a very large set of attributes to achieve "posture", so the information model has to define the MUST (as 'the' minimum set) of attributes that a data model must support.

Again, I am going by the basis that there is a single SACM information model that a data model must meet requirements.....a data model could be extended to have its own attributes but that could be for vendor differentiation or because there may be different types of applications (e.g. there may be apps that do more than posture so the data model would be richer in that sense).  

Does that help?
   Nancy.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/24#issuecomment-98591365

---

From: Jim Schaad <[email-masked]>
Date: Fri, 08 May 2015 15:27:22 -0700

That is a clear requirement.  And it very clearly expresses what is a DM requirement that needs to be adhered to.  Should there be a sentence along the lines of "The attribute dictionary should be defined with a clear mechanism for extensibility to enable future versions of the information model to be expanded with new attributes."

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/24#issuecomment-100385086

---

From: ncamwing <[email-masked]>
Date: Fri, 08 May 2015 20:21:53 -0700

I think the added sentence to Lisa's updates makes sense as well....will do in -05

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/24#issuecomment-100417749

---

From: Jim Schaad <[email-masked]>
Date: Sun, 10 May 2015 13:45:16 -0700

Looks fine to me.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/24#issuecomment-100698204