Subject: Re: [sacm] [draft-ietf-sacm-requirements] G-005: Information Extensibility (#11)

From: ncamwing <[email-masked]>
Date: Mon, 04 May 2015 18:34:36 -0700

Hi Jim,
I think you mean G-006 "Extensibility"....to comment on your points:
1. We should avoid name collisions in the standard attribute definitions as data models are mapped to the information model.....I think it will be hard to enforce non-standard attribute definitions that may collide.  But say, if the information model defines a "software version" attribute to be a string (vs. a number), then the data model should map directly to it (vs. overriding it, say to be a numeric value as that would be a type of collision).  Similarly, non-standard attribute names may collide but I am not sure how we can enforce such avoidance?

2. Given that there's a single SACM information model, I think the collisions are more about the data model (though since this is general, we do need to ensure we don't mess up and create collisions in the IM too).

3. The SHOULD is to avoid collisions (perhaps a MUST for the information model and for the standard base but a SHOULD for the non-standard). 

4. The attributes are defined in the information model with the mandatory ones to be highlighted to ensure the data models include them.

If you have suggestions for language improvements let me know!

Thanks, Nancy

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/11#issuecomment-98901629

---

From: llorenzin <[email-masked]>
Date: Fri, 08 May 2015 14:55:11 -0700

To Nancy's comment "Similarly, non-standard attribute names may collide but I am not sure how we can enforce such avoidance?" - One way to avoid attribute name collisions is to require a unique well-defined prefix (such as the 24-bit SMI Private Enterprise Number Vendor ID, which is what TCG uses to avoid name collisions for vendor-defined elements) on the name.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/11#issuecomment-100378216

---

From: ncamwing <[email-masked]>
Date: Fri, 08 May 2015 20:08:23 -0700

I think there are ways to define mechanisms to avoid collisions, my point is that SACM can not really enforce it as it is implementation based.

That is, from a specification (vs. requirement) we can specify how attributes can be defined to avoid collisions.....but am not sure we put that as a requirement?

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/11#issuecomment-100414749

---

From: Jim Schaad <[email-masked]>
Date: Wed, 13 May 2015 21:40:45 -0700

Information Extensibility:  Non-standard (implementation-specific) data attributes MUST be supported.  A method SHOULD be defined for preventing collisions from occurring in the naming of all data attributes independent of their source.  For interoperability and scope boundary, the information model MUST define the mandatory set of data attributes.   The set of attributes defined by the information model MUST be well defined.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/11#issuecomment-101907056

---

From: Jim Schaad <[email-masked]>
Date: Wed, 27 May 2015 14:32:48 -0700

Closed #11.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/11#event-315400179

---

From: Jim Schaad <[email-masked]>
Date: Wed, 27 May 2015 14:32:47 -0700

Fixed in -06

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/11#issuecomment-106085805