Subject: [sacm] [draft-ietf-sacm-terminology] Does a repository provide data? (#25)

From: Danny Haynes <[email-masked]>
Date: Mon, 07 Dec 2015 18:40:30 -0800

Currently, the definition for "repository" is:

"A repository is a specific controller type that contains functions to store information of a particular kind - typically data transported on the data plane, but potentially also data and metadata from the control and management plane. A single repository may provide the functions of more than one specific repository type (i.e. configuration baseline repository, assessment results repository, etc.)"

Furthermore, Section 3.1.4 of the Architecture draft states:

"Repository:  Intermediary receiving and storing data from a Provider, and providing stored data to a Consumer.  Implements both control and data plane functions. "

Given this, shouldn't the definition of "repository", in the Terminology draft, say something about providing data?

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/25

---

From: Jerome Athias <[email-masked]>
Date: Sun, 13 Dec 2015 20:05:59 -0800

Good point.
Potentially consider also the term (Knowledge) Catalog before updating the Terminology draft.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/25#issuecomment-164337365