Subject: [sacm] Consensus Call: Choosing an IM Expression Syntax

From: "Adam W. Montville" <[email-masked]>
Date: Wed, 2 Dec 2015 09:19:05 -0600

Hi.

This message starts a two-week consensus call for selecting an
expression syntax for our Information Model.  Danny has already started
a thread on the subject [1].  There are five options in total:

Option 1: RFC 7326 - Energy Management Framework [2]

Option 2: Information Model for Large-Scale Measurement Platforms [3]

Option 3: Unified Modeling Language [4]

Option 4: Entity-relationship Diagram [5]

Option 5: Plain English, as exemplified by RFC 6880 [6]

Please let us know your preference, if you have not already, no later
than 23:59 UTC on 2015-12-16.

Kind regards,

Adam

[1]
https://mailarchive.ietf.org/arch/search/?email_list=sacm&gbt=1&index=UGE7tF3SO-e3Bo1AkwVHVvtvu3s

[2] https://datatracker.ietf.org/doc/rfc7326/

[3] https://datatracker.ietf.org/doc/draft-burbridge-lmap-information-model/

[4] http://www.uml-diagrams.org/

[5] https://en.wikipedia.org/wiki/Entity%E2%80%93relationship_model

[6] https://tools.ietf.org/html/rfc6880

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 7 Dec 2015 14:01:39 -0800

I have tried to find time over the last few weeks to look at this and figure
out what the formal language, if any is.

Based on what I have seen, I don't know that I have a preference that I can
state.   We can easily formalize a syntax for the first two, but there is no
existing syntax that I can find that can be used.

Option 1: roll your own syntax that somewhat matches UML v 1.5

Option 2: roll your own syntax

Option 3: graphical syntax - If we do this then we need to consider moving
to the v3 xml2rfc so that we can use better graphics tools.  Hard to compile
for correctness checking

Option 4:  same as above .  Hard to compile for correctness checking

Option 5: hard to compile for correctness checking

ASN.1/MIB - This was a common IM model that is not used so much anymore.
MIBs are for old ASN.1 and a newer version would be nicer if we use this.
Lots of tools exist but almost nobody likes it (except maybe me).

Jim

> -----Original Message-----
> From: sacm [mailto:[email-masked]] On Behalf Of Adam W. Montville
> Sent: Wednesday, December 02, 2015 7:19 AM
> To: [email-masked]
> Subject: [sacm] Consensus Call: Choosing an IM Expression Syntax
> 
> Hi.
> 
> This message starts a two-week consensus call for selecting an expression
> syntax for our Information Model.  Danny has already started a thread on
the
> subject [1].  There are five options in total:
> 
> Please let us know your preference, if you have not already, no later than
23:59
> UTC on 2015-12-16.
https://mailarchive.ietf.org/arch/search/?email_list=sacm&gbt=1&index=UGE7t
> F3SO-e3Bo1AkwVHVvtvu3s
> [3]
https://datatracker.ietf.org/doc/draft-burbridge-lmap-information-model/
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 8 Dec 2015 14:39:53 +0000

I prefer Option 2, followed by Option 5. 

It is also worth looking at the Information Models defined by the IPFIX working group. 

Regards,

Dan

> Sent: Wednesday, December 02, 2015 5:19 PM
> To: [email-masked]
> syntax for our Information Model.  Danny has already started a thread on the
> 23:59 UTC on 2015-12-16.

---

From: David Harrington <[email-masked]>
Date: Fri, 11 Dec 2015 17:23:31 -0500

I do not like options 3 and 4 because to use them effectively typically requires tools that can be expensive. These options therefore favor contributors working for large companies and makes it harder for students, consultants, and other cash-limited contributors. 

I have no experience with #1 and #2, so i'm neutral on those, but wonder if they might tend to favor certain segments of the industry. 

#5 is free and accessible to all ietf contributors (assuming reasonable english skill) so i favor this as one viable approach although it lacks a standardized structure which can help endure completeness and robustness of models. 

David Harrington
[email-masked]
603-828-1401

> On Dec 8, 2015, at 9:39 AM, Romascanu, Dan (Dan) <[email-masked]> wrote:
>

---

From: "Adam W. Montville" <[email-masked]>
Date: Wed, 30 Dec 2015 15:46:45 -0600

Hi again.  After going through the multiple threads on this topic, it's
not really clear which approach people would like to take.  This is in
part because some people changed their preference between the two threads.

For the record, here's what I was able to count (I think):

Option 1: 3 (one person also voted for Option 3)
Option 2: 1 (a first preference for one person)
Option 3: 3 (one person also voted for Option 1)
Option 4: 0
Option 5: 5 (one of which is an individual's second preference; another
of which would switch from Option 3)

I've heard, privately, some strong arguments against using English. 
I've heard rather reasonable arguments in favor of it.

Given the confusion along the way, let's restart this consensus call
based on the options as originally indicated (see message below). Let's
leave it open until midnight (UTC) January 7.  We need to arrive at some
conclusion very soon, so that we can start making tangible progress on
expressing the IM.

Kind regards,

Adam

---

From: Jerome Athias <[email-masked]>
Date: Thu, 31 Dec 2015 09:29:17 +0300

Hi,

Few comments on some of the options:
Option 3 (UML) is, imho, more descriptive than Option 4 (E-R). But
both are 'visual'. (brain friendly)
Option 4 (E-R) is, imho, the fastest way for implementation (without
arguing for 'quality/scale' of it).
Option 3 (UML) requires, imho, a little bit of extra work vs Option 4
(E-R), but results in Option 4+ and is more generic/flexible for
implementation.
Option 3 (UML) would come with (straight to the point) Option 5 (Plain English).
Option 5 (Plain English) is not visual. (obtaining UML or E-R from
Option 5, while possible, would open the door for interpretation,
leading potentially to misunderstandings, etc. And, imho, would need
more (time) effort).

While, I can understand interest for Option 5 (Plain English), and it
would kind of have to be done at some level, in terms of
time-implementation-efficiency trade-off:
- I think that Option 3 (UML) would be very valuable.

(but again, if Option 5 is performed well*, it will help for Option 3 and 4)

* "If you can't explain it simply, you don't understand it yourself.",
Albert Einstein

PS: My work on the XORCISM research is available, as of today, as
Option 4. But Option 3 or/and Option 5 could be built on it, quite
easily, and imho, could save time.

Best regards
Hacky New Year!
/JA

---

From: Adam Montville <[email-masked]>
Date: Thu, 31 Dec 2015 10:41:45 -0600

Thanks, Jerome.  

To be clear, are you throwing your hat in for Option 3?

> On Dec 31, 2015, at 12:29 AM, Jerome Athias <[email-masked]> wrote:
> 
> Hi,
>