Subject: Re: [sacm] Consensus Call: Choosing an IM Expression Syntax

From: "Wolfkiel, Joseph L CIV DISA ID (US)" <[email-masked]>
Date: Tue, 29 Dec 2015 19:28:59 +0000

I'm not wedded to UML.  If throwing my vote to plain English would make this move along, I'm fine with it.

Joseph L. Wolfkiel
SCM Engineering Lead
DISA ID52
Fort Meade DISA Acquisiton Bldg Cube A4A58E
Work: (301) 225-8820
Gov Cell: (571) 814-8231
[email-masked]

-----Original Message-----
From: Adam Montville [mailto:[email-masked]] 
Sent: Tuesday, December 29, 2015 12:45 PM
To: Jerome Athias
Cc: Wolfkiel, Joseph L CIV DISA ID (US); [email-masked]
Subject: [Non-DoD Source] Re: [sacm] Consensus Call: Choosing an IM Expression Syntax

All active links contained in this email were disabled. Please verify the identity of the sender, and confirm the authenticity of all links contained within the message prior to copying and pasting the address to a Web browser. 

________________________________

Somehow, my mail client hasn’t threaded things correctly.  I will find and review all of the opinions.

	On Dec 29, 2015, at 11:42 AM, Adam Montville <[email-masked] < Caution-mailto:[email-masked] > > wrote:

	Does no one else have an opinion?  If not, then it would seem that the “consensus” would need to be to use UML (Option 3) as the preferred Information Model expression syntax.

	Kind regards,

	Adam

		On Dec 4, 2015, at 11:17 PM, Jerome Athias <[email-masked] < Caution-mailto:[email-masked] > > wrote:

		Option 3 is fine for me also
		
		On Saturday, 5 December 2015, Wolfkiel, Joseph L CIV DISA ID (US) <[email-masked] < Caution-mailto:[email-masked] > > wrote:

			My preference: Option 3.
			
			Joseph L. Wolfkiel
			SCM Engineering Lead
			DISA ID52
			Fort Meade DISA Acquisiton Bldg Cube A4A58E
			Work: (301) 225-8820
			Gov Cell: (571) 814-8231
			[email-masked] < javascript:; > 

			-----Original Message-----
			From: sacm [Caution-mailto:[email-masked] < javascript:; > ] On Behalf Of Adam W. Montville
			Sent: Wednesday, December 02, 2015 10:19 AM
			To: [email-masked] < javascript:; > 
			Subject: [Non-DoD Source] [sacm] Consensus Call: Choosing an IM Expression Syntax

			Hi.
			
			This message starts a two-week consensus call for selecting an
			expression syntax for our Information Model.  Danny has already started
			a thread on the subject [1].  There are five options in total:
			
			Option 1: RFC 7326 - Energy Management Framework [2]
			
			Option 2: Information Model for Large-Scale Measurement Platforms [3]
			
			Option 3: Unified Modeling Language [4]
			
			Option 4: Entity-relationship Diagram [5]
			
			Option 5: Plain English, as exemplified by RFC 6880 [6]

			Please let us know your preference, if you have not already, no later
			than 23:59 UTC on 2015-12-16.
			
			Kind regards,
			
			Adam

			[1]
			Caution-Caution-https://mailarchive.ietf.org/arch/search/?email_list=sacm&gbt=1&index=UGE7tF3SO-e3Bo1AkwVHVvtvu3s < Caution-https://mailarchive.ietf.org/arch/search/?email_list=sacm&gbt=1&index=UGE7tF3SO-e3Bo1AkwVHVvtvu3s > 
			
			[2] Caution-Caution-https://datatracker.ietf.org/doc/rfc7326/ < Caution-https://datatracker.ietf.org/doc/rfc7326/ > 
			
			[3] Caution-Caution-https://datatracker.ietf.org/doc/draft-burbridge-lmap-information-model/ < Caution-https://datatracker.ietf.org/doc/draft-burbridge-lmap-information-model/ > 
			
			[4] Caution-Caution-http://www.uml-diagrams.org/ < Caution-http://www.uml-diagrams.org/ > 
			
			[5] Caution-Caution-https://en.wikipedia.org/wiki/Entity%E2%80%93relationship_model < Caution-https://en.wikipedia.org/wiki/Entity%E2%80%93relationship_model > 
			
			[6] Caution-Caution-https://tools.ietf.org/html/rfc6880 < Caution-https://tools.ietf.org/html/rfc6880 > 
			
			_______________________________________________
			sacm mailing list
			[email-masked] < javascript:; > 
			Caution-Caution-https://www.ietf.org/mailman/listinfo/sacm < Caution-https://www.ietf.org/mailman/listinfo/sacm >

---

From: Leif Johansson <[email-masked]>
Date: Tue, 29 Dec 2015 20:45:51 +0100

> I'm not wedded to UML.  If throwing my vote to plain English would make this move along, I'm fine with it.

How are you going to represent UML in an I-D? Publish under the new
format rules and do SVG?

Lets just make sure the mechanics of playing with the arrows take
more time and energy than the content.

	Cheers Leif