Subject: Re: [sacm] Consensus Call: Choosing an IM Expression Syntax

From: "Wolfkiel, Joseph L CIV DISA ID (US)" <[email-masked]>
Date: Fri, 4 Dec 2015 21:36:56 +0000

My preference: Option 3.

Joseph L. Wolfkiel
SCM Engineering Lead
DISA ID52
Fort Meade DISA Acquisiton Bldg Cube A4A58E
Work: (301) 225-8820
Gov Cell: (571) 814-8231
[email-masked]

-----Original Message-----
From: sacm [mailto:[email-masked]] On Behalf Of Adam W. Montville
Sent: Wednesday, December 02, 2015 10:19 AM
To: [email-masked]
Subject: [Non-DoD Source] [sacm] Consensus Call: Choosing an IM Expression Syntax

Hi.

This message starts a two-week consensus call for selecting an
expression syntax for our Information Model.  Danny has already started
a thread on the subject [1].  There are five options in total:

Option 1: RFC 7326 - Energy Management Framework [2]

Option 2: Information Model for Large-Scale Measurement Platforms [3]

Option 3: Unified Modeling Language [4]

Option 4: Entity-relationship Diagram [5]

Option 5: Plain English, as exemplified by RFC 6880 [6]

Please let us know your preference, if you have not already, no later
than 23:59 UTC on 2015-12-16.

Kind regards,

Adam

[1]
Caution-https://mailarchive.ietf.org/arch/search/?email_list=sacm&gbt=1&index=UGE7tF3SO-e3Bo1AkwVHVvtvu3s

[2] Caution-https://datatracker.ietf.org/doc/rfc7326/

[3] Caution-https://datatracker.ietf.org/doc/draft-burbridge-lmap-information-model/

[4] Caution-http://www.uml-diagrams.org/

[5] Caution-https://en.wikipedia.org/wiki/Entity%E2%80%93relationship_model

[6] Caution-https://tools.ietf.org/html/rfc6880

_______________________________________________
sacm mailing list
[email-masked]
Caution-https://www.ietf.org/mailman/listinfo/sacm

---

From: Jerome Athias <[email-masked]>
Date: Sat, 5 Dec 2015 08:17:06 +0300

Option 3 is fine for me also

On Saturday, 5 December 2015, Wolfkiel, Joseph L CIV DISA ID (US) <
[email-masked]> wrote:

> [email-masked] <javascript:;>
>
>
>
> From: sacm [mailto:[email-masked] <javascript:;>] On Behalf Of
> Adam W. Montville
> To: [email-masked] <javascript:;>
> Caution-
> https://mailarchive.ietf.org/arch/search/?email_list=sacm&gbt=1&index=UGE7tF3SO-e3Bo1AkwVHVvtvu3s
>
> [3] Caution-
> https://datatracker.ietf.org/doc/draft-burbridge-lmap-information-model/
>
> [5] Caution-
> https://en.wikipedia.org/wiki/Entity%E2%80%93relationship_model
>
> [email-masked] <javascript:;>

---

From: Adam Montville <[email-masked]>
Date: Tue, 29 Dec 2015 11:42:38 -0600

Does no one else have an opinion?  If not, then it would seem that the “consensus” would need to be to use UML (Option 3) as the preferred Information Model expression syntax.

Kind regards,

Adam

> On Dec 4, 2015, at 11:17 PM, Jerome Athias <[email-masked]> wrote:
> 
> On Saturday, 5 December 2015, Wolfkiel, Joseph L CIV DISA ID (US) <[email-masked] <mailto:[email-masked]>> wrote:
> My preference: Option 3.
> 
> Joseph L. Wolfkiel
> SCM Engineering Lead
> DISA ID52
> From: sacm [mailto:[email-masked] <javascript:;>] On Behalf Of Adam W. Montville
> Caution-https://mailarchive.ietf.org/arch/search/?email_list=sacm&gbt=1&index=UGE7tF3SO-e3Bo1AkwVHVvtvu3s <https://mailarchive.ietf.org/arch/search/?email_list=sacm&gbt=1&index=UGE7tF3SO-e3Bo1AkwVHVvtvu3s>
> 
> [2] Caution-https://datatracker.ietf.org/doc/rfc7326/ <https://datatracker.ietf.org/doc/rfc7326/>
> 
> [3] Caution-https://datatracker.ietf.org/doc/draft-burbridge-lmap-information-model/ <https://datatracker.ietf.org/doc/draft-burbridge-lmap-information-model/>
> 
> [4] Caution-http://www.uml-diagrams.org/ <http://www.uml-diagrams.org/>
> 
> [5] Caution-https://en.wikipedia.org/wiki/Entity%E2%80%93relationship_model <https://en.wikipedia.org/wiki/Entity%E2%80%93relationship_model>
> 
> [6] Caution-https://tools.ietf.org/html/rfc6880 <https://tools.ietf.org/html/rfc6880>
> 
> Caution-https://www.ietf.org/mailman/listinfo/sacm <https://www.ietf.org/mailman/listinfo/sacm>

---

From: Adam Montville <[email-masked]>
Date: Tue, 29 Dec 2015 11:44:34 -0600

Somehow, my mail client hasn’t threaded things correctly.  I will find and review all of the opinions.

> On Dec 29, 2015, at 11:42 AM, Adam Montville <[email-masked]> wrote:
> 
>> On Dec 4, 2015, at 11:17 PM, Jerome Athias <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: "Adam W. Montville" <[email-masked]>
Date: Tue, 29 Dec 2015 13:08:45 -0600

Ok.  It seems that we've got a couple of people in favor of UML (Option
3), one in favor of the Information Model for Large-Scale Measurement
Platforms (Option 2), and a couple in favor of plain English (Option 5).

Given the information at hand, we've got either UML or plain English at
play.  I generally prefer something more strucutred, like UML, but I am
also sensitive to the complications using UML may introduce (as pointed
out by David Harrington and Jim Schaad). 

At this point, I'd like to ask one follow-up question.  Who objects to
plain English for our preferred method of expressing the information model?

Kind regards,

Adam

On 12/29/2015 11:44 AM, Adam Montville wrote:
>> On Dec 29, 2015, at 11:42 AM, Adam Montville
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>> Does no one else have an opinion?  If not, then it would seem that
>> the “consensus” would need to be to use UML (Option 3) as the
>> preferred Information Model expression syntax.
>>
>> Kind regards,
>>
>> Adam
>>
>>
>>
>>> On Saturday, 5 December 2015, Wolfkiel, Joseph L CIV DISA ID (US)
>>> <[email-masked]
>>> <mailto:[email-masked]>> wrote:
>>>
>>>     My preference: Option 3.
>>>
>>>     Joseph L. Wolfkiel
>>>     SCM Engineering Lead
>>>     DISA ID52
>>>     [3]
>>>     Caution-https://datatracker.ietf.org/doc/draft-burbridge-lmap-information-model/
>>>
>>>     [5]
>>>     Caution-https://en.wikipedia.org/wiki/Entity%E2%80%93relationship_model
>>>

---

From: Gunnar Engelbach <[email-masked]>
Date: Tue, 29 Dec 2015 14:12:16 -0500

No objections.

In fact, I think Dave Harrington made a very convincing case for the use 
of plain English.

--gun

On 12/29/2015 2:08 PM, Adam W. Montville wrote:
> Ok.  It seems that we've got a couple of people in favor of UML 
> (Option 3), one in favor of the Information Model for Large-Scale 
> Measurement Platforms (Option 2), and a couple in favor of plain 
> English (Option 5).
>
> Given the information at hand, we've got either UML or plain English 
> at play.  I generally prefer something more strucutred, like UML, but 
> I am also sensitive to the complications using UML may introduce (as 
> pointed out by David Harrington and Jim Schaad).
>
>>>> <[email-masked]> wrote:
>>>>
>>>>     My preference: Option 3.
>>>>
>>>>     Joseph L. Wolfkiel
>>>>     SCM Engineering Lead
>>>>     DISA ID52
> https://www.ietf.org/mailman/listinfo/sacm

---

From: Leif Johansson <[email-masked]>
Date: Tue, 29 Dec 2015 20:47:17 +0100

> plain English for our preferred method of expressing the information model?

I'll go on record with a +1 for plain English because it hopefully helps
the WG to focus on content.

	Cheers Leif

---

From: Adam Montville <[email-masked]>
Date: Tue, 29 Dec 2015 13:50:57 -0600

Contributor hat on: I’m going to +1 for plain English as well. 

> On Dec 29, 2015, at 1:47 PM, Leif Johansson <[email-masked]> wrote:
>

---

From: Iain Bell <[email-masked]>
Date: Wed, 30 Dec 2015 02:58:05 +0000

For what it's worth ( if anything at such a late stage) I think uml is the way forward. It has its limitations however at least these are quantifiable. Where as plain old English is anything but plain

Sent from my iPhone

> On 29 Dec 2015, at 19:50, Adam Montville <[email-masked]> wrote:
>