Subject: Re: [sacm] Consensus Call: Parking Architecture Draft

From: Lisa Lorenzin <[email-masked]>
Date: Mon, 7 Dec 2015 16:05:42 +0000

Hi all,

I agree with Leif that that the architecture draft provides important guidance for the WG.  However, I don't think it makes sense to advance the architecture to IESG separately from solution drafts, since we may (and my guess is, probably will) learn new things from the solution-draft development process that will inform the architecture, and we'll want to have our architecture and solutions in sync when we submit them to IESG.

Parking the architecture draft - specifically, advancing it through WGLC but then holding off on submitting it to IESG - seems like a good approach as long as we are in agreement that we aren't abandoning it entirely.  We're simply acknowledging that it may need to evolve as we gain a better understanding of our solutions.

Regards,
Lisa

-----Original Message-----
From: sacm [mailto:[email-masked]] On Behalf Of Leif Johansson
Sent: Monday, November 16, 2015 5:06 AM
To: [email-masked]
Subject: Re: [sacm] Consensus Call: Parking Architecture Draft

On 2015-11-15 16:55, Adam W. Montville wrote:
> Hi All:
> 
> At some point in the past we've talked about the possibility of 
> "parking" certain foundational drafts while we look at solutions.
> Doing so would, presumably, afford us the ability to go back and 
> change things in our foundation as we discover new knowledge during 
> the course of working on solutions.
> 
> However, during our sessions in Yokohama it was clear that we weren't 
> necessarily aligned on taking such an approach.  In particular, it 
> seemed as though parking our Architecture draft [1] was not desired by 
> the participants in the room.  Part of our Way Forward [2] requires us 
> to determine our approach on the list.
> 
> This message begins such a consensus call.  Please voice your opinion 
> on the matter by December 5, 2014.  "Parking" the architecture draft 
> could mean progressing it through WGLC (when it's ready), but holding 
> off on IESG submission until a later date (after we've done some 
> solutions work).

Personally I don't understand how you can look for solutions when you don't know what you are looking for.

In general I'm not a big fan of the "requirements document"-style in the IETF but this WG seems comparatively unclear on what it wants and so I think the architecture draft provides important guidance for the WG.

For instance the question of security model I raised in Yokohama would have significant impact on both architecture and solutions.
	
	Cheers Leif

_______________________________________________
sacm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sacm

---

From: "Waltermire, David A." <[email-masked]>
Date: Mon, 7 Dec 2015 16:20:59 +0000

+1 to Lisa's comments below.

Dave

> From: sacm [mailto:[email-masked]] On Behalf Of Lisa Lorenzin
> Sent: Monday, December 07, 2015 11:06 AM
> To: Leif Johansson <[email-masked]>; [email-masked]
> I agree with Leif that that the architecture draft provides important guidance
> for the WG.  However, I don't think it makes sense to advance the
> architecture to IESG separately from solution drafts, since we may (and my
> guess is, probably will) learn new things from the solution-draft development
> process that will inform the architecture, and we'll want to have our
> architecture and solutions in sync when we submit them to IESG.
> 
> Parking the architecture draft - specifically, advancing it through WGLC but
> then holding off on submitting it to IESG - seems like a good approach as long
> as we are in agreement that we aren't abandoning it entirely.  We're simply
> acknowledging that it may need to evolve as we gain a better understanding
> of our solutions.
> 
> Regards,
> Lisa
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> In general I'm not a big fan of the "requirements document"-style in the IETF
> but this WG seems comparatively unclear on what it wants and so I think the
> architecture draft provides important guidance for the WG.
> 
> For instance the question of security model I raised in Yokohama would have
> significant impact on both architecture and solutions.
> 
> 	Cheers Leif
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v2
> 
> iEYEARECAAYFAlZJqpQACgkQ8Jx8FtbMZndbrgCgw7HNQ4UykKIbTuc8pFXQAL
> UN
> TREAn3/mcFjnq2un2XtJAJ4CAVWRzm4H
> =g9Bv
> -----END PGP SIGNATURE-----
>

---

From: Jessica Fitzgerald-McKay <[email-masked]>
Date: Mon, 7 Dec 2015 11:46:44 -0500

+1 to Lisa's comments, and an expansion: I think we should also consider
parking the requirements document, for the same reasons. It is very useful
that we have thought through what we need from solutions that meet our use
cases. As we transition our focus to solutions drafts, we will want to
reference the architecture and requirements to make sure we are tracking
with them. As our high-level documents meet with the reality of solutions,
I suspect we will need to do some editing. Parking them lets us reference
them as needed and edit them as adjustments are necessary.

On Mon, Dec 7, 2015 at 11:20 AM, Waltermire, David A. <
[email-masked]> wrote:

> > Personally I don't understand how you can look for solutions when you
> don't
> > know what you are looking for.
> >

---

From: Lisa Lorenzin <[email-masked]>
Date: Mon, 7 Dec 2015 22:34:27 +0000

+1 to Jess's expansion.  (Uh-oh - did I just create a commenting loop? ;) )

Regards,
Lisa

-----Original Message-----
From: Jessica Fitzgerald-McKay [mailto:[email-masked]] 
Sent: Monday, December 07, 2015 11:47 AM
To: Waltermire, David A. <[email-masked]>
Cc: Lisa Lorenzin <[email-masked]>; Leif Johansson <[email-masked]>; [email-masked]
Subject: Re: [sacm] Consensus Call: Parking Architecture Draft

+1 to Lisa's comments, and an expansion: I think we should also consider parking the requirements document, for the same reasons. It is very useful that we have thought through what we need from solutions that meet our use cases. As we transition our focus to solutions drafts, we will want to reference the architecture and requirements to make sure we are tracking with them. As our high-level documents meet with the reality of solutions, I suspect we will need to do some editing. Parking them lets us reference them as needed and edit them as adjustments are necessary.

On Mon, Dec 7, 2015 at 11:20 AM, Waltermire, David A. <[email-masked] <mailto:[email-masked]> > wrote:

	Dave

	> From: sacm [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of Lisa Lorenzin
	> To: Leif Johansson <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
	> From: sacm [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of Leif Johansson
	> To: [email-masked] <mailto:[email-masked]> 
	> [email-masked] <mailto:[email-masked]> 
	> [email-masked] <mailto:[email-masked]> 
	
	_______________________________________________
	sacm mailing list
	[email-masked] <mailto:[email-masked]> 
	https://www.ietf.org/mailman/listinfo/sacm

---

From: Tony Rutkowski <[email-masked]>
Date: Mon, 07 Dec 2015 18:52:42 -0500

+1

---

From: Ira McDonald <[email-masked]>
Date: Mon, 7 Dec 2015 19:39:42 -0500

Hi,

+1 to Leif, David, Lisa, and Jess's comments.

Cheers,
- Ira

PS - Are nested self-referential comments a dangerous psychiatric symptom?

On Mon, Dec 7, 2015 at 5:34 PM, Lisa Lorenzin <[email-masked]>
wrote:

> [email-masked] <mailto:[email-masked]> > wrote:
>
>
>         > From: sacm [mailto:[email-masked] <mailto:
> [email-masked]> ] On Behalf Of Lisa Lorenzin
>         > From: sacm [mailto:[email-masked] <mailto:
> [email-masked]> ] On Behalf Of Leif Johansson
>         > Personally I don't understand how you can look for solutions
> when you don't

---

From: "Haynes, Dan" <[email-masked]>
Date: Tue, 8 Dec 2015 02:02:22 +0000

+1 to parking the architecture and requirements documents.

Thanks,

Danny

From: sacm [mailto:[email-masked]] On Behalf Of Ira McDonald
Sent: Monday, December 07, 2015 7:40 PM
To: Lisa Lorenzin <[email-masked]>; Ira McDonald <[email-masked]>
Cc: Jessica Fitzgerald-McKay <[email-masked]>; Waltermire, David A. <[email-masked]>; [email-masked]; Leif Johansson <[email-masked]>
Subject: Re: [sacm] Consensus Call: Parking Architecture Draft

Hi,

On Mon, Dec 7, 2015 at 5:34 PM, Lisa Lorenzin <[email-masked]<mailto:[email-masked]>> wrote:
+1 to Jess's expansion.  (Uh-oh - did I just create a commenting loop? ;) )

Regards,
Lisa

-----Original Message-----
From: Jessica Fitzgerald-McKay [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, December 07, 2015 11:47 AM
To: Waltermire, David A. <[email-masked]<mailto:[email-masked]>>
Cc: Lisa Lorenzin <[email-masked]<mailto:[email-masked]>>; Leif Johansson <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [sacm] Consensus Call: Parking Architecture Draft

On Mon, Dec 7, 2015 at 11:20 AM, Waltermire, David A. <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>> > wrote:

        Dave

        > From: sacm [mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>> ] On Behalf Of Lisa Lorenzin
        > To: Leif Johansson <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>> >; [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
        > From: sacm [mailto:[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>> ] On Behalf Of Leif Johansson
        > To: [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
        > [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
        > [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>

        _______________________________________________
        sacm mailing list
        [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
        https://www.ietf.org/mailman/listinfo/sacm

_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm

---

From: Leif Johansson <[email-masked]>
Date: Tue, 8 Dec 2015 09:56:49 +0100

> +1 to Leif, David, Lisa, and Jess's comments.

I like it when I get a "+1" to support a counter-argument :-)

I was arguing for having some form of explicit agreement on what this
WG wants to do before doing solutions.

The honest thing is to say that there will be no architecture draft
and ask the AD to take it off the list of milestones. "Parking" a
requirements-type draft just means that it will be left for last
and maybe not done at all.

	Cheers Leif

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 8 Dec 2015 14:53:00 +0000

I am strongly in favor of finishing the work on requirements. I do not know how to do engineering work without stable requirements – this sounds to me like working on open loop.

Regards,

Dan

From: sacm [mailto:[email-masked]] On Behalf Of Jessica Fitzgerald-McKay
Sent: Monday, December 07, 2015 6:47 PM
To: Waltermire, David A.
Cc: Leif Johansson; [email-masked]; Lisa Lorenzin
Subject: Re: [sacm] Consensus Call: Parking Architecture Draft

On Mon, Dec 7, 2015 at 11:20 AM, Waltermire, David A. <[email-masked]<mailto:[email-masked]>> wrote:
+1 to Lisa's comments below.

Dave

> From: sacm [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Lisa Lorenzin
> To: Leif Johansson <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> From: sacm [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Leif Johansson
> To: [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sacm<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=BQMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=a3_RshSP98HZL_4_RscZyW7iGUk77Q9zPpI7HG7-wD8&s=nqFkIxabvfCtIhRyhB2iWURSuOT3zchrmMuZaTgsNCY&e=>
>
> https://www.ietf.org/mailman/listinfo/sacm<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=BQMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=a3_RshSP98HZL_4_RscZyW7iGUk77Q9zPpI7HG7-wD8&s=nqFkIxabvfCtIhRyhB2iWURSuOT3zchrmMuZaTgsNCY&e=>

_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=BQMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=a3_RshSP98HZL_4_RscZyW7iGUk77Q9zPpI7HG7-wD8&s=nqFkIxabvfCtIhRyhB2iWURSuOT3zchrmMuZaTgsNCY&e=>

---

From: Jessica Fitzgerald-McKay <[email-masked]>
Date: Tue, 8 Dec 2015 10:09:37 -0500

Is it typical in IETF that a requirements document is published prior to
the solutions draft? I was under the impression that requirements were
usually incorporated into the solution. Obviously, this group can choose to
do differently, but it is important to note that "parking" the document is
not the same as abandoning it. It is simply waiting to incorporate it with
a solution, and ensuring that we can develop a solution that meets our
requirements.

On Tue, Dec 8, 2015 at 9:53 AM, Romascanu, Dan (Dan) <[email-masked]>
wrote:

> I am strongly in favor of finishing the work on requirements. I do not
> know how to do engineering work without stable requirements – this sounds
> to me like working on open loop.
>
>
>
> Regards,
>
>
>
> Dan
>
>
>
>
>
>
>
> *From:* sacm [mailto:[email-masked]] *On Behalf Of *Jessica
> Fitzgerald-McKay
> *Sent:* Monday, December 07, 2015 6:47 PM
> *To:* Waltermire, David A.
> *Cc:* Leif Johansson; [email-masked]; Lisa Lorenzin
>
> *Subject:* Re: [sacm] Consensus Call: Parking Architecture Draft
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=BQMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=a3_RshSP98HZL_4_RscZyW7iGUk77Q9zPpI7HG7-wD8&s=nqFkIxabvfCtIhRyhB2iWURSuOT3zchrmMuZaTgsNCY&e=>
> >
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=BQMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=a3_RshSP98HZL_4_RscZyW7iGUk77Q9zPpI7HG7-wD8&s=nqFkIxabvfCtIhRyhB2iWURSuOT3zchrmMuZaTgsNCY&e=>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=BQMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=a3_RshSP98HZL_4_RscZyW7iGUk77Q9zPpI7HG7-wD8&s=nqFkIxabvfCtIhRyhB2iWURSuOT3zchrmMuZaTgsNCY&e=>
>
>
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 8 Dec 2015 15:16:27 +0000

Hi Jessica,

In the IETF mileage varies in the different areas and WGs. Some do not publish requirements documents at all, this is not a mandatory phase. Some other do. I personally do believe that stable requirements are a condition for successful engineering projects. I am not sure that I understand what ‘incorporated with a solution’ means, especially as the ‘solution’ here is made of different building blocks, while the requirements (IMO) should be a separate and unique reference.

Regards,

Dan

From: Jessica Fitzgerald-McKay [mailto:[email-masked]]
Sent: Tuesday, December 08, 2015 5:10 PM
To: Romascanu, Dan (Dan)
Cc: Waltermire, David A.; Leif Johansson; [email-masked]; Lisa Lorenzin
Subject: Re: [sacm] Consensus Call: Parking Architecture Draft

Is it typical in IETF that a requirements document is published prior to the solutions draft? I was under the impression that requirements were usually incorporated into the solution. Obviously, this group can choose to do differently, but it is important to note that "parking" the document is not the same as abandoning it. It is simply waiting to incorporate it with a solution, and ensuring that we can develop a solution that meets our requirements.

On Tue, Dec 8, 2015 at 9:53 AM, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:

Regards,

Dan

From: sacm [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Jessica Fitzgerald-McKay
Sent: Monday, December 07, 2015 6:47 PM
To: Waltermire, David A.
Cc: Leif Johansson; [email-masked]<mailto:[email-masked]>; Lisa Lorenzin

Dave

---

From: Lisa Lorenzin <[email-masked]>
Date: Tue, 8 Dec 2015 15:18:13 +0000

Hi Dan,

I agree that stable requirements are key - among other things, they will guide us in evaluating candidate protocols and data models!  The requirements draft is very well advanced and largely complete - we just need to address comments (primarily yours!) from the WGLC. At that point, rather than send it on, I like Jess's idea of parking it while we work on solutions - that way if the solutions make us realize we have new requirements that didn't occur to us, it need to update the existing requirements, we have that flexibility.

Regards,

Lisa

Lisa Lorenzin
Principal Solutions Architect, Pulse Secure
919-384-7275<tel:919-384-7275> | [email-masked]<mailto: [email-masked]>

Please pardon brevity - sent from my phone

------ Original message------

From: Romascanu, Dan (Dan)

Date: Tue, Dec 8, 2015 09:53

To: Jessica Fitzgerald-McKay;Waltermire, David A.;

Cc: Leif Johansson;[email-masked]<mailto:;[email-masked]>;Lisa Lorenzin;

Subject:RE: [sacm] Consensus Call: Parking Architecture Draft

Regards,

Dan

From: sacm [mailto:[email-masked]<mailto::[email-masked]>]On Behalf Of Jessica Fitzgerald-McKay
Sent: Monday, December 07, 2015 6:47 PM
To: Waltermire, David A.
Cc: Leif Johansson; [email-masked]<mailto:[email-masked]>; Lisa Lorenzin
Subject: Re: [sacm] Consensus Call: Parking Architecture Draft

Dave

> On 2015-11-15 16<tel:2015-11-15%2016>:55, Adam W. Montville wrote:
> > Hi All:
> >

---

From: Kathleen Moriarty <[email-masked]>
Date: Tue, 8 Dec 2015 10:26:24 -0500

On Tue, Dec 8, 2015 at 10:18 AM, Lisa Lorenzin
<[email-masked]> wrote:
> Hi Dan,
>
>
> I agree that stable requirements are key - among other things, they will
> guide us in evaluating candidate protocols and data models!  The
> requirements draft is very well advanced and largely complete - we just need
> to address comments (primarily yours!) from the WGLC. At that point, rather
> than send it on, I like Jess's idea of parking it while we work on solutions
> - that way if the solutions make us realize we have new requirements that
> didn't occur to us, it need to update the existing requirements, we have
> that flexibility.

There is nothing that stops the WG from deciding that additional
requirements are needed later if the requirements draft is published.
It would be more for consistency to hold it.  If the WG comes upon new
technology solutions that flip requirements, they can later agree to
the adoption.  It would be silly to be that rigid in my opinion, but
rather to use requirements as a guide.  They'll be informative not
normative, right?

Thanks,
Kathleen

> 919-384-7275 | [email-masked]
>
> Cc: Leif Johansson;[email-masked];Lisa Lorenzin;
>
> I am strongly in favor of finishing the work on requirements. I do not know
> how to do engineering work without stable requirements – this sounds to me
> like working on open loop.
>
>
>
> Regards,
>
>
>
> Dan
>
>
>
>
>
>
>
> From: sacm [mailto:[email-masked]]On Behalf Of Jessica
> Fitzgerald-McKay
> with them. As our high-level documents meet with the reality of solutions, I
> suspect we will need to do some editing. Parking them lets us reference them
> as needed and edit them as adjustments are necessary.
>
>
>
> On Mon, Dec 7, 2015 at 11:20 AM, Waltermire, David A.
> <[email-masked]> wrote:
>

-- 

Best regards,
Kathleen

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 8 Dec 2015 15:26:47 +0000

Hi Lisa,

If the WG reaches consensus at the end of the WGLC the work to push ahead is mainly on the chairs. I do not want to get stuck on process issues, however.  I would just observe that when evaluating the different components of the solution (protocols, IM, DMs) we need to work with stable and agreed requirements as criteria. If any of the solutions does not comply on one or several key requirements, the argument ‘we can update the requirement, we have that flexibility’ SHOULD NOT be used.

Regards,

Dan

From: sacm [mailto:[email-masked]] On Behalf Of Lisa Lorenzin
Sent: Tuesday, December 08, 2015 5:18 PM
To: Romascanu, Dan (Dan); Jessica Fitzgerald-McKay; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [sacm] Consensus Call: Parking Architecture Draft

Hi Dan,

Regards,

Lisa

Lisa Lorenzin

------ Original message------

Regards,

Dan

Dave

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 8 Dec 2015 11:21:16 -0800

+1 for Lief,

If the architecture draft is not right, then it can get republished once it
is seen just how wrong it is.  If there is not the energy to finish it now,
then the energy to finish it is going to be even less after the solutions
have been produced.

I don't care one way or the other about the requirements draft as it should
be adequately reflected in the solution drafts and does not need to be an
independent document.

> Sent: Tuesday, December 08, 2015 12:57 AM
> To: Ira McDonald <[email-masked]>; Lisa Lorenzin
> <[email-masked]>
> Cc: Jessica Fitzgerald-McKay <[email-masked]>; Waltermire, David A.
> <[email-masked]>; [email-masked]
> I was arguing for having some form of explicit agreement on what this WG
> wants to do before doing solutions.
> 
> The honest thing is to say that there will be no architecture draft and
ask the AD
> to take it off the list of milestones. "Parking" a requirements-type draft
just
> means that it will be left for last and maybe not done at all.
> 
> 	Cheers Leif
>

---

From: David Harrington <[email-masked]>
Date: Tue, 8 Dec 2015 22:10:39 -0500

It is typical in the ietf to document requirements to help focus wg discussion and differentiate requirements from wants and nice to haves. What is a requirement for one company or one segment of the industry maybe totally unnecessary in other segments of the industry. Before establishing standards it can be important to under the applicability of different aspects of the technology. You can see many requirements documents among published rfcs. 

David Harrington
[email-masked]
603-828-1401

> On Dec 8, 2015, at 10:09 AM, Jessica Fitzgerald-McKay <[email-masked]> wrote:
> 
>> On Tue, Dec 8, 2015 at 9:53 AM, Romascanu, Dan (Dan) <[email-masked]> wrote:
>> On Mon, Dec 7, 2015 at 11:20 AM, Waltermire, David A. <[email-masked]> wrote:
>>

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Wed, 9 Dec 2015 03:46:11 +0000

While I can understand why we may want to wait on doing a WGLC on the
architecture draft to ensure that we have covered all adopted protocol or
³solution² drafts, I think the requirements have to be well understood.
That is, in order to ensure we have agreement on the ³solution² they have
to be evaluated against a set of adopted/agreed-on requirements by the WG.

I am now confused; as I can see Leif¹s point on the group needing to agree
on what it is we want to doŠ. I¹m not sure how we are to propose solutions
if we only have high level use cases in RFC 7632 but no requirements (and
architecture) to drive the evaluation of proposalsŠ.

	Nancy

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 9 Dec 2015 10:54:28 +0000

+1 (especially in what requirements are concerned)

Regards,

Dan

> From: sacm [mailto:[email-masked]] On Behalf Of Nancy Cam-
> Winget (ncamwing)
> Sent: Wednesday, December 09, 2015 5:46 AM
> To: Leif Johansson; Ira McDonald; Lisa Lorenzin
> Cc: Jessica Fitzgerald-McKay; Waltermire, David A.; [email-masked]
> That is, in order to ensure we have agreement on the ³solution² they have to
> be evaluated against a set of adopted/agreed-on requirements by the WG.
> 
> I am now confused; as I can see Leif¹s point on the group needing to agree on
> what it is we want to doŠ. I¹m not sure how we are to propose solutions if we
> only have high level use cases in RFC 7632 but no requirements (and
> >ask the AD to take it off the list of milestones. "Parking" a
> >requirements-type draft just means that it will be left for last and
> >maybe not done at all.
> >
> >	Cheers Leif
> >
> >https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailm
> >an_listinfo_sacm&d=BQIF-
> g&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQz
> >vlsiLQfucBXRucPvdrphpBsFA&m=Rx_1-
> dZW0R6qu7hdnRRuEAd3MlhcuHCCKBls555CExo
> >&s=AOxVsc-T7pGNWIS0Fz9gcp_Z-inYuYSdCVzDsEsiPJ0&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_sacm&d=BQIF-
> g&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvd
> rphpBsFA&m=Rx_1-
> dZW0R6qu7hdnRRuEAd3MlhcuHCCKBls555CExo&s=AOxVsc-
> T7pGNWIS0Fz9gcp_Z-inYuYSdCVzDsEsiPJ0&e=

---

From: "Jim Bieda (jbieda)" <[email-masked]>
Date: Wed, 9 Dec 2015 16:36:43 +0000

+1. Without agreed-upon requirements, any solution can work.  Worse yet,
we could end up with multiple incompatible solutions for every use case
(and subset of use cases).  I’m don’t think that helps interoperability.

Furthermore, I believe the solutions should be proposed within the context
of an architecture.  Otherwise, each solution will have to make up the
terminology and interactions between “functional elements”.  Aren’t the
basic functional elements described in the architecture (producer,
collector, controller, repository, etc.)?  You can set the architecture
aside in the parking lot, but I believe you’ll just end up re-creating it
(or something very much like it) when you attempt to describe a solution.

I realize we’re trying to make progress, but I don’t see how we move
faster without leveraging the work already done on requirements and
architecture.  Are we going to use that work or not?  I think it would be
beneficial to use it and potentially modify it as we go into solution
space. Perhaps I’m confused on where this is heading?

Thanks,
Jim  

On 12/9/15, 2:54 AM, "sacm on behalf of Romascanu, Dan (Dan)"
<[email-masked] on behalf of [email-masked]> wrote:

Regards,

Dan

---

From: Dorothy Gellert <[email-masked]>
Date: Wed, 9 Dec 2015 10:07:57 -0800

+1.  Can’t call it engineering without stable requirements. 

> On Dec 8, 2015, at 6:53 AM, Romascanu, Dan (Dan) <[email-masked]> wrote:
> 
> On Mon, Dec 7, 2015 at 11:20 AM, Waltermire, David A. <[email-masked] <mailto:[email-masked]>> wrote:
> > From: sacm [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Lisa Lorenzin
> > To: Leif Johansson <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> > From: sacm [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Leif Johansson
> > https://www.ietf.org/mailman/listinfo/sacm <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=BQMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=a3_RshSP98HZL_4_RscZyW7iGUk77Q9zPpI7HG7-wD8&s=nqFkIxabvfCtIhRyhB2iWURSuOT3zchrmMuZaTgsNCY&e=>
> >
> > https://www.ietf.org/mailman/listinfo/sacm <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=BQMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=a3_RshSP98HZL_4_RscZyW7iGUk77Q9zPpI7HG7-wD8&s=nqFkIxabvfCtIhRyhB2iWURSuOT3zchrmMuZaTgsNCY&e=>
> 
> https://www.ietf.org/mailman/listinfo/sacm <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_sacm&d=BQMFaQ&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=a3_RshSP98HZL_4_RscZyW7iGUk77Q9zPpI7HG7-wD8&s=nqFkIxabvfCtIhRyhB2iWURSuOT3zchrmMuZaTgsNCY&e=>
>

---

From: Tony Rutkowski <[email-masked]>
Date: Wed, 9 Dec 2015 13:27:23 -0500

It is worth noting that Yet Another Software ID (YASID)
has entered on the scene.  One of the legacy SDOs has
begun advertising a "First-ever Application Registry"
http://www.prnewswire.com/news-releases/potential-of-iot-expanded-with-first-ever-application-registry-300189746.html
It is a completely bogus assertion.

An inquiring mind would ask how much it costs to
avail one's self of this first-ever service.  The answer is
>
> Thanks for your inquiry regarding oneM2M Application Identifier 
> (App-ID) Registry fees. The fee to register an official oneM2M 
> Application Identifier (App-ID) is $100 USD, but for a limited time we 
> are offering these registrations for FREE by utilizing the coupon code 
> ‘ICONECTIV’ during the order process.
>
> There is no cost to search the App-ID registry for existing App-IDs.
>
> Regards,
>
> oneM2M App-ID Registry Customer Service Center
Get them while they last. :-)

So the IETF's repository on app-ID schemes probably
needs updating.

https://www.ietf.org/mail-archive/web/mile/current/pdfJvN_FxflCS.pdf

--tony