Subject: Re: [sacm] IM Expression Consensus Call Redux (WAS: Re: Consensus Call: Choosing an IM Expression Syntax)

From: "Waltermire, David A." <[email-masked]>
Date: Mon, 4 Jan 2016 18:51:07 +0000

+1 for option 2.

-1 for option 4. I don't believe an ERD (or any other visual form) will be sufficient to document the IM. It can be provided as a value add, but some text documentation will be needed using one of the other options. I'd say the same for UML if it is purely used in a visually rendered form.

Thanks,
Dave

> -----Original Message-----
> From: sacm [mailto:[email-masked]] On Behalf Of Adam W.
> Montville
> Sent: Wednesday, December 30, 2015 4:47 PM
> To: [email-masked]
> Subject: [sacm] IM Expression Consensus Call Redux (WAS: Re: Consensus
> Call: Choosing an IM Expression Syntax)
> 
> Hi again.  After going through the multiple threads on this topic, it's not really
> clear which approach people would like to take.  This is in part because some
> people changed their preference between the two threads.
> 
> For the record, here's what I was able to count (I think):
> 
> Option 1: 3 (one person also voted for Option 3) Option 2: 1 (a first
> preference for one person) Option 3: 3 (one person also voted for Option 1)
> Option 4: 0 Option 5: 5 (one of which is an individual's second preference;
> another of which would switch from Option 3)
> 
> I've heard, privately, some strong arguments against using English.
> I've heard rather reasonable arguments in favor of it.
> 
> Given the confusion along the way, let's restart this consensus call based on
> the options as originally indicated (see message below). Let's leave it open
> until midnight (UTC) January 7.  We need to arrive at some conclusion very
> soon, so that we can start making tangible progress on expressing the IM.
> 
> Kind regards,
> 
> Adam
> 
> 
> On 12/02/2015 09:19 AM, Adam W. Montville wrote:
> > Hi.
> >
> > This message starts a two-week consensus call for selecting an
> > expression syntax for our Information Model.  Danny has already
> > started a thread on the subject [1].  There are five options in total:
> >
> > Option 1: RFC 7326 - Energy Management Framework [2]
> >
> > Option 2: Information Model for Large-Scale Measurement Platforms [3]
> >
> > Option 3: Unified Modeling Language [4]
> >
> > Option 4: Entity-relationship Diagram [5]
> >
> > Option 5: Plain English, as exemplified by RFC 6880 [6]
> >
> >
> > Please let us know your preference, if you have not already, no later
> > than 23:59 UTC on 2015-12-16.
> >
> > Kind regards,
> >
> > Adam
> >
> >
> >
> > [1]
> > https://mailarchive.ietf.org/arch/search/?email_list=sacm&gbt=1&index=
> > UGE7tF3SO-e3Bo1AkwVHVvtvu3s
> >
> > [2] https://datatracker.ietf.org/doc/rfc7326/
> >
> > [3]
> > https://datatracker.ietf.org/doc/draft-burbridge-lmap-information-mode
> > l/
> >
> > [4] http://www.uml-diagrams.org/
> >
> > [5] https://en.wikipedia.org/wiki/Entity%E2%80%93relationship_model
> >
> > [6] https://tools.ietf.org/html/rfc6880
> 
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm

---

From: Ira McDonald <[email-masked]>
Date: Mon, 4 Jan 2016 14:51:27 -0500

Hi,

I agree with Dave Waltermire:

+1 for Option 2
-1 for Option 4 or Option 5

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Winter  579 Park Place  Saline, MI  48176  734-944-0094
Summer  PO Box 221  Grand Marais, MI 49839  906-494-2434

On Mon, Jan 4, 2016 at 1:51 PM, Waltermire, David A. <
[email-masked]> wrote:

> +1 for option 2.
>
> -1 for option 4. I don't believe an ERD (or any other visual form) will be
> sufficient to document the IM. It can be provided as a value add, but some
> text documentation will be needed using one of the other options. I'd say
> the same for UML if it is purely used in a visually rendered form.
>
> Thanks,
> Dave
>