Subject: Re: [sacm] [draft-ietf-sacm-requirements] G-001: extensions and new protocols / standard and proprietary (#81)

From: Nancy <[email-masked]>
Date: Tue, 19 Jan 2016 15:31:53 -0800

Hi Dan,
The intent is to have SACM be extensible in 2 dimensions:
1. SACM should be able to adapt to future requirements whether it be to allow new standard transports, protocols or data models (or extending the information model).
2. SACM should allow for vendors to use their own extensions to the information model, protocols or data model (agreed that if they do, then they are not necessarily SACM compliant).

I can see not forcing a requirement for the 2nd one, though there are quite a few standards that allow for vendor extensibility; for example, "vendor specified" attributes.  Which is why I think we added the last clause (e.g. "proprietary").

Do you have a suggestion as to how to make that more clear?  Would breaking it into the two separate bullets per the above help?

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/81#issuecomment-173022735

---

From: llorenzin <[email-masked]>
Date: Mon, 25 Jan 2016 09:27:50 -0800

Consensus of 1/25 virtual interim call - change the SHOULD back to a MUST for supporting proprietary extensions.  Outside of the requirements document, SACM should encourage implementers to notify SACM of proprietary extensions - perhaps via something simple like an email to the SACM mailing list, perhaps via a more structured forum if demand arises.

---
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-requirements/issues/81#issuecomment-174594256