Subject: [sacm] New version 14 draft-ietf-sacm-requirements posted

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Sun, 18 Sep 2016 23:22:25 +0000

All,

We continued discussions both within the SACM thread and amongst those who were most vocal in discussions for DM-001 clarification and could not reach consensus.

I believe the main issue that needs further discussion as no consensus was reached is whether there is ONE SACM DM or several.
As DM-001 speaks only to the requirement of the DM element association vs whether there are 1 or more DMs , I have gone ahead
and updated wording to further clarify that mapping or relation of a DM element to an Information Model element.

…thanks to John Strassner for providing the base for the updated text.

The updates are now in –14: https://datatracker.ietf.org/doc/draft-ietf-sacm-requirements/

Regards, Nancy

---

From: Adam Montville <[email-masked]>
Date: Mon, 19 Sep 2016 08:03:57 -0500

Thanks for getting the draft updated.

I need to catch up on the entire thread, so I'm writing without full context.  

The original intent in this group was to have an IM to which we could map data model elements from existing data models or for which we could build new data models (i.e. where none exist).  So, one IM, many DMs.  Does there need to be "one DM to rule them all" here?  It doesn't seem like it.  Instead, it seems that what we want is a way to express a mapping of DM elements to IM elements.  We want to use some DMTF CIM specification in the context of a SACM ecosystem?  Great.  Show me the mapping of CIM data model elements to the SACM Information Model.

That said, is the present text for DM-001 good enough?  It seems reasonable to me.

   DM-001  Element Association: A SACM Information Model consists of a
    set of SACM Information Model elements.  A SACM Data Model MUST be
    derived from the SACM Information Model.  A SACM Data Model consists
    of a set of SACM Data Model elements.  In this derivation, a SACM
    Data Model element MAY map to one or more SACM Information Model
    elements.  In addition, a SACM Data Model MAY include additional
    Data Model elements that are not associated with any SACM
    Information Model elements.

> On Sep 18, 2016, at 6:22 PM, Nancy Cam-Winget (ncamwing) <[email-masked]> wrote:
> 
> All,
> 
> The updates are now in –14: https://datatracker.ietf.org/doc/draft-ietf-sacm-requirements/ <https://datatracker.ietf.org/doc/draft-ietf-sacm-requirements/>
> 
> Regards, Nancy
> 
> 
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Wed, 21 Sep 2016 07:00:31 +0000

Hi Adam,

Yes, the thread went on for a bit :-)  and the general issue that remained unresolved is that to the number of DMs to be standardized in SACM.
But again, the main requirements for the data model (whether it is 1 or many) in DM-001 is more to define the relation between the elements in the DM to that in the IM….

Nancy

From: Adam Montville <[email-masked]<mailto:[email-masked]>>
Date: Monday, September 19, 2016 at 6:03 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sacm] New version 14 draft-ietf-sacm-requirements posted

On Sep 18, 2016, at 6:22 PM, Nancy Cam-Winget (ncamwing) <[email-masked]<mailto:[email-masked]>> wrote:

All,

Regards, Nancy

_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm

---

From: Adam Montville <[email-masked]>
Date: Thu, 22 Sep 2016 12:02:03 -0500

> On Sep 21, 2016, at 2:00 AM, Nancy Cam-Winget (ncamwing) <[email-masked]> wrote:
> 
> Hi Adam,
> 

Yes, I agree.  Then, my question still stands: Is the text we have now good enough?  I believe it is.

> 
> Nancy
> 
> 
> From: Adam Montville <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>> On Sep 18, 2016, at 6:22 PM, Nancy Cam-Winget (ncamwing) <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> All,
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/sacm <https://www.ietf.org/mailman/listinfo/sacm>
>

---

From: "Haynes, Dan" <[email-masked]>
Date: Thu, 22 Sep 2016 19:17:00 +0000

This text would be good enough for me.

Thanks,

Danny

From: sacm [mailto:[email-masked]] On Behalf Of Adam Montville
Sent: Thursday, September 22, 2016 1:02 PM
To: Nancy Cam-Winget <[email-masked]>
Cc: [email-masked]
Subject: Re: [sacm] New version 14 draft-ietf-sacm-requirements posted

On Sep 21, 2016, at 2:00 AM, Nancy Cam-Winget (ncamwing) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Adam,

Nancy

All,

Regards, Nancy