Subject: [sacm] Consensus call on SW M&A Issue #7

From: Adam Montville <[email-masked]>
Date: Thu, 13 Oct 2016 16:46:07 -0500

This message begins a consensus call pertaining to SW M&A Issue #7 (see: https://github.com/sacmwg/software-identification/issues/7 <https://github.com/sacmwg/software-identification/issues/7>).

Though there are three types of software inventories SACM may be interested in, we believe we can (and should) initially focus only on inventories of installed software.

We believe we can handle inventories of running software and installation packages down the road, perhaps in one or more separate M&A drafts.

If you object to the SW M&A draft limiting its scope to installed software, please state so along with your reasoning.

If you do not object to the SW M&A draft limiting its scope to installed software, please state so (a simple +1 will suffice).

This consensus call will end at 23:59 UTC on October 21.

Kind regards,

Adam

---

From: "Waltermire, David A. (Fed)" <[email-masked]>
Date: Thu, 13 Oct 2016 21:55:28 +0000

+1. I am in favor of limiting the scope in this draft to installed software.

Thanks,
Dave

From: sacm [mailto:[email-masked]] On Behalf Of Adam Montville
Sent: Thursday, October 13, 2016 5:46 PM
To: <[email-masked]> <[email-masked]>
Subject: [sacm] Consensus call on SW M&A Issue #7

This message begins a consensus call pertaining to SW M&A Issue #7 (see: https://github.com/sacmwg/software-identification/issues/7).

Kind regards,

Adam

---

From: Jarrett Lu <[email-masked]>
Date: Thu, 13 Oct 2016 16:47:48 -0700

I give +1 to this because (1) don't want to slow down the progress of 
this draft, and (2) reporting installed software has value.

I really like to see support for running software soon. It's common to 
have installed software that are not running. I think running software 
is often more interesting than installed (but not running) ones. For 
example, if I have anti-virus software installed on my system but not 
running, I like to know that.

Thanks.

- Jarrett

On 10/13/16 02:46 PM, Adam Montville wrote:
> This message begins a consensus call pertaining to SW M&A Issue #7 
> (see: https://github.com/sacmwg/software-identification/issues/7).
>
> Though there are three types of software inventories SACM may be 
> interested in, we believe we can (and should) initially focus only on 
> inventories of installed software.
>
> We believe we can handle inventories of running software and 
> installation packages down the road, perhaps in one or more separate 
> M&A drafts.
>
> If you object to the SW M&A draft limiting its scope to installed 
> software, please state so along with your reasoning.
>
> If you do not object to the SW M&A draft limiting its scope to 
> installed software, please state so (a simple +1 will suffice).
>
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm

---

From: Jessica Fitzgerald-McKay <[email-masked]>
Date: Fri, 14 Oct 2016 08:46:51 -0400

+1. I agree that it would be useful to know what software is running, but
we don't need to tackle that question in this version of Software M&A.

On Thu, Oct 13, 2016 at 7:47 PM, Jarrett Lu <[email-masked]> wrote:

> I give +1 to this because (1) don't want to slow down the progress of this
> draft, and (2) reporting installed software has value.
>
> have installed software that are not running. I think running software is
> often more interesting than installed (but not running) ones. For example,
> if I have anti-virus software installed on my system but not running, I
> like to know that.
>
> Thanks.
>
> - Jarrett
>
>
>
> This message begins a consensus call pertaining to SW M&A Issue #7 (see:
> https://github.com/sacmwg/software-identification/issues/7).
>
> We believe we can handle inventories of running software and installation
> packages down the road, perhaps in one or more separate M&A drafts.
>
> If you do not object to the SW M&A draft limiting its scope to installed
> software, please state so (a simple +1 will suffice).
>
> sacm mailing [email-masked]://www.ietf.org/mailman/listinfo/sacm
>
>
>

---

From: Ira McDonald <[email-masked]>
Date: Fri, 14 Oct 2016 16:10:55 -0400

Hi,

+1

But I agree with Jarrett that running software (such as anti-virus) is
important and I suggest is a much higher priority than installation
packages (which seem kind of like noise to me...).

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Co-Chair - TCG Trusted Mobility Solutions WG
Chair - Linux Foundation Open Printing WG
Secretary - IEEE-ISTO Printer Working Group
Co-Chair - IEEE-ISTO PWG Internet Printing Protocol WG
IETF Designated Expert - IPP & Printer MIB
Blue Roof Music / High North Inc
http://sites.google.com/site/blueroofmusic
http://sites.google.com/site/highnorthinc
mailto: [email-masked]
Jan-April: 579 Park Place  Saline, MI  48176  734-944-0094
May-Dec: PO Box 221  Grand Marais, MI 49839  906-494-2434

---

From: John Strassner <[email-masked]>
Date: Fri, 14 Oct 2016 17:50:08 -0700

+1
I am also much more interested in what is currently running than what is
installed, just for the record.

best,
John

On Fri, Oct 14, 2016 at 1:10 PM, Ira McDonald <[email-masked]>
wrote:

>>> installation packages down the road, perhaps in one or more separate M&A
>>> drafts.
>>>

-- 
regards,
John

---

From: Adam Montville <[email-masked]>
Date: Wed, 26 Oct 2016 06:51:54 -0400

It seems we have good consensus to move forward on this issue, given that there have been no objections to scoping our present solution work to installed software.  We should note for the future that there were a couple of calls/suggestions to turn our attention next to running software.

Kind regards,

Adam

> On Oct 13, 2016, at 5:46 PM, Adam Montville <[email-masked]> wrote:
>