Subject: [sacm] SACM Information Model Status Update

From: "Haynes, Dan" <[email-masked]>
Date: Thu, 23 Mar 2017 19:37:30 +0000

Hi Everyone,

I just wanted to give a quick status update on the SACM Information Model since we will not be providing an update at IETF 98.

We published revision -09 on March 13, 2017. It addressed the following issues.

*        Added "derived", "authority", and "verified" to the collectionTaskType IE (https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/18).

*        Updated IE examples that use content-type to use statement-type (https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/56).

*        Added "networkZoneLocation", "layer2NetworkLocation", and "layer3NetworkLocation" IEs (https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/9).

*        Created a softwareClass attribute IE and added it to the softwareInstance subject IE.  Also, removed the os* attribute IEs (https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/10).

There are still some open issues associated with this draft, but, the majority do not represent roadblocks and can be added at any time (e.g. new IE and datatype requests, etc.). With that said, there is the open discussion around the scope of the IM which has been a roadblock :) and we are trying to work through that on the Vulnerability Assessment Scenario front.

Please let me know if you have any questions or comments on these changes.

Thanks,

Danny

---

From: Adam Montville <[email-masked]>
Date: Fri, 24 Mar 2017 11:51:11 +0000

Thank you for the update, Danny.  Would it be accurate to say, then, that
at this point there are not contentious issues with the information model?

Tangent: Do you believe the information model, as it stands, does well
enough for endpoint identification?

Kind regards,

Adam

On Thu, Mar 23, 2017 at 2:37 PM Haynes, Dan <[email-masked]> wrote:

> Hi Everyone,
>
>
> I just wanted to give a quick status update on the SACM Information Model
> since we will not be providing an update at IETF 98.
>
>
>
> ·        Added "derived", "authority", and "verified" to the collectionTaskType IE (https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/18).
>
> ·        Updated IE examples that use content-type to use statement-type (https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/56).
>
> ·        Added "networkZoneLocation", "layer2NetworkLocation", and "layer3NetworkLocation" IEs (https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/9).
>
> ·        Created a softwareClass attribute IE and added it to the softwareInstance subject IE.  Also, removed the os* attribute IEs (https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/10).
>
>
>
> _______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm
>