Subject: [sacm] [sacmwg/draft-ietf-sacm-information-model] Section 6: Which endpoint to identity relation is correct? (#79)

From: adammontville <[email-masked]>
Date: Tue, 20 Jun 2017 09:07:37 -0700

In section 6 there is figure 15, which looks something like this: 
```
           +---------+*______in>_______*+-----+
           |Hardware |                  |!   !|
           |Component|   +---------+    |!   !|
           +---------+   |Software |in> |!   !|
                         |Component|____|!   !|
                         +---------+*  *|!   !|
                             1|         |!   !|
                             *|         |     |       +----------+
                         +---------+    |End- |*_____*| Identity |
                         |Software |in> |point| acts  +----------+
                         |Instance |____|     | for>
                         +---------+*  1|!   !|
                                        |!   !|
                                        |!   !|
                                        |!   !|
                                        |!   !|____
                                        |!   !|0..1|
                                        +-----+    |
                                           |*      |
                                           |_______|
                                              in>

```
Of particular interest is the many-to-many relationship "acts for" between Endpoint and Identity; the direction of the "acts for" relation is from Endpoint to Identity, such that an Endpoint "acts for" an Identity. 

However, in the paragraph above figure 15 there is a sentence reading, "...zero or more identities that act on behalf of the endpoint..." By this reading, then, the Identity would "act for" the Endpoint, which is the opposite of what the diagram seems to say.

Which is the intended perspective?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/79

---

From: cliffordk <[email-masked]>
Date: Tue, 20 Jun 2017 11:32:59 -0700

Adam,
The ascii art looks like mine – I recognize the brush strokes.

My view is this: my computer acts for me. I provide my credentials. The computer uses the credentials to access resources for me.

An infected computer may act against me instead, but never mind that!

I say that an endpoint acts for an identity. The diagram is right, and the accompanying text needs correcting.

Works?

Best,
                                                Cliff

From: adammontville <[email-masked]>
Reply-To: sacmwg/draft-ietf-sacm-information-model <[email-masked]>
Date: Tuesday, June 20, 2017 at 12:07 PM
To: sacmwg/draft-ietf-sacm-information-model <[email-masked]>
Cc: Subscribed <[email-masked]>
Subject: [sacmwg/draft-ietf-sacm-information-model] Section 6: Which endpoint to identity relation is correct? (#79)

           |Hardware |                  |!   !|

                         |Component|____|!   !|

                         +---------+*  *|!   !|

                             1|         |!   !|

                             *|         |     |       +----------+

                         |Instance |____|     | for>

                         +---------+*  1|!   !|

                                        |!   !|

                                        |!   !|

                                        |!   !|

                                        |!   !|____

                                        |!   !|0..1|

                                        +-----+    |

                                           |*      |

                                           |_______|

                                              in>

—
You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub<https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/79>, or mute the thread<https://github.com/notifications/unsubscribe-auth/AMcywnDMNlj5oGXOKZ_Bqz12W9I3B4fiks5sF-5JgaJpZM4N_0E1>.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-information-model/issues/79#issuecomment-309848279