Subject: [sacm] [sacmwg/draft-ietf-sacm-terminology] Definition of "Attribute" (#39)

From: adammontville <[email-masked]>
Date: Mon, 17 Jul 2017 04:18:13 -0700

The definition of _attribute_ presently relies on RFC5209, which defines an attribute as a "data element including any requisite meta-data describing an observed, expected, or the operational status of an endpoint feature (e.g., anti-virus software is currently in use)." We augment this definition by stating that an attribute is atomic and equivalent to (synonymous with??) attribute-value-pairs. We further state that an attribute is a component of a subject.

This feels overly complicated for what we need. There are subjects, and these subjects have attributes. These attributes have values. The AV description provided does not seem like a single attribute, but a collection of attributes for different subjects. Endpoint has_installed anti-virus software. Anti-virus software has_execution_state running.

Is our definition of attribute granular enough?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/39

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 17 Jul 2017 05:27:09 -0700

Referencing the NEA definitions seems approriate as seems to be the biggest component used in SACM at the moment.
The SACM specific definition  is composed of two statements:

* Attributes are "atomic" information elements and an equivalent to attribute-value-pairs.
* Attributes can be components of Subjects.

What improvements would you propose?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/39#issuecomment-315741426

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 17 Jul 2017 07:21:41 -0700

Merged https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/43 into this issue.

Please make "Endpoint Characteristic" singular.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/39#issuecomment-315770209

---

From: adammontville <[email-masked]>
Date: Mon, 31 Jul 2017 20:12:03 +0000 (UTC)

I suppose I just don't like the NEA definition, either because it conflates entities of reality into one term or because I'm discomforted by viewing an attribute as a set of information elements (which is what the NEA definition permits).

I'm thinking of attribute like, for example, minimum password length. There is a configuration item (an attribute) that inheres in many software applications called minimum password length. Its purpose is to specify the minimum length of users' passwords, and may take on a range of values depending on the policy and the technology. The range of values assignable to minimum password length is not the attribute itself, nor is the actual value presently assigned to minimum password length. 

Another way to look at it is that the terminology is saying "attribute" is the same as "attribute-value pair". An attribute is an attribute-value pair doesn't make sense to me. An attribute is part of an attribute-value pair, yes, but not an attribute-value pair in its own right.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/39#issuecomment-319182535

---

From: adammontville <[email-masked]>
Date: Mon, 31 Jul 2017 20:17:23 +0000 (UTC)

After reading Henk's comment on #42, I see why attribute-value pair was talked about as being synonymous with "attribute".  With minimum password length the value of 14 existing on an endpoint in a well-defined/expected location would be the instance of that attribute for that endpoint. ??

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/39#issuecomment-319183953