Subject: [sacm] [sacmwg/draft-ietf-sacm-terminology] "Endpoint Attribute" should probably not use "Information Element" in its definition. (#42)

From: adammontville <[email-masked]>
Date: Mon, 17 Jul 2017 12:58:54 +0000 (UTC)

At present the definition of _Endpoint Attribute_ begins with: "In the context of SACM, endpoint attributes are information elements..." _Information Element_ is defined as "a representation of information about...objects of interest", and it is pointed out that _Information Elements_ are part of our Information Model (building blocks, in fact). Does this, to anyone else, seem as though we are stating the "Endpoint Attribute" is an "Information Element"?

Concretely, the endpoint attribute "password length" is not actually on the endpoint, but is an information element in our information model with value 14. 

Is there  a way to define _Endpoint Attribute_ without relying on how we intend to model it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/42

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 17 Jul 2017 13:28:42 +0000 (UTC)

the declarative guidance on password length is indeed not an password attribute. The actual length of a password (which hopefully cannot be inferred for security reasons) would be an endpoint attribute.

Not every Information Element is an Endpoint Attribute.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/42#issuecomment-315755423

---

From: adammontville <[email-masked]>
Date: Mon, 31 Jul 2017 20:15:19 +0000 (UTC)

Aha! Ok, now things are starting to shape differently in my mind. Thank you.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/42#issuecomment-319183391