Subject: [sacm] [sacmwg/draft-ietf-sacm-terminology] Should we define "Endpoint Profile" or "Profile"? (#45)

From: adammontville <[email-masked]>
Date: Mon, 17 Jul 2017 13:11:01 +0000 (UTC)

_Endpoint Characterization_ mentions a "profile" of endpoint attributes, and _Endpoint Classification_ states that an "endpoint profile" is a form of declarative guidance used to define a class of endpoints. Do we need to explicitly define either "profile" or "endpoint profile"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/45

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 17 Jul 2017 14:06:54 +0000 (UTC)

That is worthwhile, I think.

"Endpoint Profile" is very useful - but we have to point out that it might refer to more than one target endpoints and more than one "Endpoint Profiles" might point to a single target endpoint... depending on the information that can be acquired to compose the "Endpoint Profile". Without a well-known "trusted" (RFC4949) label, there can be this ambiguity in expressiveness.

As a reference, "Identity"  from RFC4949 allows for this ambiguity.

RFC4949 references the CC protection profile. To be more aligned with CC we could pull in some reference of "security target" and therefore know what the declarative guidance side is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/45#issuecomment-315765520