Subject: [sacm] [sacmwg/draft-ietf-sacm-terminology] Revisit "Endpoint Label" (#46)

From: adammontville <[email-masked]>
Date: Mon, 17 Jul 2017 06:23:58 -0700

The term _Endpoint Label_ indicates that these are for endpoints, but then describes them as being applied to SACM components as well. I do not believe that a SACM Component is an endpoint, is it? Also, the "endpoint label" seems like an authoritative (in a SACM Domain) identifier. True? If so, then we should state that perhaps more clearly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/46

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 17 Jul 2017 14:16:55 +0000 (UTC)

A SACM component is not a "target endpoint". Both SACM components and target endpoints are typically endpoints (NEA: endpoint, RFC4949: information system or system entity, respectively).

A label is intended to refer to an endpoint regardless of its "role" or being a target endpoint. SACM component label and target endpoint label would be taxonomic specializations.

In any case, we should state that more clearly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/46#issuecomment-315766465

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 17 Jul 2017 14:18:15 +0000 (UTC)

Addendum: *by default*, a SACM component is not a target endpoint, because it is an excluded endpoint. You can deviate from that default in a SACM domain via corresponding imperative guidance. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/46#issuecomment-315767340

---

From: adammontville <[email-masked]>
Date: Mon, 17 Jul 2017 07:18:54 -0700

Henk, a "target endpoint" is an endpoint. How is an "excluded endpoint" not an endpoint?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/46#issuecomment-315769426

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 17 Jul 2017 14:49:14 +0000 (UTC)

Both excluded endpoints and target endpoints are endpoints, of course....

It either is included in continuous monitoring, or not.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-terminology/issues/46#issuecomment-315771011