Subject: [sacm] [IANA #1048649] Last Call: <draft-ietf-sacm-nea-swima-patnc-01.txt> (Software Inventory Message and Attributes (SWIMA) for PA-TNC) to Proposed Standard

From: "Sabrina Tanamal via RT" <[email-masked]>
Date: Wed, 21 Feb 2018 00:10:48 +0000

(BEGIN IANA COMMENTS)

IESG/Authors/WG Chairs:

The IANA Services Operator has completed its review of draft-ietf-sacm-nea-swima-patnc-01. If any part of this review is inaccurate, please let us know. 

The IANA Services Operator understands that, upon approval of this document, there are three actions which we must complete.

First, in the PA Subtypes registry on the Posture Broker (PB) Protocol Compatible with Trusted Network Connect (TNC) Parameters regsitry page located at:

https://www.iana.org/assignments/pb-tnc-parameters/

the following registration is to be added:

PEN: 0
Integer: 9
Name: SWIMA Attributes
Reference: [ RFC-to-be ]

As this document requests registrations in a Specification Required (see RFC 8126) registry, we will initiate the required Expert Review via a separate request. Expert review will need to be completed before your document can be approved for publication as an RFC.

Second, in the PA-TNC Attribute Types registry on the Posture Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC) Parameters registry page located at:

https://www.iana.org/assignments/pa-tnc-parameters/

the following registrations will be added to the registry:

+-----+---------+-------------------+-------------------------------+
| PEN | Integer | Name | Defining Specification |
+-----+---------+-------------------+-------------------------------+
| 0 | 17 | SWIMA Request | [ RFC-to-be ] |
| | | | |
| 0 | 18 | Software | [ RFC-to-be ] |
| | | Identifier | |
| | | Inventory | |
| | | | |
| 0 | 19 | Software | [ RFC-to-be ] |
| | | Identifier Events | |
| | | | |
| 0 | 20 | Software | [ RFC-to-be ] |
| | | Inventory | |
| | | | |
| 0 | 21 | Software Events | [ RFC-to-be ] |
| | | | |
| 0 | 22 | Subscription | [ RFC-to-be ] |
| | | Status Request | |
| | | | |
| 0 | 23 | Subscription | [ RFC-to-be ] |
| | | Status Response | |
| | | | |
| 0 | 24 | Source Metadata | [ RFC-to-be ] |
| | | Request | |
| | | | |
| 0 | 25 | Source Metadata | [ RFC-to-be ] |
| | | Response | |
| | | | |
| 0 | 26 - 31 | Reserved for | [ RFC-to-be ] |
| | | future use | |
+-----+---------+-------------------+-------------------------------+

IANA Question --> are Integer values 13 - 16 defined in another document, or is there a reason these values are not used?

As this also requests registrations in a Specification Required (see RFC 8126) registry, we will initiate the required Expert Review via a separate request. Expert review will need to be completed before your document can be approved for publication as an RFC.

Third, in the PA-TNC Error Codes registry on the Posture Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC) Parameters registry page located at:

https://www.iana.org/assignments/pa-tnc-parameters/

the following registrations will be added to the registry:

+-----+---------+--------------------------------------+---------------+
| PEN | Integer | Name | Reference |
+-----+---------+--------------------------------------+---------------+
| 0 | 32 | SWIMA_ERROR | [ RFC-to-be ] |
| 0 | 33 | SWIMA_SUBSCRIPTION_DENIED_ERROR | [ RFC-to-be ] |
| 0 | 34 | SWIMA_RESPONSE_TOO_LARGE_ERROR | [ RFC-to-be ] |
| 0 | 35 | SWIMA_SUBSCRIPTION_FULFILLMENT_ERROR | [ RFC-to-be ] |
| 0 | 36 | SWIMA_SUBSCRIPTION_ID_REUSE_ERROR | [ RFC-to-be ] |
| 0 | 37-47 | Reserved for future use | [ RFC-to-be ] |
+-----+---------+--------------------------------------+---------------+

IANA Question --> are Integer values 4 - 31 defined in another document, or is there a reason these values are not used?

As this also requests registrations in a Specification Required (see RFC 8126) registry, we will initiate the required Expert Review via a separate request. Expert review will need to be completed before your document can be approved for publication as an RFC.

Fourth, a new registry is to be created called the Software Data Models registry.

IANA Question --> Where should this new registry be located? Should it be added to an existing registry page? If not, does it belong in an existing category at http://www.iana.org/protocols? Is it to be on the Posture Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC) Parameters registry page located at:

https://www.iana.org/assignments/pa-tnc-parameters/ ?

The new registry is to be managed via Specification Required as defined in RFC 8126.

There are initial registrations in the new registry as follows:

+-----+---------+----------------------------+----------------------+
| PEN | Integer | Name | Reference |
+-----+---------+----------------------------+----------------------+
| 0 | 1 | ISO 2015 SWID Tags using | [ RFC-to-be ] |
| | | XML | |
| 0 | 2 | ISO 2009 SWID Tags using | [ RFC-to-be ] |
| | | XML | |
| 0 | 192-255 | Reserved for local | N/A |
| | | enterprise use | |
+-----+---------+----------------------------+----------------------+

IANA Question --> Is PEN 0, Integer Value 0 reserved or unassigned?

IANA Question --> Are PEN 0, Integer Values 3-191 unassigned?

The IANA Services Operator understands that these are the only actions required to be completed upon approval of this document.

Note:  The actions requested in this document will not be completed until the document has been approved for publication as an RFC. This message is only to confirm the list of actions that will be performed. 

Thank you,

Sabrina Tanamal
Senior IANA Services Specialist

(END IANA COMMENTS)

---

From: "Schmidt, Charles M." <[email-masked]>
Date: Thu, 22 Feb 2018 18:54:43 +0000

Hello,

Thank you for your review. Regarding your questions:

> Second, in the PA-TNC Attribute Types registry on the Posture Attribute (PA)
> Protocol Compatible with Trusted Network Connect (TNC) Parameters
> registry page located at:
> 
> IANA Question --> are Integer values 13 - 16 defined in another document, or
> is there a reason these values are not used?

No. This is a holdover from the Trusted Computing Group document from which SWIMA was derived, but the use of an IANA table makes the saving of values unnecessary. I'll adjust the specification to continue from 13.

 > Third, in the PA-TNC Error Codes registry on the Posture Attribute (PA)
> Protocol Compatible with Trusted Network Connect (TNC) Parameters
> registry page located at:
> 
> IANA Question --> are Integer values 4 - 31 defined in another document, or
> is there a reason these values are not used?

No. Same issue as above. I will adjust to continue from 4.

> IANA Question --> Where should this new registry be located? Should it be
> added to an existing registry page? If not, does it belong in an existing
> category at http://www.iana.org/protocols? Is it to be on the Posture
> Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC)
> Parameters registry page located at:
> 

This should be a new registry on the Posture Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC) Parameters registry page.

> IANA Question --> Is PEN 0, Integer Value 0 reserved or unassigned?

Unassigned. If it would be more in keeping with convention I can shift values down by one.

> IANA Question --> Are PEN 0, Integer Values 3-191 unassigned?

Unassigned and available for future assignment.

Thanks a bunch,
Charles

> -----Original Message-----
> From: Sabrina Tanamal via RT [mailto:[email-masked]]
> Sent: Tuesday, February 20, 2018 6:11 PM
> Cc: [email-masked]; [email-masked]; Schmidt, Charles M.
> <[email-masked]>; Haynes Jr., Dan <[email-masked]>; Coffin,
> Chris <[email-masked]>; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: [IANA #1048649] Last Call: <draft-ietf-sacm-nea-swima-patnc-
> 01.txt> (Software Inventory Message and Attributes (SWIMA) for PA-TNC) to
> Proposed Standard
> 
> (BEGIN IANA COMMENTS)
> 
> IESG/Authors/WG Chairs:
> 
> The IANA Services Operator has completed its review of draft-ietf-sacm-nea-
> swima-patnc-01. If any part of this review is inaccurate, please let us know.
> 
> The IANA Services Operator understands that, upon approval of this
> document, there are three actions which we must complete.
> 
> First, in the PA Subtypes registry on the Posture Broker (PB) Protocol
> Compatible with Trusted Network Connect (TNC) Parameters regsitry page
> located at:
> 
> As this document requests registrations in a Specification Required (see RFC
> 8126) registry, we will initiate the required Expert Review via a separate
> request. Expert review will need to be completed before your document can
> be approved for publication as an RFC.
> 
> Second, in the PA-TNC Attribute Types registry on the Posture Attribute (PA)
> Protocol Compatible with Trusted Network Connect (TNC) Parameters
> registry page located at:
> 
> IANA Question --> are Integer values 13 - 16 defined in another document, or
> is there a reason these values are not used?
> 
> As this also requests registrations in a Specification Required (see RFC 8126)
> registry, we will initiate the required Expert Review via a separate request.
> Expert review will need to be completed before your document can be
> approved for publication as an RFC.
> 
> Third, in the PA-TNC Error Codes registry on the Posture Attribute (PA)
> Protocol Compatible with Trusted Network Connect (TNC) Parameters
> registry page located at:
> 
> IANA Question --> are Integer values 4 - 31 defined in another document, or
> is there a reason these values are not used?
> 
> As this also requests registrations in a Specification Required (see RFC 8126)
> registry, we will initiate the required Expert Review via a separate request.
> Expert review will need to be completed before your document can be
> approved for publication as an RFC.
> 
> IANA Question --> Where should this new registry be located? Should it be
> added to an existing registry page? If not, does it belong in an existing
> category at http://www.iana.org/protocols? Is it to be on the Posture
> Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC)
> Parameters registry page located at:
> 
> The IANA Services Operator understands that these are the only actions
> required to be completed upon approval of this document.
> 
> Note:  The actions requested in this document will not be completed until
> the document has been approved for publication as an RFC. This message is
> only to confirm the list of actions that will be performed.
> 
> 
> Thank you,
> 
> Sabrina Tanamal

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Thu, 22 Feb 2018 19:06:55 +0000

Hi Charles,

> Unassigned. If it would be more in keeping with convention I can shift

Not a problem for us either way. We just needed to know whether it's available for assignment in the future ("Unassigned") or not ("Reserved").

thanks,
Amanda

On Thu Feb 22 18:55:07 2018, [email-masked] wrote:
> No. This is a holdover from the Trusted Computing Group document from
> which SWIMA was derived, but the use of an IANA table makes the saving
> of values unnecessary. I'll adjust the specification to continue from
> 13.
> 
> > Fourth, a new registry is to be created called the Software Data
> > Models
> > registry.
> >
> This should be a new registry on the Posture Attribute (PA) Protocol
> Compatible with Trusted Network Connect (TNC) Parameters registry
> page.
> 
> > Fourth, a new registry is to be created called the Software Data
> > Models
> > registry.
> >
> > The new registry is to be managed via Specification Required as
> > defined in
> > RFC 8126.
> >

---

From: "Schmidt, Charles M." <[email-masked]>
Date: Thu, 22 Feb 2018 19:11:03 +0000

Hi Amanda,

Thanks for the fast response. After scanning through some of the other registries, I think it makes sense for me to shift so the list is 0-indexed like most others. I'll include that change in the next release.

I believe this will address all items you raised (other than the expert review).

Thanks a bunch,
Charles

> From: Amanda Baber via RT [mailto:[email-masked]]
> Sent: Thursday, February 22, 2018 1:07 PM
> Cc: Schmidt, Charles M. <[email-masked]>; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: [IANA #1050998] FW: Last Call: <draft-ietf-sacm-nea-swima-patnc-
> Not a problem for us either way. We just needed to know whether it's
> available for assignment in the future ("Unassigned") or not ("Reserved").
> 
> thanks,
> Amanda
>

---

From: "Schmidt, Charles M." <[email-masked]>
Date: Thu, 22 Feb 2018 02:41:48 +0000

Hello,

Thanks a bunch,
Charles