Subject: Re: [sacm] EXTENDED (Re: WGLC for draft-ietf-sacm-rolie-softwaredescriptor)

From: "Banghart, Stephen A. (Fed)" <[email-masked]>
Date: Mon, 1 Jul 2019 14:58:04 +0000

Bill,

Thanks for the review!

In sections 6.1.2 and 6.2.1, there is mention of the ISO SWID spec.  Should those 2 mentions include the [SWID] reference link?  It may just be that the first mention/reference includes the link (which happens previously in the draft), so if it's not the norm to include the reference elsewhere, that's fine.  Just my inexperience, so I thought I'd ask.

I think it’s pretty much flexible on whether or not to include the SWID references more than once, but I typically only include the link on the first use.

6.2.2: In the 1st bullet of the "A "COSWID Tag Entry" MUST conform to the following requirements" section, the "type" attribute is required to be "application/coswid+cbor".  The CoSWID draft creates the media type of "application/swid+cbor" (Here<https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-sacm-coswid-11%23section-5.3&data=02%7C01%7Cstephen.banghart%40nist.gov%7C9b6337b287ab499f0fe108d6fd69fa01%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C1%7C636975028952652474&sdata=YWKWHTqWCnvNtuYuKH9hmby7ZfnS6ZvPkpQNe6sTGLU%3D&reserved=0>).  Should those be the same?

That absolutely should be the same, thanks for the catch.

Last, are the "rolie:property" values for CoSWID Tag Entries the "translated" values?  i.e. the decoded value at integer 0, 1, and 12?  I think the answer is "yes", but wanted the clarification.

Yes, it should be the decoded value stored at that integer key. I can add some language to make that more clear.

Thanks,
Stephen

From: sacm <[email-masked]> On Behalf Of Bill Munyan
Sent: Sunday, June 30, 2019 10:48 AM
To: <[email-masked]> <[email-masked]>
Cc: Karen O'donoghue <[email-masked]>
Subject: Re: [sacm] EXTENDED (Re: WGLC for draft-ietf-sacm-rolie-softwaredescriptor)

Hello all,
I've read the draft and I have just a couple of nits/questions:

In sections 6.1.2 and 6.2.1, there is mention of the ISO SWID spec.  Should those 2 mentions include the [SWID] reference link?  It may just be that the first mention/reference includes the link (which happens previously in the draft), so if it's not the norm to include the reference elsewhere, that's fine.  Just my inexperience, so I thought I'd ask.

6.2.2: In the 1st bullet of the "A "COSWID Tag Entry" MUST conform to the following requirements" section, the "type" attribute is required to be "application/coswid+cbor".  The CoSWID draft creates the media type of "application/swid+cbor" (Here<https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-sacm-coswid-11%23section-5.3&data=02%7C01%7Cstephen.banghart%40nist.gov%7C9b6337b287ab499f0fe108d6fd69fa01%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C1%7C636975028952652474&sdata=YWKWHTqWCnvNtuYuKH9hmby7ZfnS6ZvPkpQNe6sTGLU%3D&reserved=0>).  Should those be the same?

Last, are the "rolie:property" values for CoSWID Tag Entries the "translated" values?  i.e. the decoded value at integer 0, 1, and 12?  I think the answer is "yes", but wanted the clarification.

Cheers,
-Bill M.

On Thu, Jun 27, 2019 at 5:18 PM Jessica Fitzgerald-McKay <[email-masked]<mailto:[email-masked]>> wrote:
I have reviewed the draft. It is ready for publication.

Thanks,
Jess

On Thu, Jun 27, 2019 at 4:29 PM Karen O'Donoghue <[email-masked]<mailto:[email-masked]>> wrote:
Folks,

As discussed during our virtual interim on Tuesday, we are extending this working group last call in order to get a better response. Please reply to this email thread with an indication that you have read the document, any comments you may have, and your assessment of whether or not it is ready to proceed to publication.

DEADLINE: Please reply by Friday 5 July 2019.

Karen

On Jun 4, 2019, at 10:19 AM, Karen O'Donoghue <[email-masked]<mailto:[email-masked]>> wrote:

Folks,

This begins a two week working group last call for:
Definition of the ROLIE Software Descriptor Extension
https://datatracker.ietf.org/doc/draft-ietf-sacm-rolie-softwaredescriptor/<https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-sacm-rolie-softwaredescriptor%2F&data=02%7C01%7Cstephen.banghart%40nist.gov%7C9b6337b287ab499f0fe108d6fd69fa01%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C1%7C636975028952662482&sdata=yPjjIa8K90jtF25r%2BronNUEBWJ7lct4PvkDRtC%2BlVLY%3D&reserved=0>

Please review this document and send comments (including suitability to publish) to the mailing list.

This WGLC will close on 19 June 2019.

Thank you!
Karen and Chris

_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm<https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsacm&data=02%7C01%7Cstephen.banghart%40nist.gov%7C9b6337b287ab499f0fe108d6fd69fa01%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C1%7C636975028952662482&sdata=aPyW2lBdfbPysD61bmciNgITNCSYEQjGMWRz6DJCxP8%3D&reserved=0>
_______________________________________________
sacm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sacm<https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsacm&data=02%7C01%7Cstephen.banghart%40nist.gov%7C9b6337b287ab499f0fe108d6fd69fa01%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C1%7C636975028952672491&sdata=p2eLCf%2FZ9zhLM3KkDfj6djp4nzl0AnbNa7TFftrmTFQ%3D&reserved=0>

---

From: Adam Montville <[email-masked]>
Date: Fri, 12 Jul 2019 10:27:28 -0500

Hello all:

Once these small issues are addressed, I am in favor of publication.

Kind regards,

Adam

> On Jul 1, 2019, at 9:58 AM, Banghart, Stephen A. (Fed) <stephen.banghart=[email-masked]> wrote:
> 
> Bill,
>  
> Thanks for the review!
>  
> 6.2.2: In the 1st bullet of the "A "COSWID Tag Entry" MUST conform to the following requirements" section, the "type" attribute is required to be "application/coswid+cbor".  The CoSWID draft creates the media type of "application/swid+cbor" (Here <https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-sacm-coswid-11%23section-5.3&data=02%7C01%7Cstephen.banghart%40nist.gov%7C9b6337b287ab499f0fe108d6fd69fa01%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C1%7C636975028952652474&sdata=YWKWHTqWCnvNtuYuKH9hmby7ZfnS6ZvPkpQNe6sTGLU%3D&reserved=0>).  Should those be the same?
>  
> 6.2.2: In the 1st bullet of the "A "COSWID Tag Entry" MUST conform to the following requirements" section, the "type" attribute is required to be "application/coswid+cbor".  The CoSWID draft creates the media type of "application/swid+cbor" (Here <https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-ietf-sacm-coswid-11%23section-5.3&data=02%7C01%7Cstephen.banghart%40nist.gov%7C9b6337b287ab499f0fe108d6fd69fa01%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C1%7C636975028952652474&sdata=YWKWHTqWCnvNtuYuKH9hmby7ZfnS6ZvPkpQNe6sTGLU%3D&reserved=0>).  Should those be the same?
> 
> On Thu, Jun 27, 2019 at 5:18 PM Jessica Fitzgerald-McKay <[email-masked] <mailto:[email-masked]>> wrote:
> On Thu, Jun 27, 2019 at 4:29 PM Karen O'Donoghue <[email-masked] <mailto:[email-masked]>> wrote:
> Folks, 
>  
> On Jun 4, 2019, at 10:19 AM, Karen O'Donoghue <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Folks, 
>  
> https://datatracker.ietf.org/doc/draft-ietf-sacm-rolie-softwaredescriptor/ <https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-sacm-rolie-softwaredescriptor%2F&data=02%7C01%7Cstephen.banghart%40nist.gov%7C9b6337b287ab499f0fe108d6fd69fa01%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C1%7C636975028952662482&sdata=yPjjIa8K90jtF25r%2BronNUEBWJ7lct4PvkDRtC%2BlVLY%3D&reserved=0>
>  
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sacm <https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsacm&data=02%7C01%7Cstephen.banghart%40nist.gov%7C9b6337b287ab499f0fe108d6fd69fa01%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C1%7C636975028952662482&sdata=aPyW2lBdfbPysD61bmciNgITNCSYEQjGMWRz6DJCxP8%3D&reserved=0>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/sacm <https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsacm&data=02%7C01%7Cstephen.banghart%40nist.gov%7C9b6337b287ab499f0fe108d6fd69fa01%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C1%7C636975028952672491&sdata=p2eLCf%2FZ9zhLM3KkDfj6djp4nzl0AnbNa7TFftrmTFQ%3D&reserved=0>_______________________________________________
> sacm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sacm