Subject: [sacm] [sacmwg/draft-ietf-sacm-coswid] Missing hash description in resource-collection (#28)

From: Thomas Fossati <[email-masked]>
Date: Mon, 12 Oct 2020 08:20:22 -0700

There is no description of the `hash` entry in the `resource-collection` group (Section 2.9.2).  Also the CDDL in the same section does not define the `hash` code point.  It is probably better to keep all the relevant bits tightly packed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/28

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 28 Oct 2020 05:57:38 -0700

It is described in 2.9.1 just before resource-collection. This includes the "code point" and the definition of index 7.

Is your proposal to merge 2.9.1 into 2.9.2? At the moment, I think being next to each other could satisfy the requirement of "relevant bits are tightly packed".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/28#issuecomment-717914680

---

From: Thomas Fossati <[email-masked]>
Date: Thu, 29 Oct 2020 07:32:31 -0700

Currently the full information about hash is spread across three different sections - 2.9.1, 2.9.2 and 2.10.

> Is your proposal to merge 2.9.1 into 2.9.2? 

Yep, and also copy `hash = 7` from 2.10 into the "scoped" CDDL.

This is by no means a blocker or anything of that sort.  It's just a suggestion to make the document more easily consumable.  When I implemented it, I was going through each section and build the encoder/decoder from the description, and it all went great until I hit section 2.9.1 :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/28#issuecomment-718792537

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 29 Oct 2020 07:36:20 -0700

Well... it's hard to argue with that :-)

It's now on the list for the next authors meeting!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/28#issuecomment-718795104