Subject: [sacm] [sacmwg/draft-ietf-sacm-coswid] rel type should be int rather than uint (#31)

From: Thomas Fossati <[email-masked]>
Date: Wed, 14 Oct 2020 08:27:28 -0700

In the CDDL, `rel` is defined as:
```
$rel /= uint / text
```
but the textual description that follows allows negative values (for testing and use in closed environments).

So I guess it should instead say:
```
$rel /= int / text
```
or even
```
$rel /= -256..65535 / text
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/31

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 28 Oct 2020 05:39:25 -0700

Thank you!

'$rel /= -256..65535 / text'

sounds fine. Will be included in the next proposal.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/31#issuecomment-717905524