Subject: [sacm] [sacmwg/draft-ietf-sacm-coswid] What is the extension story around global-attributes? (#21)

From: Thomas Fossati <[email-masked]>
Date: Thu, 08 Oct 2020 09:46:53 -0700

The omnipresent `global-attributes` has an `any-attribute` sub-group with apparent unbounded freedom to pick a label.   AFAICS, this extension point is not governed by a registry or an allocation policy.  So it's not clear to me how do we plan to prevent clashes?

(Note that the SWID equivalent seems to be `BaseElement`'s `anyAttribute`, which has proper namespace separation.  The relevant SWID XSD comment says: _"Allows any undeclared attributes on any element as long as the attribute is placed in a different namespace."_)

Maybe I am just confused and it all works fine, but I think that the envisaged extension story around `global-attributes` needs to be made a bit clearer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/21

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 28 Oct 2020 06:26:27 -0700

Potentially addressed by #29.

But even "contained" in their own map, the any-attributes can never be validated and should be processed with care. The namespace checking for the any-attribute in the ISO XSD is set to lax, which allows for omission of a namespace.

The closest "equivalent" to "any-attributes that have their own schema and namespace" in CDDL is the definition of extension CDDL using the existing sockets. 

The closest "equivalent" to "any-attributes that have no schema or namespace" in CDDL is the use of the any-attribute (now augmented by the proposal to contain them in their own map).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/21#issuecomment-717931134

---

From: Thomas Fossati <[email-masked]>
Date: Fri, 30 Oct 2020 03:04:02 -0700

> The namespace checking for the any-attribute in the ISO XSD is set to lax, which allows for omission of a namespace.

"lax" only means that if the XML processor hasn't been able to retrieve the schema for validating the 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/21#issuecomment-719460548

---

From: Thomas Fossati <[email-masked]>
Date: Fri, 30 Oct 2020 03:04:03 -0700

Closed #21.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/21#event-3940455024

---

From: Thomas Fossati <[email-masked]>
Date: Fri, 30 Oct 2020 04:54:38 -0700

Reopened #21.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/21#event-3940853688

---

From: Thomas Fossati <[email-masked]>
Date: Fri, 30 Oct 2020 04:55:38 -0700

closed by accident, not sure what button got pushed... :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/21#issuecomment-719510287

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 30 Oct 2020 04:59:20 -0700

Which maps to using a placeholder namespace and never providing it. A machine will never be able to infer the difference and therefore - semantically and in consequence implementation-wise - lax breaks down to the expect-able worst case of: there will never be any kind of validation for this.

But I have to admit, I am approaching the problem a bit formally, as I am generating and validating XML... let's say rarely :-) 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/21#issuecomment-719511782