Subject: [sacm] [sacmwg/draft-ietf-sacm-coswid] wrong CDDL in global-attributes group definition (#25)

From: Thomas Fossati <[email-masked]>
Date: Fri, 09 Oct 2020 02:03:46 -0700

In section 2.5 `global-attributes` is defined as
```
   global-attributes = (
     ? lang,
     * any-attribute,
   )
```
Instead, it should be:
```
   global-attributes = (
     ? lang => text,
     * any-attribute,
   )
```
This kind of copy&paste error could be avoided by having one true CDDL source; an example [here](https://github.com/thomas-fossati/draft-psa-token/tree/master/cddl).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/25

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 28 Oct 2020 06:04:04 -0700

Breaking out CDDL should be automated - I absolute agree. There are mechanisms in place for younger I-Ds. I admit that I was too lazy to backport them here. And this is the consequence :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/25#issuecomment-717918250

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 28 Oct 2020 06:04:05 -0700

Closed #25.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/25#event-3931130313

---

From: cabo <[email-masked]>
Date: Wed, 28 Oct 2020 06:10:25 -0700

Please use {::include foo.cddl} and make sure these CDDL files build/validate (write a Makefile).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/25#issuecomment-717921783

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 28 Oct 2020 06:14:49 -0700

We currently use:

```
~~~ CDDL
<CODE BEGINS>
{::include concise-swid-tag.cddl}
<CODE ENDS>
~~~
```

But not for the exepositional CDDL fragments that are used to improve readability throughout the text. Using regexp here to extract fragments from the full CDDL usually helps. We did not do this here. The fragments used as examples are not intended to build/validate by their own.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/25#issuecomment-717924268

---

From: Henk Birkholz <[email-masked]>
Date: Wed, 28 Oct 2020 06:15:27 -0700

Reopened #25.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/25#event-3931183290