Subject: Re: [sacm] [sacmwg/draft-ietf-sacm-coswid] What is the extension story around global-attributes? (#21)

From: Henk Birkholz <[email-masked]>
Date: Mon, 22 Feb 2021 00:08:11 -0800

The summary we settled on and now reconfirmed is this:

While XML SWID require a namespace for extension for validation, they can be verified without a supplied XSD. This allows for un-verified portions of XML where no XSD can be acquired or _is defined_. We map this behavior via extension points that mandate a CDDL (analogous to XML namespace ##Other) and then allow for the any-attributes (analogous lax contentProcess and the XML any attribute).

An errata to XML SWID might come up in the future, but now we are sticking with similar expressiveness.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/21#issuecomment-783177956

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 22 Feb 2021 09:26:45 -0800

Closed #21.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/21#event-4360971552

---

From: Henk Birkholz <[email-masked]>
Date: Mon, 22 Feb 2021 09:26:44 -0800

We can resurrect this issue, if need be. For now I'll bury this in is:closed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-coswid/issues/21#issuecomment-783538052