Subject: Re: [sacm] [sacmwg/draft-ietf-sacm-arch] Define the method to describe capabilities (#20)

From: adammontville <[email-masked]>
Date: Thu, 04 Nov 2021 03:52:11 -0700

@wmunyan, in the above you wrote, "Devised a set...". Does that mean that you have a list of URNs that represent the capabilities defined somewhere, or did you mean that these URNs still need to be defined? If they exist somewhere, can you publish here so they can be added to the draft?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-arch/issues/20#issuecomment-960644923

---

From: bmunyan <[email-masked]>
Date: Thu, 04 Nov 2021 05:35:23 -0700

@adammontville anything i might have had/added was on a VM that became CIS property, so as a great replicant once said, it is now "lost in time, like tears in the rain"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-arch/issues/20#issuecomment-960818693

---

From: adammontville <[email-masked]>
Date: Thu, 04 Nov 2021 08:05:57 -0700

That's unfortunate. Do you have any recollection of what you did?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-arch/issues/20#issuecomment-961130449

---

From: bmunyan <[email-masked]>
Date: Thu, 04 Nov 2021 08:53:35 -0700

apart from the example above, not much.  i think the idea was to associate "capability urn's" to topic(s), but i feel like, during the "pre-the-previous-ietf" timeframe, i may have thought it was overkill to try and abstract specific topic names to the capability urn crap.

I feel like this was part of the component onboarding bits - some component registers with the manager and says "i can do 'foo'", and the manager replies with "because you can do 'foo', subscribe to these topics" -- it was a way to let components advertise what they do.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/sacmwg/draft-ietf-sacm-arch/issues/20#issuecomment-961177919