Subject: [salud] The new draft

From: "WORLEY, Dale R (Dale)" <[email-masked]>
Date: Thu, 22 Jul 2010 16:42:03 -0400

(as an individual)

I see the following open issues:

* I think we need to consolidate the list of requriemens.  We now have something like two pages of them, which seems excessive.

* There is still a big point of debate as to whether alert dimension values are combined by putting them in one URN or by using several URNsin one Alert-Info header.

The advantage of using one URN is that URNs can be interpreted individually, and the Alert-Info list is just a list of URNs, of which the UA can use any that it understands.

The advantage of using multiple URNs is that the set of URNs is small and fixed (except for extensions).

Note that in either case the logic and semantics of combining the values to determine an actual rendering is the same.

* We need some text describing the merging process, by which a set of dimension values is used to select one rendering.  Not a specification, but rather an exposition or sample implementation, to (1) prove that it can be done in a systematic and universal manner, and (2) to provide an example so that implementors do a reasonably good job, and especially, that will interoperate reasonably well.

* Extensibility.  We need to provide clearer guidance for extensibility, since we expect it to be used a lot, and in several different ways.  It would also be good to make the extension mechanism more terse than it is now.  I think we're fairly close to a good mechanism already, but we need to improve the syntax.

Dale

---

From: Laura Liess <[email-masked]>
Date: Fri, 23 Jul 2010 13:39:18 +0200

Dale thank you for your input.
Please see comments inline.

> * I think we need to consolidate the list of requriemens.  We now have something like two pages of them, which seems excessive.

Yes.
In my opinion, we have at least two requirements which are redundant
(REQ-5 and REQ 6), maybe there are more.
REQ-12 to REQ-15 are in principle the use cases. Do we need them in
both sections?

Some of the requirements may need text changes.

> * There is still a big point of debate as to whether alert dimension values are combined by putting them in one URN or by using several URNsin one Alert-Info header.

This is the key open issue we need to discuss face2face. We can not
make real progress until we have a decision on this issue. I hope we
can come to a consensus in Maastricht..

Thanks
Laura

>
> Dale
> _______________________________________________
> salud mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/salud
>

---

From: Laura Liess <[email-masked]>
Date: Fri, 23 Jul 2010 13:42:12 +0200

Dale,

I put together a first draft for the slides. Maybe we can meet in
Maastricht on Monday or Tuesday an go through them together?

Thanks
Laura