Subject: Re: [salud] Next steps for Alert-Info URN draft

From: Laura Liess <[email-masked]>
Date: Wed, 1 Jun 2011 15:57:10 +0200

Dale,

Please see inline.

>
> First, let us try to list all the open technical issues on the mailing list.
[LL] You are right.

 The issues that I know of are:
>
> - Shall we combine all the characteristics into one URN (leading to a very large set of possible URNs), or specify each characteristic in a separate URN (and have the UA combine them)?

[LL]  I will try to recapitulate the history of this subject and the
issues which were raised for both alternatives:
- In the initial draft in bliss we had some kind of single URN.
- Adam objected we have to register a very high number of URN with
IANA to cover all possible combinations.
- Additional issues with single URN: Intermediaries may want to insert
or  delete elements of the URN or add an URN. We need rules for this
(e.g. a proxy want to discard priority:high).
-  Paul came up with the multiple URN proposal and the values
definitions as currently described in Section 5.

Would we have advantages if  switching back to single URN? Even for
single URNs, we need combination/removal rules or rules for
inserting/removing parts of URNs in case intermediaries whant to
change the rendering at the receiving UA. And what do we handle the
number of IANA registrations?

>
> - In regard to extensibility, shall we arrange for each characteristic value to be subdividable into more narrowly-defined values, which are themselves subdividable, etc.?

[LL] I think they are. E.g.  we already defined
urn:alert:source:family. If there is a need to be more specific, we
can subdivide this into urn:alert:source:family.normal (or default, or
whatever) and urn:alert:source:family.children. Or maybe I did not
understand you correctly?

>
> - In regard to extensibility, what proprietary or non-standard extensions will be possible?
>
> - How will non-standard extensions be designated?  (Will they be consistently marked by a particular prefix?  Will they be constructed from domain names?)

[LL] We currently have private.<private-name> for every
alert-category.Maybe this is not enough?
>
> - How does the "legacy" URN <urn:alert:service:normal> fit into the new system?

[LL] I am not sure I understand what you mean with this. Change the
name "normal" by , e.g. "default"? Or is it  something else ?

[LL] These are also the issues I know about.
> Dale

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Mon, 6 Jun 2011 14:55:07 -0400

[as chair]

Hey, everybody!!!

So far, we have only 5 open technical issues listed.  Do they really cover everything
that is left to be done?

We don't need solution proposals right now, just to make sure we see the whole
landscape of problems.

Currently known problems:

Dale